%global _empty_manifest_terminate_build 0 Name: python-jupyterlab-git Version: 0.41.0 Release: 1 Summary: A JupyterLab extension for version control using git License: BSD-3-Clause URL: https://github.com/jupyterlab/jupyterlab-git Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d9/59/d2a2dceac873fe9de6cde6698db8ef5a434b5816fc5f720317befbd05f35/jupyterlab_git-0.41.0.tar.gz BuildArch: noarch Requires: python3-jupyter-server Requires: python3-nbdime Requires: python3-nbformat Requires: python3-packaging Requires: python3-pexpect Requires: python3-traitlets Requires: python3-black Requires: python3-coverage Requires: python3-jupyter-packaging Requires: python3-jupyterlab Requires: python3-pre-commit Requires: python3-pytest Requires: python3-pytest-asyncio Requires: python3-pytest-cov Requires: python3-pytest-jupyter[server] Requires: python3-black Requires: python3-coverage Requires: python3-jupyter-packaging Requires: python3-jupyterlab Requires: python3-pre-commit Requires: python3-pytest Requires: python3-pytest-asyncio Requires: python3-pytest-cov Requires: python3-pytest-jupyter[server] Requires: python3-hybridcontents Requires: python3-jupytext Requires: python3-black Requires: python3-coverage Requires: python3-jupyter-packaging Requires: python3-jupyterlab Requires: python3-pre-commit Requires: python3-pytest Requires: python3-pytest-asyncio Requires: python3-pytest-cov Requires: python3-pytest-jupyter[server] Requires: python3-hybridcontents Requires: python3-jupytext Requires: python3-jupyter-archive %description # jupyterlab-git [![Binder](https://mybinder.org/badge_logo.svg)](https://mybinder.org/v2/gh/jupyterlab/jupyterlab-git/master?urlpath=lab/tree/examples/demo.ipynb) [![Github Actions Status](https://github.com/jupyterlab/jupyterlab-git/workflows/Test/badge.svg)](https://github.com/jupyterlab/jupyterlab-git/actions?query=workflow%3ATest) [![Version](https://img.shields.io/npm/v/@jupyterlab/git.svg)](https://www.npmjs.com/package/@jupyterlab/git) [![Version](https://img.shields.io/pypi/v/jupyterlab-git.svg)](https://pypi.org/project/jupyterlab-git/) [![Downloads](https://img.shields.io/npm/dm/@jupyterlab/git.svg)](https://www.npmjs.com/package/@jupyterlab/git) [![Version](https://img.shields.io/conda/vn/conda-forge/jupyterlab-git.svg)](https://anaconda.org/conda-forge/jupyterlab-git) [![Downloads](https://img.shields.io/conda/dn/conda-forge/jupyterlab-git.svg)](https://anaconda.org/conda-forge/jupyterlab-git) [![All Contributors](https://img.shields.io/badge/all_contributors-27-orange.svg?style=flat-square)](#contributors-) A JupyterLab extension for version control using Git ![ui_glow_up](https://raw.githubusercontent.com/jupyterlab/jupyterlab-git/master/docs/figs/preview.gif) To see the extension in action, open the example notebook included in the Binder [demo](https://mybinder.org/v2/gh/jupyterlab/jupyterlab-git/master?urlpath=lab/tree/examples/demo.ipynb). ## Requirements - JupyterLab >= 3.0 ([older version](https://github.com/jupyterlab/jupyterlab-git/tree/jlab-2) available for 2.x) - Git (version `>=2.x`) ## Usage - Open the Git extension from the _Git_ tab on the left panel - [Set up authentication](#authentication-to-remote-repository-hosts) ## Install To install perform the following steps, with _pip_: ```bash pip install --upgrade jupyterlab jupyterlab-git ``` or with _conda_: ```bash conda install -c conda-forge jupyterlab jupyterlab-git ``` For JupyterLab < 3, you will need to run the following command after installing the package: ```bash jupyter lab build ``` ### Uninstall ```bash pip uninstall jupyterlab-git ``` or with _conda_: ```bash conda remove jupyterlab-git ``` For JupyterLab < 3, you will also need to run the following command after removing the Python package: ```bash jupyter labextension uninstall @jupyterlab/git ``` ## Settings ### Authentication to remote repository hosts If you are seeing errors similar to `[E yyyy-mm-dd hh:mm:ss ServerApp] 500 POST /git/` on the console which is running the JupyterLab server, you probably need to set up a credentials store for your local Git repository. This extension tries to handle credentials for HTTP(S) connections (if you don't have set up a credential manager). But not for other SSH connections. > For Windows users, it is recommended to install [git for windows](https://gitforwindows.org/). It will automatically set up a credential manager. > In order to connect to a remote host, it is recommended to use SSH. #### HTTP(S) protocol The extension can cache temporarily (by default for an hour) credentials. To use the caching, you will need to check the option _Save my login temporarily_ in the dialog asking your credentials. > You can set a longer cache timeout; see [Server Settings](#server-settings). > This is a new feature since v0.37.0 #### SSH protocol Here are the steps to follow to set up SSH authentication (skip any that is already accomplished for your project): 1. [Create a SSH key](https://docs.github.com/en/github/authenticating-to-github/connecting-to-github-with-ssh/generating-a-new-ssh-key-and-adding-it-to-the-ssh-agent) 2. Register the public part of it to your Git server: * [GitHub](https://docs.github.com/en/github/authenticating-to-github/connecting-to-github-with-ssh/adding-a-new-ssh-key-to-your-github-account) * [GitLab](https://docs.gitlab.com/ee/ssh/index.html#add-an-ssh-key-to-your-gitlab-account) 3. Optionally, if you have more than one key managed by your ssh agent: [Create a config file for the ssh-agent](https://stackoverflow.com/a/21938804) 4. Tell your local Git repository to [connect to remote via ssh](https://docs.github.com/en/get-started/getting-started-with-git/managing-remote-repositories#switching-remote-urls-from-https-to-ssh) You should now be able to pull and push committed changes to and from your remote repository using the respective buttons on the top of the extension's panel. ### UI Settings Once installed, extension behavior can be modified via the following settings which can be set in JupyterLab's advanced settings editor: - **blockWhileCommandExecutes**: suspend JupyterLab user interaction until Git commands (e.g., `commit`, `pull`, `reset`, `revert`) finish executing. Setting this to `true` helps mitigate potential race conditions leading to data loss, conflicts, and a broken Git history. Unless running a slow network, UI suspension should not interfere with standard workflows. Setting this to `false` allows for actions to trigger multiple concurrent Git actions. - **cancelPullMergeConflict**: cancel pulling changes from a remote repository if there exists a merge conflict. If set to `true`, when fetching and integrating changes from a remote repository, a conflicting merge is canceled and the working tree left untouched. - **commitAndPush**: Whether to trigger or not a push for each commit; default is `false`. - **disableBranchWithChanges**: disable all branch operations, such as creating a new branch or switching to a different branch, when there are changed/staged files. When set to `true`, this setting guards against overwriting and/or losing uncommitted changes. - **displayStatus**: display Git extension status updates in the JupyterLab status bar. If `true`, the extension displays status updates in the JupyterLab status bar, such as when pulling and pushing changes, switching branches, and polling for changes. Depending on the level of extension activity, some users may find the status updates distracting. In which case, setting this to `false` should reduce visual noise. - **doubleClickDiff**: double click a file in the Git extension panel to open a diff of the file instead of opening the file for editing. - **historyCount**: number of commits shown in the history log, beginning with the most recent. Displaying a larger number of commits can lead to performance degradation, so use caution when modifying this setting. - **refreshIfHidden**: whether to refresh even if the Git tab is hidden; default to `false` (i.e. refresh is turned off if the Git tab is hidden). - **refreshInterval**: number of milliseconds between polling the file system for changes. In order to ensure that the UI correctly displays the current repository status, the extension must poll the file system for changes. Longer polling times increase the likelihood that the UI does not reflect the current status; however, longer polling times also incur less performance overhead. - **simpleStaging**: enable a simplified concept of staging. When this setting is `true`, all files with changes are automatically staged. When we develop in JupyterLab, we often only care about what files have changed (in the broadest sense) and don't need to distinguish between "tracked" and "untracked" files. Accordingly, this setting allows us to simplify the visual presentation of changes, which is especially useful for those less acquainted with Git. ### Server Settings - `JupyterLabGit.actions.post_init`: Set post _git init_ actions. It is possible to provide a list of commands to be executed in a folder after it is initialized as Git repository. - `JupyterLabGit.credential_helper`: Git credential helper to set to cache the credentials. The default value is `cache --timeout=3600` to cache the credentials for an hour. If you want to cache them for 10 hours, set `cache --timeout=36000`. - `JupyterLabGit.excluded_paths`: Set path patterns to exclude from this extension. You can use wildcard and interrogation mark for respectively everything or any single character in the pattern.
How to set server settings? In `$HOME/.jupyter/jupyter_notebook_config.py` (on Windows `%USERPROFILE%/.jupyter/jupyter_notebook_config.py`): ```python c.JupyterLabGit.actions = {"post_init": ["touch dummy_init.dat"]} c.JupyterLabGit.credential_helper = 'cache --timeout=3600' ``` Or equivalently in `$HOME/.jupyter/jupyter_notebook_config.json` (on Windows `%USERPROFILE%/.jupyter/jupyter_notebook_config.json`): ```json { "JupyterLabGit": { "actions": { "post_init": ["touch dummy_init.dat"] }, "credential_helper": "cache --timeout=3600" } } ```
## Troubleshoot Before consulting the following list, be sure the `jupyterlab_git` server extension and the `@jupyterlab/git` frontend extension have the same version by executing the following commands: ```bash jupyter server extension list jupyter labextension list ``` If they do not match or one is missing, please [reinstall the package](README.md#Install).
the Git panel does not recognize that you are in a Git repository. Possible fixes: - Be sure to be in a Git repository in the filebrowser tab - Check the server log. If you see a warning with a 404 code similar to: `[W 00:27:41.800 LabApp] 404 GET /git/settings?version=0.20.0` Explicitly enable the server extension by running: ```bash jupyter server extension enable --py jupyterlab_git ``` - If you are using JupyterHub or some other technologies requiring an initialization script which includes the jupyterlab-git extension, be sure to install both the frontend and the server extension **before** launching JupyterLab.
the Git panel is not visible. Possible fixes: - Check that the JupyterLab extension is installed: ```bash jupyter labextension list ``` If you don't see `@jupyterlab/git v... enabled OK` in the list, explicitly install the jupyter labextension by running: ```bash jupyter labextension install @jupyterlab/git ``` If you see `@jupyterlab/git` under `Uninstalled core extensions: `, your installation may have been corrupted. You can run `jupyter lab clean --all` and reinstall all your extensions.
## Contributing If you would like to contribute to the project, please read our [contributor documentation](https://github.com/jupyterlab/jupyterlab/blob/master/CONTRIBUTING.md). JupyterLab follows the official [Jupyter Code of Conduct](https://github.com/jupyter/governance/blob/master/conduct/code_of_conduct.md). ### Development install Note: You will need NodeJS to build the extension package. The `jlpm` command is JupyterLab's pinned version of [yarn](https://yarnpkg.com/) that is installed with JupyterLab. You may use `yarn` or `npm` in lieu of `jlpm` below. ```bash # Clone the repo to your local environment git clone https://github.com/jupyterlab/jupyterlab-git.git # Change directory to the jupyterlab-git directory cd jupyterlab-git # Install package in development mode pip install -e ".[dev]" pre-commit install # Link your development version of the extension with JupyterLab jupyter labextension develop . --overwrite # Server extension must be manually installed in develop mode jupyter server extension enable jupyterlab_git # Rebuild extension Typescript source after making changes jlpm run build ``` You can watch the source directory and run JupyterLab at the same time in different terminals to watch for changes in the extension's source and automatically rebuild the extension. ```bash # Watch the source directory in one terminal, automatically rebuilding when needed jlpm run watch # Run JupyterLab in another terminal jupyter lab ``` With the watch command running, every saved change will immediately be built locally and available in your running JupyterLab. Refresh JupyterLab to load the change in your browser (you may need to wait several seconds for the extension to be rebuilt). By default, the `jlpm run build` command generates the source maps for this extension to make it easier to debug using the browser dev tools. To also generate source maps for the JupyterLab core extensions, you can run the following command: ```bash jupyter lab build --minimize=False ``` To execute the tests ```bash pytest jupyterlab_git jlpm run test ``` ## Contributors ✨ The Jupyter Git extension is part of [Project Jupyter](http://jupyter.org/) and is developed by an open community of contributors. To see who has been active recently, please look at the ["Contributors"](https://github.com/jupyterlab/jupyterlab-git/graphs/contributors) tab. Below we list the people and entities who contributed in different ways to the project ([emoji key](https://allcontributors.org/docs/en/emoji-key)):
Amazon Web Services
Amazon Web Services

🀝
Ashutosh Bondre
Ashutosh Bondre

πŸ’» πŸ‘€
Athan
Athan

πŸ’» πŸ‘€ πŸ“† 🎨
Bosco Chan
Bosco Chan

πŸ’»
Brian E. Granger
Brian E. Granger

πŸ“† 🎨 πŸ€” πŸ”
Daman Arora
Daman Arora

πŸ’»
Dat Quach
Dat Quach

πŸ’»
FrΓ©dΓ©ric Collonval
FrΓ©dΓ©ric Collonval

🚧
Hana Zarea
Hana Zarea

πŸ’» πŸ‘€
Ian Hunt-Isaak
Ian Hunt-Isaak

πŸ’» πŸ‘€
Jaipreet Singh
Jaipreet Singh

πŸ“† πŸ‘€ πŸ’» 🎨
Ji Zhang
Ji Zhang

πŸ’» πŸ‘€
Konstantin Taletskiy
Konstantin Taletskiy

πŸ’» πŸ‘€
Kostya Farber
Kostya Farber

πŸ’»
Linda Ngoc Nguyen
Linda Ngoc Nguyen

πŸ’»
Major League Hacking
Major League Hacking

🀝
Max Klein
Max Klein

πŸ’» πŸ‘€ πŸ“† 🎨 πŸš‡
MichaΕ‚ Krassowski
MichaΕ‚ Krassowski

πŸ’» πŸ‘€ πŸ›
Navinn Ravindaran
Navinn Ravindaran

πŸ’»
Neelam Gehlot
Neelam Gehlot

πŸ’» πŸ‘€
Noah Stapp
Noah Stapp

πŸ’» πŸ‘€
Saul Shanabrook
Saul Shanabrook

πŸ’» πŸ“† πŸ‘€ πŸš‡
Sheeza Aziz
Sheeza Aziz

πŸ’»
Sina Khalili
Sina Khalili

πŸ’»
The D. E. Shaw Group
The D. E. Shaw Group

🀝
Zeshan Fayyaz
Zeshan Fayyaz

πŸ’»
jupytercalpoly
jupytercalpoly

🀝
This project follows the [all-contributors](https://github.com/all-contributors/all-contributors) specification. Contributions of any kind are welcomed! To add yourself, or someone else, to this list you can either [use the bot](https://allcontributors.org/docs/en/bot/usage) (`@all-contributors please add for `) or [the CLI](https://allcontributors.org/docs/en/cli/usage) (`jlpm all-contributors add `). If you manually edit the `.all-contributorsrc` config file, run `yarn run contributors:generate`. %package -n python3-jupyterlab-git Summary: A JupyterLab extension for version control using git Provides: python-jupyterlab-git BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-jupyterlab-git # jupyterlab-git [![Binder](https://mybinder.org/badge_logo.svg)](https://mybinder.org/v2/gh/jupyterlab/jupyterlab-git/master?urlpath=lab/tree/examples/demo.ipynb) [![Github Actions Status](https://github.com/jupyterlab/jupyterlab-git/workflows/Test/badge.svg)](https://github.com/jupyterlab/jupyterlab-git/actions?query=workflow%3ATest) [![Version](https://img.shields.io/npm/v/@jupyterlab/git.svg)](https://www.npmjs.com/package/@jupyterlab/git) [![Version](https://img.shields.io/pypi/v/jupyterlab-git.svg)](https://pypi.org/project/jupyterlab-git/) [![Downloads](https://img.shields.io/npm/dm/@jupyterlab/git.svg)](https://www.npmjs.com/package/@jupyterlab/git) [![Version](https://img.shields.io/conda/vn/conda-forge/jupyterlab-git.svg)](https://anaconda.org/conda-forge/jupyterlab-git) [![Downloads](https://img.shields.io/conda/dn/conda-forge/jupyterlab-git.svg)](https://anaconda.org/conda-forge/jupyterlab-git) [![All Contributors](https://img.shields.io/badge/all_contributors-27-orange.svg?style=flat-square)](#contributors-) A JupyterLab extension for version control using Git ![ui_glow_up](https://raw.githubusercontent.com/jupyterlab/jupyterlab-git/master/docs/figs/preview.gif) To see the extension in action, open the example notebook included in the Binder [demo](https://mybinder.org/v2/gh/jupyterlab/jupyterlab-git/master?urlpath=lab/tree/examples/demo.ipynb). ## Requirements - JupyterLab >= 3.0 ([older version](https://github.com/jupyterlab/jupyterlab-git/tree/jlab-2) available for 2.x) - Git (version `>=2.x`) ## Usage - Open the Git extension from the _Git_ tab on the left panel - [Set up authentication](#authentication-to-remote-repository-hosts) ## Install To install perform the following steps, with _pip_: ```bash pip install --upgrade jupyterlab jupyterlab-git ``` or with _conda_: ```bash conda install -c conda-forge jupyterlab jupyterlab-git ``` For JupyterLab < 3, you will need to run the following command after installing the package: ```bash jupyter lab build ``` ### Uninstall ```bash pip uninstall jupyterlab-git ``` or with _conda_: ```bash conda remove jupyterlab-git ``` For JupyterLab < 3, you will also need to run the following command after removing the Python package: ```bash jupyter labextension uninstall @jupyterlab/git ``` ## Settings ### Authentication to remote repository hosts If you are seeing errors similar to `[E yyyy-mm-dd hh:mm:ss ServerApp] 500 POST /git/` on the console which is running the JupyterLab server, you probably need to set up a credentials store for your local Git repository. This extension tries to handle credentials for HTTP(S) connections (if you don't have set up a credential manager). But not for other SSH connections. > For Windows users, it is recommended to install [git for windows](https://gitforwindows.org/). It will automatically set up a credential manager. > In order to connect to a remote host, it is recommended to use SSH. #### HTTP(S) protocol The extension can cache temporarily (by default for an hour) credentials. To use the caching, you will need to check the option _Save my login temporarily_ in the dialog asking your credentials. > You can set a longer cache timeout; see [Server Settings](#server-settings). > This is a new feature since v0.37.0 #### SSH protocol Here are the steps to follow to set up SSH authentication (skip any that is already accomplished for your project): 1. [Create a SSH key](https://docs.github.com/en/github/authenticating-to-github/connecting-to-github-with-ssh/generating-a-new-ssh-key-and-adding-it-to-the-ssh-agent) 2. Register the public part of it to your Git server: * [GitHub](https://docs.github.com/en/github/authenticating-to-github/connecting-to-github-with-ssh/adding-a-new-ssh-key-to-your-github-account) * [GitLab](https://docs.gitlab.com/ee/ssh/index.html#add-an-ssh-key-to-your-gitlab-account) 3. Optionally, if you have more than one key managed by your ssh agent: [Create a config file for the ssh-agent](https://stackoverflow.com/a/21938804) 4. Tell your local Git repository to [connect to remote via ssh](https://docs.github.com/en/get-started/getting-started-with-git/managing-remote-repositories#switching-remote-urls-from-https-to-ssh) You should now be able to pull and push committed changes to and from your remote repository using the respective buttons on the top of the extension's panel. ### UI Settings Once installed, extension behavior can be modified via the following settings which can be set in JupyterLab's advanced settings editor: - **blockWhileCommandExecutes**: suspend JupyterLab user interaction until Git commands (e.g., `commit`, `pull`, `reset`, `revert`) finish executing. Setting this to `true` helps mitigate potential race conditions leading to data loss, conflicts, and a broken Git history. Unless running a slow network, UI suspension should not interfere with standard workflows. Setting this to `false` allows for actions to trigger multiple concurrent Git actions. - **cancelPullMergeConflict**: cancel pulling changes from a remote repository if there exists a merge conflict. If set to `true`, when fetching and integrating changes from a remote repository, a conflicting merge is canceled and the working tree left untouched. - **commitAndPush**: Whether to trigger or not a push for each commit; default is `false`. - **disableBranchWithChanges**: disable all branch operations, such as creating a new branch or switching to a different branch, when there are changed/staged files. When set to `true`, this setting guards against overwriting and/or losing uncommitted changes. - **displayStatus**: display Git extension status updates in the JupyterLab status bar. If `true`, the extension displays status updates in the JupyterLab status bar, such as when pulling and pushing changes, switching branches, and polling for changes. Depending on the level of extension activity, some users may find the status updates distracting. In which case, setting this to `false` should reduce visual noise. - **doubleClickDiff**: double click a file in the Git extension panel to open a diff of the file instead of opening the file for editing. - **historyCount**: number of commits shown in the history log, beginning with the most recent. Displaying a larger number of commits can lead to performance degradation, so use caution when modifying this setting. - **refreshIfHidden**: whether to refresh even if the Git tab is hidden; default to `false` (i.e. refresh is turned off if the Git tab is hidden). - **refreshInterval**: number of milliseconds between polling the file system for changes. In order to ensure that the UI correctly displays the current repository status, the extension must poll the file system for changes. Longer polling times increase the likelihood that the UI does not reflect the current status; however, longer polling times also incur less performance overhead. - **simpleStaging**: enable a simplified concept of staging. When this setting is `true`, all files with changes are automatically staged. When we develop in JupyterLab, we often only care about what files have changed (in the broadest sense) and don't need to distinguish between "tracked" and "untracked" files. Accordingly, this setting allows us to simplify the visual presentation of changes, which is especially useful for those less acquainted with Git. ### Server Settings - `JupyterLabGit.actions.post_init`: Set post _git init_ actions. It is possible to provide a list of commands to be executed in a folder after it is initialized as Git repository. - `JupyterLabGit.credential_helper`: Git credential helper to set to cache the credentials. The default value is `cache --timeout=3600` to cache the credentials for an hour. If you want to cache them for 10 hours, set `cache --timeout=36000`. - `JupyterLabGit.excluded_paths`: Set path patterns to exclude from this extension. You can use wildcard and interrogation mark for respectively everything or any single character in the pattern.
How to set server settings? In `$HOME/.jupyter/jupyter_notebook_config.py` (on Windows `%USERPROFILE%/.jupyter/jupyter_notebook_config.py`): ```python c.JupyterLabGit.actions = {"post_init": ["touch dummy_init.dat"]} c.JupyterLabGit.credential_helper = 'cache --timeout=3600' ``` Or equivalently in `$HOME/.jupyter/jupyter_notebook_config.json` (on Windows `%USERPROFILE%/.jupyter/jupyter_notebook_config.json`): ```json { "JupyterLabGit": { "actions": { "post_init": ["touch dummy_init.dat"] }, "credential_helper": "cache --timeout=3600" } } ```
## Troubleshoot Before consulting the following list, be sure the `jupyterlab_git` server extension and the `@jupyterlab/git` frontend extension have the same version by executing the following commands: ```bash jupyter server extension list jupyter labextension list ``` If they do not match or one is missing, please [reinstall the package](README.md#Install).
the Git panel does not recognize that you are in a Git repository. Possible fixes: - Be sure to be in a Git repository in the filebrowser tab - Check the server log. If you see a warning with a 404 code similar to: `[W 00:27:41.800 LabApp] 404 GET /git/settings?version=0.20.0` Explicitly enable the server extension by running: ```bash jupyter server extension enable --py jupyterlab_git ``` - If you are using JupyterHub or some other technologies requiring an initialization script which includes the jupyterlab-git extension, be sure to install both the frontend and the server extension **before** launching JupyterLab.
the Git panel is not visible. Possible fixes: - Check that the JupyterLab extension is installed: ```bash jupyter labextension list ``` If you don't see `@jupyterlab/git v... enabled OK` in the list, explicitly install the jupyter labextension by running: ```bash jupyter labextension install @jupyterlab/git ``` If you see `@jupyterlab/git` under `Uninstalled core extensions: `, your installation may have been corrupted. You can run `jupyter lab clean --all` and reinstall all your extensions.
## Contributing If you would like to contribute to the project, please read our [contributor documentation](https://github.com/jupyterlab/jupyterlab/blob/master/CONTRIBUTING.md). JupyterLab follows the official [Jupyter Code of Conduct](https://github.com/jupyter/governance/blob/master/conduct/code_of_conduct.md). ### Development install Note: You will need NodeJS to build the extension package. The `jlpm` command is JupyterLab's pinned version of [yarn](https://yarnpkg.com/) that is installed with JupyterLab. You may use `yarn` or `npm` in lieu of `jlpm` below. ```bash # Clone the repo to your local environment git clone https://github.com/jupyterlab/jupyterlab-git.git # Change directory to the jupyterlab-git directory cd jupyterlab-git # Install package in development mode pip install -e ".[dev]" pre-commit install # Link your development version of the extension with JupyterLab jupyter labextension develop . --overwrite # Server extension must be manually installed in develop mode jupyter server extension enable jupyterlab_git # Rebuild extension Typescript source after making changes jlpm run build ``` You can watch the source directory and run JupyterLab at the same time in different terminals to watch for changes in the extension's source and automatically rebuild the extension. ```bash # Watch the source directory in one terminal, automatically rebuilding when needed jlpm run watch # Run JupyterLab in another terminal jupyter lab ``` With the watch command running, every saved change will immediately be built locally and available in your running JupyterLab. Refresh JupyterLab to load the change in your browser (you may need to wait several seconds for the extension to be rebuilt). By default, the `jlpm run build` command generates the source maps for this extension to make it easier to debug using the browser dev tools. To also generate source maps for the JupyterLab core extensions, you can run the following command: ```bash jupyter lab build --minimize=False ``` To execute the tests ```bash pytest jupyterlab_git jlpm run test ``` ## Contributors ✨ The Jupyter Git extension is part of [Project Jupyter](http://jupyter.org/) and is developed by an open community of contributors. To see who has been active recently, please look at the ["Contributors"](https://github.com/jupyterlab/jupyterlab-git/graphs/contributors) tab. Below we list the people and entities who contributed in different ways to the project ([emoji key](https://allcontributors.org/docs/en/emoji-key)):
Amazon Web Services
Amazon Web Services

🀝
Ashutosh Bondre
Ashutosh Bondre

πŸ’» πŸ‘€
Athan
Athan

πŸ’» πŸ‘€ πŸ“† 🎨
Bosco Chan
Bosco Chan

πŸ’»
Brian E. Granger
Brian E. Granger

πŸ“† 🎨 πŸ€” πŸ”
Daman Arora
Daman Arora

πŸ’»
Dat Quach
Dat Quach

πŸ’»
FrΓ©dΓ©ric Collonval
FrΓ©dΓ©ric Collonval

🚧
Hana Zarea
Hana Zarea

πŸ’» πŸ‘€
Ian Hunt-Isaak
Ian Hunt-Isaak

πŸ’» πŸ‘€
Jaipreet Singh
Jaipreet Singh

πŸ“† πŸ‘€ πŸ’» 🎨
Ji Zhang
Ji Zhang

πŸ’» πŸ‘€
Konstantin Taletskiy
Konstantin Taletskiy

πŸ’» πŸ‘€
Kostya Farber
Kostya Farber

πŸ’»
Linda Ngoc Nguyen
Linda Ngoc Nguyen

πŸ’»
Major League Hacking
Major League Hacking

🀝
Max Klein
Max Klein

πŸ’» πŸ‘€ πŸ“† 🎨 πŸš‡
MichaΕ‚ Krassowski
MichaΕ‚ Krassowski

πŸ’» πŸ‘€ πŸ›
Navinn Ravindaran
Navinn Ravindaran

πŸ’»
Neelam Gehlot
Neelam Gehlot

πŸ’» πŸ‘€
Noah Stapp
Noah Stapp

πŸ’» πŸ‘€
Saul Shanabrook
Saul Shanabrook

πŸ’» πŸ“† πŸ‘€ πŸš‡
Sheeza Aziz
Sheeza Aziz

πŸ’»
Sina Khalili
Sina Khalili

πŸ’»
The D. E. Shaw Group
The D. E. Shaw Group

🀝
Zeshan Fayyaz
Zeshan Fayyaz

πŸ’»
jupytercalpoly
jupytercalpoly

🀝
This project follows the [all-contributors](https://github.com/all-contributors/all-contributors) specification. Contributions of any kind are welcomed! To add yourself, or someone else, to this list you can either [use the bot](https://allcontributors.org/docs/en/bot/usage) (`@all-contributors please add for `) or [the CLI](https://allcontributors.org/docs/en/cli/usage) (`jlpm all-contributors add `). If you manually edit the `.all-contributorsrc` config file, run `yarn run contributors:generate`. %package help Summary: Development documents and examples for jupyterlab-git Provides: python3-jupyterlab-git-doc %description help # jupyterlab-git [![Binder](https://mybinder.org/badge_logo.svg)](https://mybinder.org/v2/gh/jupyterlab/jupyterlab-git/master?urlpath=lab/tree/examples/demo.ipynb) [![Github Actions Status](https://github.com/jupyterlab/jupyterlab-git/workflows/Test/badge.svg)](https://github.com/jupyterlab/jupyterlab-git/actions?query=workflow%3ATest) [![Version](https://img.shields.io/npm/v/@jupyterlab/git.svg)](https://www.npmjs.com/package/@jupyterlab/git) [![Version](https://img.shields.io/pypi/v/jupyterlab-git.svg)](https://pypi.org/project/jupyterlab-git/) [![Downloads](https://img.shields.io/npm/dm/@jupyterlab/git.svg)](https://www.npmjs.com/package/@jupyterlab/git) [![Version](https://img.shields.io/conda/vn/conda-forge/jupyterlab-git.svg)](https://anaconda.org/conda-forge/jupyterlab-git) [![Downloads](https://img.shields.io/conda/dn/conda-forge/jupyterlab-git.svg)](https://anaconda.org/conda-forge/jupyterlab-git) [![All Contributors](https://img.shields.io/badge/all_contributors-27-orange.svg?style=flat-square)](#contributors-) A JupyterLab extension for version control using Git ![ui_glow_up](https://raw.githubusercontent.com/jupyterlab/jupyterlab-git/master/docs/figs/preview.gif) To see the extension in action, open the example notebook included in the Binder [demo](https://mybinder.org/v2/gh/jupyterlab/jupyterlab-git/master?urlpath=lab/tree/examples/demo.ipynb). ## Requirements - JupyterLab >= 3.0 ([older version](https://github.com/jupyterlab/jupyterlab-git/tree/jlab-2) available for 2.x) - Git (version `>=2.x`) ## Usage - Open the Git extension from the _Git_ tab on the left panel - [Set up authentication](#authentication-to-remote-repository-hosts) ## Install To install perform the following steps, with _pip_: ```bash pip install --upgrade jupyterlab jupyterlab-git ``` or with _conda_: ```bash conda install -c conda-forge jupyterlab jupyterlab-git ``` For JupyterLab < 3, you will need to run the following command after installing the package: ```bash jupyter lab build ``` ### Uninstall ```bash pip uninstall jupyterlab-git ``` or with _conda_: ```bash conda remove jupyterlab-git ``` For JupyterLab < 3, you will also need to run the following command after removing the Python package: ```bash jupyter labextension uninstall @jupyterlab/git ``` ## Settings ### Authentication to remote repository hosts If you are seeing errors similar to `[E yyyy-mm-dd hh:mm:ss ServerApp] 500 POST /git/` on the console which is running the JupyterLab server, you probably need to set up a credentials store for your local Git repository. This extension tries to handle credentials for HTTP(S) connections (if you don't have set up a credential manager). But not for other SSH connections. > For Windows users, it is recommended to install [git for windows](https://gitforwindows.org/). It will automatically set up a credential manager. > In order to connect to a remote host, it is recommended to use SSH. #### HTTP(S) protocol The extension can cache temporarily (by default for an hour) credentials. To use the caching, you will need to check the option _Save my login temporarily_ in the dialog asking your credentials. > You can set a longer cache timeout; see [Server Settings](#server-settings). > This is a new feature since v0.37.0 #### SSH protocol Here are the steps to follow to set up SSH authentication (skip any that is already accomplished for your project): 1. [Create a SSH key](https://docs.github.com/en/github/authenticating-to-github/connecting-to-github-with-ssh/generating-a-new-ssh-key-and-adding-it-to-the-ssh-agent) 2. Register the public part of it to your Git server: * [GitHub](https://docs.github.com/en/github/authenticating-to-github/connecting-to-github-with-ssh/adding-a-new-ssh-key-to-your-github-account) * [GitLab](https://docs.gitlab.com/ee/ssh/index.html#add-an-ssh-key-to-your-gitlab-account) 3. Optionally, if you have more than one key managed by your ssh agent: [Create a config file for the ssh-agent](https://stackoverflow.com/a/21938804) 4. Tell your local Git repository to [connect to remote via ssh](https://docs.github.com/en/get-started/getting-started-with-git/managing-remote-repositories#switching-remote-urls-from-https-to-ssh) You should now be able to pull and push committed changes to and from your remote repository using the respective buttons on the top of the extension's panel. ### UI Settings Once installed, extension behavior can be modified via the following settings which can be set in JupyterLab's advanced settings editor: - **blockWhileCommandExecutes**: suspend JupyterLab user interaction until Git commands (e.g., `commit`, `pull`, `reset`, `revert`) finish executing. Setting this to `true` helps mitigate potential race conditions leading to data loss, conflicts, and a broken Git history. Unless running a slow network, UI suspension should not interfere with standard workflows. Setting this to `false` allows for actions to trigger multiple concurrent Git actions. - **cancelPullMergeConflict**: cancel pulling changes from a remote repository if there exists a merge conflict. If set to `true`, when fetching and integrating changes from a remote repository, a conflicting merge is canceled and the working tree left untouched. - **commitAndPush**: Whether to trigger or not a push for each commit; default is `false`. - **disableBranchWithChanges**: disable all branch operations, such as creating a new branch or switching to a different branch, when there are changed/staged files. When set to `true`, this setting guards against overwriting and/or losing uncommitted changes. - **displayStatus**: display Git extension status updates in the JupyterLab status bar. If `true`, the extension displays status updates in the JupyterLab status bar, such as when pulling and pushing changes, switching branches, and polling for changes. Depending on the level of extension activity, some users may find the status updates distracting. In which case, setting this to `false` should reduce visual noise. - **doubleClickDiff**: double click a file in the Git extension panel to open a diff of the file instead of opening the file for editing. - **historyCount**: number of commits shown in the history log, beginning with the most recent. Displaying a larger number of commits can lead to performance degradation, so use caution when modifying this setting. - **refreshIfHidden**: whether to refresh even if the Git tab is hidden; default to `false` (i.e. refresh is turned off if the Git tab is hidden). - **refreshInterval**: number of milliseconds between polling the file system for changes. In order to ensure that the UI correctly displays the current repository status, the extension must poll the file system for changes. Longer polling times increase the likelihood that the UI does not reflect the current status; however, longer polling times also incur less performance overhead. - **simpleStaging**: enable a simplified concept of staging. When this setting is `true`, all files with changes are automatically staged. When we develop in JupyterLab, we often only care about what files have changed (in the broadest sense) and don't need to distinguish between "tracked" and "untracked" files. Accordingly, this setting allows us to simplify the visual presentation of changes, which is especially useful for those less acquainted with Git. ### Server Settings - `JupyterLabGit.actions.post_init`: Set post _git init_ actions. It is possible to provide a list of commands to be executed in a folder after it is initialized as Git repository. - `JupyterLabGit.credential_helper`: Git credential helper to set to cache the credentials. The default value is `cache --timeout=3600` to cache the credentials for an hour. If you want to cache them for 10 hours, set `cache --timeout=36000`. - `JupyterLabGit.excluded_paths`: Set path patterns to exclude from this extension. You can use wildcard and interrogation mark for respectively everything or any single character in the pattern.
How to set server settings? In `$HOME/.jupyter/jupyter_notebook_config.py` (on Windows `%USERPROFILE%/.jupyter/jupyter_notebook_config.py`): ```python c.JupyterLabGit.actions = {"post_init": ["touch dummy_init.dat"]} c.JupyterLabGit.credential_helper = 'cache --timeout=3600' ``` Or equivalently in `$HOME/.jupyter/jupyter_notebook_config.json` (on Windows `%USERPROFILE%/.jupyter/jupyter_notebook_config.json`): ```json { "JupyterLabGit": { "actions": { "post_init": ["touch dummy_init.dat"] }, "credential_helper": "cache --timeout=3600" } } ```
## Troubleshoot Before consulting the following list, be sure the `jupyterlab_git` server extension and the `@jupyterlab/git` frontend extension have the same version by executing the following commands: ```bash jupyter server extension list jupyter labextension list ``` If they do not match or one is missing, please [reinstall the package](README.md#Install).
the Git panel does not recognize that you are in a Git repository. Possible fixes: - Be sure to be in a Git repository in the filebrowser tab - Check the server log. If you see a warning with a 404 code similar to: `[W 00:27:41.800 LabApp] 404 GET /git/settings?version=0.20.0` Explicitly enable the server extension by running: ```bash jupyter server extension enable --py jupyterlab_git ``` - If you are using JupyterHub or some other technologies requiring an initialization script which includes the jupyterlab-git extension, be sure to install both the frontend and the server extension **before** launching JupyterLab.
the Git panel is not visible. Possible fixes: - Check that the JupyterLab extension is installed: ```bash jupyter labextension list ``` If you don't see `@jupyterlab/git v... enabled OK` in the list, explicitly install the jupyter labextension by running: ```bash jupyter labextension install @jupyterlab/git ``` If you see `@jupyterlab/git` under `Uninstalled core extensions: `, your installation may have been corrupted. You can run `jupyter lab clean --all` and reinstall all your extensions.
## Contributing If you would like to contribute to the project, please read our [contributor documentation](https://github.com/jupyterlab/jupyterlab/blob/master/CONTRIBUTING.md). JupyterLab follows the official [Jupyter Code of Conduct](https://github.com/jupyter/governance/blob/master/conduct/code_of_conduct.md). ### Development install Note: You will need NodeJS to build the extension package. The `jlpm` command is JupyterLab's pinned version of [yarn](https://yarnpkg.com/) that is installed with JupyterLab. You may use `yarn` or `npm` in lieu of `jlpm` below. ```bash # Clone the repo to your local environment git clone https://github.com/jupyterlab/jupyterlab-git.git # Change directory to the jupyterlab-git directory cd jupyterlab-git # Install package in development mode pip install -e ".[dev]" pre-commit install # Link your development version of the extension with JupyterLab jupyter labextension develop . --overwrite # Server extension must be manually installed in develop mode jupyter server extension enable jupyterlab_git # Rebuild extension Typescript source after making changes jlpm run build ``` You can watch the source directory and run JupyterLab at the same time in different terminals to watch for changes in the extension's source and automatically rebuild the extension. ```bash # Watch the source directory in one terminal, automatically rebuilding when needed jlpm run watch # Run JupyterLab in another terminal jupyter lab ``` With the watch command running, every saved change will immediately be built locally and available in your running JupyterLab. Refresh JupyterLab to load the change in your browser (you may need to wait several seconds for the extension to be rebuilt). By default, the `jlpm run build` command generates the source maps for this extension to make it easier to debug using the browser dev tools. To also generate source maps for the JupyterLab core extensions, you can run the following command: ```bash jupyter lab build --minimize=False ``` To execute the tests ```bash pytest jupyterlab_git jlpm run test ``` ## Contributors ✨ The Jupyter Git extension is part of [Project Jupyter](http://jupyter.org/) and is developed by an open community of contributors. To see who has been active recently, please look at the ["Contributors"](https://github.com/jupyterlab/jupyterlab-git/graphs/contributors) tab. Below we list the people and entities who contributed in different ways to the project ([emoji key](https://allcontributors.org/docs/en/emoji-key)):
Amazon Web Services
Amazon Web Services

🀝
Ashutosh Bondre
Ashutosh Bondre

πŸ’» πŸ‘€
Athan
Athan

πŸ’» πŸ‘€ πŸ“† 🎨
Bosco Chan
Bosco Chan

πŸ’»
Brian E. Granger
Brian E. Granger

πŸ“† 🎨 πŸ€” πŸ”
Daman Arora
Daman Arora

πŸ’»
Dat Quach
Dat Quach

πŸ’»
FrΓ©dΓ©ric Collonval
FrΓ©dΓ©ric Collonval

🚧
Hana Zarea
Hana Zarea

πŸ’» πŸ‘€
Ian Hunt-Isaak
Ian Hunt-Isaak

πŸ’» πŸ‘€
Jaipreet Singh
Jaipreet Singh

πŸ“† πŸ‘€ πŸ’» 🎨
Ji Zhang
Ji Zhang

πŸ’» πŸ‘€
Konstantin Taletskiy
Konstantin Taletskiy

πŸ’» πŸ‘€
Kostya Farber
Kostya Farber

πŸ’»
Linda Ngoc Nguyen
Linda Ngoc Nguyen

πŸ’»
Major League Hacking
Major League Hacking

🀝
Max Klein
Max Klein

πŸ’» πŸ‘€ πŸ“† 🎨 πŸš‡
MichaΕ‚ Krassowski
MichaΕ‚ Krassowski

πŸ’» πŸ‘€ πŸ›
Navinn Ravindaran
Navinn Ravindaran

πŸ’»
Neelam Gehlot
Neelam Gehlot

πŸ’» πŸ‘€
Noah Stapp
Noah Stapp

πŸ’» πŸ‘€
Saul Shanabrook
Saul Shanabrook

πŸ’» πŸ“† πŸ‘€ πŸš‡
Sheeza Aziz
Sheeza Aziz

πŸ’»
Sina Khalili
Sina Khalili

πŸ’»
The D. E. Shaw Group
The D. E. Shaw Group

🀝
Zeshan Fayyaz
Zeshan Fayyaz

πŸ’»
jupytercalpoly
jupytercalpoly

🀝
This project follows the [all-contributors](https://github.com/all-contributors/all-contributors) specification. Contributions of any kind are welcomed! To add yourself, or someone else, to this list you can either [use the bot](https://allcontributors.org/docs/en/bot/usage) (`@all-contributors please add for `) or [the CLI](https://allcontributors.org/docs/en/cli/usage) (`jlpm all-contributors add `). If you manually edit the `.all-contributorsrc` config file, run `yarn run contributors:generate`. %prep %autosetup -n jupyterlab-git-0.41.0 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-jupyterlab-git -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Fri Apr 21 2023 Python_Bot - 0.41.0-1 - Package Spec generated