%global _empty_manifest_terminate_build 0
Name: python-ffmpy
Version: 0.3.0
Release: 1
Summary: A simple Python wrapper for ffmpeg
License: MIT
URL: https://github.com/Ch00k/ffmpy
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/bf/e2/947df4b3d666bfdd2b0c6355d215c45d2d40f929451cb29a8a2995b29788/ffmpy-0.3.0.tar.gz
BuildArch: noarch
%description
ffmpy is a simplistic `FFmpeg `_ command line wrapper. It implements a Pythonic interface for FFmpeg command line compilation and uses Python `subprocess `_ module to execute compiled command line.
%package -n python3-ffmpy
Summary: A simple Python wrapper for ffmpeg
Provides: python-ffmpy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-ffmpy
ffmpy is a simplistic `FFmpeg `_ command line wrapper. It implements a Pythonic interface for FFmpeg command line compilation and uses Python `subprocess `_ module to execute compiled command line.
%package help
Summary: Development documents and examples for ffmpy
Provides: python3-ffmpy-doc
%description help
ffmpy is a simplistic `FFmpeg `_ command line wrapper. It implements a Pythonic interface for FFmpeg command line compilation and uses Python `subprocess `_ module to execute compiled command line.
%prep
%autosetup -n ffmpy-0.3.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-ffmpy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 0.3.0-1
- Package Spec generated