%global _empty_manifest_terminate_build 0
Name: python-jplephem
Version: 2.18
Release: 1
Summary: Use a JPL ephemeris to predict planet positions.
License: MIT
URL: https://github.com/brandon-rhodes/python-jplephem/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/fe/19/94e96d1283e9b1aa1c0911f03a38226ed28bad420e3c80c2bcbc6102af38/jplephem-2.18.tar.gz
BuildArch: noarch
%description
The only third-party package that ``jplephem`` depends on is `NumPy
`_, which ``pip`` will automatically attempt to
install alongside ``pyephem`` when you run::
$ pip install jplephem
If you see NumPy compilation errors, then try downloading and installing
NumPy directly from `its web site `_ or simply
use a distribution of Python with science tools already installed, like
`Anaconda `_.
Note that ``jplephem`` offers only the logic necessary to produce plain
three-dimensional vectors. Most programmers interested in astronomy
will want to look at `Skyfield `_
instead, which uses ``jplephem`` but converts the numbers into more
traditional measurements like right ascension and declination.
Most users will use ``jplephem`` with the Satellite Planet Kernel (SPK)
files that the NAIF facility at NASA JPL offers for use with their own
SPICE toolkit. They have collected their most useful kernels beneath
the directory:
http://naif.jpl.nasa.gov/pub/naif/generic_kernels/spk/
To learn more about SPK files, the official `SPK Required Reading
`_
document is available from the NAIF facility’s web site under the NASA
JPL domain.
%package -n python3-jplephem
Summary: Use a JPL ephemeris to predict planet positions.
Provides: python-jplephem
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-jplephem
The only third-party package that ``jplephem`` depends on is `NumPy
`_, which ``pip`` will automatically attempt to
install alongside ``pyephem`` when you run::
$ pip install jplephem
If you see NumPy compilation errors, then try downloading and installing
NumPy directly from `its web site `_ or simply
use a distribution of Python with science tools already installed, like
`Anaconda `_.
Note that ``jplephem`` offers only the logic necessary to produce plain
three-dimensional vectors. Most programmers interested in astronomy
will want to look at `Skyfield `_
instead, which uses ``jplephem`` but converts the numbers into more
traditional measurements like right ascension and declination.
Most users will use ``jplephem`` with the Satellite Planet Kernel (SPK)
files that the NAIF facility at NASA JPL offers for use with their own
SPICE toolkit. They have collected their most useful kernels beneath
the directory:
http://naif.jpl.nasa.gov/pub/naif/generic_kernels/spk/
To learn more about SPK files, the official `SPK Required Reading
`_
document is available from the NAIF facility’s web site under the NASA
JPL domain.
%package help
Summary: Development documents and examples for jplephem
Provides: python3-jplephem-doc
%description help
The only third-party package that ``jplephem`` depends on is `NumPy
`_, which ``pip`` will automatically attempt to
install alongside ``pyephem`` when you run::
$ pip install jplephem
If you see NumPy compilation errors, then try downloading and installing
NumPy directly from `its web site `_ or simply
use a distribution of Python with science tools already installed, like
`Anaconda `_.
Note that ``jplephem`` offers only the logic necessary to produce plain
three-dimensional vectors. Most programmers interested in astronomy
will want to look at `Skyfield `_
instead, which uses ``jplephem`` but converts the numbers into more
traditional measurements like right ascension and declination.
Most users will use ``jplephem`` with the Satellite Planet Kernel (SPK)
files that the NAIF facility at NASA JPL offers for use with their own
SPICE toolkit. They have collected their most useful kernels beneath
the directory:
http://naif.jpl.nasa.gov/pub/naif/generic_kernels/spk/
To learn more about SPK files, the official `SPK Required Reading
`_
document is available from the NAIF facility’s web site under the NASA
JPL domain.
%prep
%autosetup -n jplephem-2.18
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-jplephem -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 2.18-1
- Package Spec generated