%global _empty_manifest_terminate_build 0
Name: python-pyhdfe
Version: 0.1.2
Release: 1
Summary: High dimensional fixed effect absorption with Python 3
License: MIT
URL: https://github.com/jeffgortmaker/pyhdfe
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/15/70/b16abf377dbe2abb91cc867c3fb4d1fe7633af217975910d84071bd861c0/pyhdfe-0.1.2.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-scipy
Requires: python3-sphinx
Requires: python3-ipython
Requires: python3-astunparse
Requires: python3-sphinx-rtd-theme
Requires: python3-nbsphinx
Requires: python3-jinja2
Requires: python3-docutils
Requires: python3-pytest
Requires: python3-pytest-xdist
%description
The PyHDFE package has been tested on `Python `_ versions 3.6 through 3.9. The `SciPy instructions `_ for installing related packages is a good guide for how to install a scientific Python environment. A good choice is the `Anaconda Distribution `_, since, along with many other packages that are useful for scientific computing, it comes packaged with PyHDFE's only required dependencies: `NumPy `_ and `SciPy `_.
You can install the current release of PyHDFE with `pip `_::
pip install pyhdfe
You can upgrade to a newer release with the ``--upgrade`` flag::
pip install --upgrade pyhdfe
If you lack permissions, you can install PyHDFE in your user directory with the ``--user`` flag::
pip install --user pyhdfe
Alternatively, you can download a wheel or source archive from `PyPI `_. You can find the latest development code on `GitHub `_ and the latest development documentation `here `_.
%package -n python3-pyhdfe
Summary: High dimensional fixed effect absorption with Python 3
Provides: python-pyhdfe
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pyhdfe
The PyHDFE package has been tested on `Python `_ versions 3.6 through 3.9. The `SciPy instructions `_ for installing related packages is a good guide for how to install a scientific Python environment. A good choice is the `Anaconda Distribution `_, since, along with many other packages that are useful for scientific computing, it comes packaged with PyHDFE's only required dependencies: `NumPy `_ and `SciPy `_.
You can install the current release of PyHDFE with `pip `_::
pip install pyhdfe
You can upgrade to a newer release with the ``--upgrade`` flag::
pip install --upgrade pyhdfe
If you lack permissions, you can install PyHDFE in your user directory with the ``--user`` flag::
pip install --user pyhdfe
Alternatively, you can download a wheel or source archive from `PyPI `_. You can find the latest development code on `GitHub `_ and the latest development documentation `here `_.
%package help
Summary: Development documents and examples for pyhdfe
Provides: python3-pyhdfe-doc
%description help
The PyHDFE package has been tested on `Python `_ versions 3.6 through 3.9. The `SciPy instructions `_ for installing related packages is a good guide for how to install a scientific Python environment. A good choice is the `Anaconda Distribution `_, since, along with many other packages that are useful for scientific computing, it comes packaged with PyHDFE's only required dependencies: `NumPy `_ and `SciPy `_.
You can install the current release of PyHDFE with `pip `_::
pip install pyhdfe
You can upgrade to a newer release with the ``--upgrade`` flag::
pip install --upgrade pyhdfe
If you lack permissions, you can install PyHDFE in your user directory with the ``--user`` flag::
pip install --user pyhdfe
Alternatively, you can download a wheel or source archive from `PyPI `_. You can find the latest development code on `GitHub `_ and the latest development documentation `here `_.
%prep
%autosetup -n pyhdfe-0.1.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pyhdfe -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 0.1.2-1
- Package Spec generated