%global _empty_manifest_terminate_build 0
Name: python-djangorestframework-xml
Version: 2.0.0
Release: 1
Summary: XML support for Django REST Framework
License: BSD
URL: https://github.com/jpadilla/django-rest-framework-xml
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/45/74/b75939a779fddef1d3e108991f7edb199e6240f23b6aef64f3a222e1b4dd/djangorestframework-xml-2.0.0.tar.gz
BuildArch: noarch
Requires: python3-defusedxml
Requires: python3-mkdocs
Requires: python3-Django
Requires: python3-djangorestframework
Requires: python3-pytest-django
Requires: python3-pytest
Requires: python3-flake8
Requires: python3-tox
Requires: python3-pre-commit
Requires: python3-mkdocs
Requires: python3-Django
Requires: python3-djangorestframework
Requires: python3-pytest-django
Requires: python3-pytest
Requires: python3-flake8
%description
# REST Framework XML
[![build-status-image]][github-action]
[![pypi-version]][pypi]
**XML support for Django REST Framework**
Full documentation for the project is available at [http://jpadilla.github.io/django-rest-framework-xml][docs].
## Overview
XML support extracted as a third party package directly from the official Django REST Framework implementation. It requires the [defusedxml][defusedxml] package only because it safeguards against some security issues that were discovered.
**Note**: XML output provided is an ad-hoc format that isn't formally described. If you have specific XML requirements you'll need to write your own XML parsers/renderers in order to fully control the representation.
## Requirements
* Python 3.5+
* Django 2.2+
* Django REST Framework 3.11+
## Installation
Install using `pip`...
```bash
$ pip install djangorestframework-xml
```
## Example
```python
REST_FRAMEWORK = {
'DEFAULT_PARSER_CLASSES': (
'rest_framework_xml.parsers.XMLParser',
),
'DEFAULT_RENDERER_CLASSES': (
'rest_framework_xml.renderers.XMLRenderer',
),
}
```
You can also set the renderer and parser used for an individual view, or viewset, using the APIView class based views.
```python
from rest_framework import routers, serializers, viewsets
from rest_framework_xml.parsers import XMLParser
from rest_framework_xml.renderers import XMLRenderer
class UserSerializer(serializers.HyperlinkedModelSerializer):
class Meta:
model = User
fields = ('url', 'username', 'email', 'is_staff')
class UserViewSet(viewsets.ModelViewSet):
queryset = User.objects.all()
serializer_class = UserSerializer
parser_classes = (XMLParser,)
renderer_classes = (XMLRenderer,)
```
### Sample output
```xml
http://127.0.0.1:8000/users/1/.xml
jpadilla
jpadilla@example.com
True
```
## Documentation & Support
Full documentation for the project is available at [http://jpadilla.github.io/django-rest-framework-xml][docs].
You may also want to follow the [author][jpadilla] on Twitter.
[build-status-image]: https://github.com/jpadilla/django-rest-framework-xml/workflows/CI/badge.svg
[github-action]: https://github.com/jpadilla/django-rest-framework-xml/actions?query=workflow%3ACI
[pypi-version]: https://img.shields.io/pypi/v/djangorestframework-xml.svg
[pypi]: https://pypi.python.org/pypi/djangorestframework-xml
[defusedxml]: https://pypi.python.org/pypi/defusedxml
[docs]: http://jpadilla.github.io/django-rest-framework-xml
[jpadilla]: https://twitter.com/jpadilla_
%package -n python3-djangorestframework-xml
Summary: XML support for Django REST Framework
Provides: python-djangorestframework-xml
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-djangorestframework-xml
# REST Framework XML
[![build-status-image]][github-action]
[![pypi-version]][pypi]
**XML support for Django REST Framework**
Full documentation for the project is available at [http://jpadilla.github.io/django-rest-framework-xml][docs].
## Overview
XML support extracted as a third party package directly from the official Django REST Framework implementation. It requires the [defusedxml][defusedxml] package only because it safeguards against some security issues that were discovered.
**Note**: XML output provided is an ad-hoc format that isn't formally described. If you have specific XML requirements you'll need to write your own XML parsers/renderers in order to fully control the representation.
## Requirements
* Python 3.5+
* Django 2.2+
* Django REST Framework 3.11+
## Installation
Install using `pip`...
```bash
$ pip install djangorestframework-xml
```
## Example
```python
REST_FRAMEWORK = {
'DEFAULT_PARSER_CLASSES': (
'rest_framework_xml.parsers.XMLParser',
),
'DEFAULT_RENDERER_CLASSES': (
'rest_framework_xml.renderers.XMLRenderer',
),
}
```
You can also set the renderer and parser used for an individual view, or viewset, using the APIView class based views.
```python
from rest_framework import routers, serializers, viewsets
from rest_framework_xml.parsers import XMLParser
from rest_framework_xml.renderers import XMLRenderer
class UserSerializer(serializers.HyperlinkedModelSerializer):
class Meta:
model = User
fields = ('url', 'username', 'email', 'is_staff')
class UserViewSet(viewsets.ModelViewSet):
queryset = User.objects.all()
serializer_class = UserSerializer
parser_classes = (XMLParser,)
renderer_classes = (XMLRenderer,)
```
### Sample output
```xml
http://127.0.0.1:8000/users/1/.xml
jpadilla
jpadilla@example.com
True
```
## Documentation & Support
Full documentation for the project is available at [http://jpadilla.github.io/django-rest-framework-xml][docs].
You may also want to follow the [author][jpadilla] on Twitter.
[build-status-image]: https://github.com/jpadilla/django-rest-framework-xml/workflows/CI/badge.svg
[github-action]: https://github.com/jpadilla/django-rest-framework-xml/actions?query=workflow%3ACI
[pypi-version]: https://img.shields.io/pypi/v/djangorestframework-xml.svg
[pypi]: https://pypi.python.org/pypi/djangorestframework-xml
[defusedxml]: https://pypi.python.org/pypi/defusedxml
[docs]: http://jpadilla.github.io/django-rest-framework-xml
[jpadilla]: https://twitter.com/jpadilla_
%package help
Summary: Development documents and examples for djangorestframework-xml
Provides: python3-djangorestframework-xml-doc
%description help
# REST Framework XML
[![build-status-image]][github-action]
[![pypi-version]][pypi]
**XML support for Django REST Framework**
Full documentation for the project is available at [http://jpadilla.github.io/django-rest-framework-xml][docs].
## Overview
XML support extracted as a third party package directly from the official Django REST Framework implementation. It requires the [defusedxml][defusedxml] package only because it safeguards against some security issues that were discovered.
**Note**: XML output provided is an ad-hoc format that isn't formally described. If you have specific XML requirements you'll need to write your own XML parsers/renderers in order to fully control the representation.
## Requirements
* Python 3.5+
* Django 2.2+
* Django REST Framework 3.11+
## Installation
Install using `pip`...
```bash
$ pip install djangorestframework-xml
```
## Example
```python
REST_FRAMEWORK = {
'DEFAULT_PARSER_CLASSES': (
'rest_framework_xml.parsers.XMLParser',
),
'DEFAULT_RENDERER_CLASSES': (
'rest_framework_xml.renderers.XMLRenderer',
),
}
```
You can also set the renderer and parser used for an individual view, or viewset, using the APIView class based views.
```python
from rest_framework import routers, serializers, viewsets
from rest_framework_xml.parsers import XMLParser
from rest_framework_xml.renderers import XMLRenderer
class UserSerializer(serializers.HyperlinkedModelSerializer):
class Meta:
model = User
fields = ('url', 'username', 'email', 'is_staff')
class UserViewSet(viewsets.ModelViewSet):
queryset = User.objects.all()
serializer_class = UserSerializer
parser_classes = (XMLParser,)
renderer_classes = (XMLRenderer,)
```
### Sample output
```xml
http://127.0.0.1:8000/users/1/.xml
jpadilla
jpadilla@example.com
True
```
## Documentation & Support
Full documentation for the project is available at [http://jpadilla.github.io/django-rest-framework-xml][docs].
You may also want to follow the [author][jpadilla] on Twitter.
[build-status-image]: https://github.com/jpadilla/django-rest-framework-xml/workflows/CI/badge.svg
[github-action]: https://github.com/jpadilla/django-rest-framework-xml/actions?query=workflow%3ACI
[pypi-version]: https://img.shields.io/pypi/v/djangorestframework-xml.svg
[pypi]: https://pypi.python.org/pypi/djangorestframework-xml
[defusedxml]: https://pypi.python.org/pypi/defusedxml
[docs]: http://jpadilla.github.io/django-rest-framework-xml
[jpadilla]: https://twitter.com/jpadilla_
%prep
%autosetup -n djangorestframework-xml-2.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-djangorestframework-xml -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 2.0.0-1
- Package Spec generated