%global _empty_manifest_terminate_build 0
Name: python-dask-ml
Version: 2023.3.24
Release: 1
Summary: A library for distributed and parallel machine learning
License: BSD
URL: https://github.com/dask/dask-ml
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d7/ef/3d1cbd807bae779d58723df537098fe10a1e2d8a9fad95f1cd6e94a06229/dask-ml-2023.3.24.tar.gz
BuildArch: noarch
Requires: python3-dask[array,dataframe]
Requires: python3-distributed
Requires: python3-numba
Requires: python3-numpy
Requires: python3-pandas
Requires: python3-scikit-learn
Requires: python3-scipy
Requires: python3-dask-glm
Requires: python3-multipledispatch
Requires: python3-packaging
Requires: python3-dask-xgboost
Requires: python3-xgboost
Requires: python3-sphinx
Requires: python3-numpydoc
Requires: python3-sphinx-rtd-theme
Requires: python3-nbsphinx
Requires: python3-sphinx-gallery
Requires: python3-black
Requires: python3-coverage
Requires: python3-flake8
Requires: python3-isort
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-pytest-mock
Requires: python3-sphinx
Requires: python3-numpydoc
Requires: python3-sphinx-rtd-theme
Requires: python3-nbsphinx
Requires: python3-sphinx-gallery
Requires: python3-black
Requires: python3-coverage
Requires: python3-flake8
Requires: python3-isort
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-pytest-mock
Requires: python3-dask-xgboost
Requires: python3-xgboost
%description
|Build Status| |Azure Pipelines| |Coverage| |Doc Status| |Discourse| |Version Status| |NumFOCUS|
Dask-ML provides scalable machine learning in Python using `Dask `__ alongside popular machine learning libraries like `Scikit-Learn `__, `XGBoost `__, and others.
You can try Dask-ML on a small cloud instance by clicking the following button:
%package -n python3-dask-ml
Summary: A library for distributed and parallel machine learning
Provides: python-dask-ml
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-dask-ml
|Build Status| |Azure Pipelines| |Coverage| |Doc Status| |Discourse| |Version Status| |NumFOCUS|
Dask-ML provides scalable machine learning in Python using `Dask `__ alongside popular machine learning libraries like `Scikit-Learn `__, `XGBoost `__, and others.
You can try Dask-ML on a small cloud instance by clicking the following button:
%package help
Summary: Development documents and examples for dask-ml
Provides: python3-dask-ml-doc
%description help
|Build Status| |Azure Pipelines| |Coverage| |Doc Status| |Discourse| |Version Status| |NumFOCUS|
Dask-ML provides scalable machine learning in Python using `Dask `__ alongside popular machine learning libraries like `Scikit-Learn `__, `XGBoost `__, and others.
You can try Dask-ML on a small cloud instance by clicking the following button:
%prep
%autosetup -n dask-ml-2023.3.24
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-dask-ml -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 2023.3.24-1
- Package Spec generated