%global _empty_manifest_terminate_build 0
Name: python-cypari
Version: 2.4.1
Release: 1
Summary: Sage's PARI extension, modified to stand alone.
License: GPLv2+
URL: https://bitbucket.org/t3m/cypari
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/0d/9c/c6841a6a52d81b54ef96fe0972586a6d8246d3fbdebbf29ccd5efd37e48c/cypari-2.4.1.tar.gz
Requires: python3-six
Requires: python3-future
%description
The package *cypari* is a Python wrapper for the `PARI library
`_, a computer algebra system for
number theory computations. It is derived from the `corresponding
component
`_
of `SageMath `_, but is independent of the rest of
SageMath and can be used with any recent version of Python 2 or 3.
%package -n python3-cypari
Summary: Sage's PARI extension, modified to stand alone.
Provides: python-cypari
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-cypari
The package *cypari* is a Python wrapper for the `PARI library
`_, a computer algebra system for
number theory computations. It is derived from the `corresponding
component
`_
of `SageMath `_, but is independent of the rest of
SageMath and can be used with any recent version of Python 2 or 3.
%package help
Summary: Development documents and examples for cypari
Provides: python3-cypari-doc
%description help
The package *cypari* is a Python wrapper for the `PARI library
`_, a computer algebra system for
number theory computations. It is derived from the `corresponding
component
`_
of `SageMath `_, but is independent of the rest of
SageMath and can be used with any recent version of Python 2 or 3.
%prep
%autosetup -n cypari-2.4.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-cypari -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 2.4.1-1
- Package Spec generated