%global _empty_manifest_terminate_build 0
Name: python-kedro-viz
Version: 6.0.1
Release: 1
Summary: Kedro-Viz helps visualise Kedro data and analytics pipelines
License: Apache Software License (Apache 2.0)
URL: https://github.com/kedro-org/kedro-viz
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b8/ea/a6452232b362a7241836c3e66f9f72bd424f6a7156685598e9736c8ca1a1/kedro-viz-6.0.1.tar.gz
BuildArch: noarch
Requires: python3-semver
Requires: python3-kedro
Requires: python3-ipython
Requires: python3-fastapi
Requires: python3-aiofiles
Requires: python3-uvicorn[standard]
Requires: python3-watchgod
Requires: python3-plotly
Requires: python3-pandas
Requires: python3-sqlalchemy
Requires: python3-strawberry-graphql
Requires: python3-networkx
Requires: python3-orjson
%description
# Kedro-Viz
![Kedro-Viz Pipeline Visualisation](./.github/img/banner.png)
โจ Data Science Pipelines. Beautifully Designed โจ
Live Demo: https://demo.kedro.org/
[![CircleCI](https://circleci.com/gh/kedro-org/kedro-viz/tree/main.svg?style=shield)](https://circleci.com/gh/kedro-org/kedro-viz/tree/main)
[![npm version](https://img.shields.io/npm/v/@quantumblack/kedro-viz.svg?color=cc3534)](https://badge.fury.io/js/%40quantumblack%2Fkedro-viz)
[![Python Version](https://img.shields.io/badge/python-3.7%20%7C%203.8%20%7C%203.9%20%7C%203.10-orange.svg)](https://pypi.org/project/kedro-viz/)
[![PyPI version](https://img.shields.io/pypi/v/kedro-viz.svg?color=yellow)](https://pypi.org/project/kedro-viz/)
[![License](https://img.shields.io/badge/license-Apache%202.0-3da639.svg)](https://opensource.org/licenses/Apache-2.0)
[![DOI](https://zenodo.org/badge/DOI/10.5281/zenodo.4355948.svg)](https://doi.org/10.5281/zenodo.4355948)
[![code style: prettier](https://img.shields.io/badge/code_style-prettier-ff69b4.svg)](https://github.com/prettier/prettier)
## Introduction
Kedro-Viz is an interactive development tool for building data science pipelines with [Kedro](https://github.com/kedro-org/kedro). Kedro-Viz also allows users to view and compare different runs in the Kedro project.
## Features
- โจ Complete visualisation of a Kedro project and its pipelines
- ๐จ Supports light & dark themes out of the box
- ๐ Scales to big pipelines with hundreds of nodes
- ๐ Highly interactive, filterable and searchable
- ๐ฌ Focus mode for modular pipeline visualisation
- ๐ Rich metadata side panel to display parameters, plots, etc.
- ๐ Supports all types of [Plotly charts](https://plotly.com/javascript/)
- โป๏ธ Autoreload on code change
- ๐งช Supports tracking and comparing runs in a Kedro project
- ๐ฉ Many more to come
## Installation
There are two ways you can use Kedro-Viz:
- As a [Kedro plugin](https://kedro.readthedocs.io/en/stable/07_extend_kedro/04_plugins.html) (the most common way).
To install Kedro-Viz as a Kedro plugin:
```bash
pip install kedro-viz
```
- As a standalone React component (for embedding Kedro-Viz in your web application).
To install the standalone React component:
```bash
npm install @quantumblack/kedro-viz
```
## Usage
### CLI Usage
To launch Kedro-Viz from the command line as a Kedro plugin, use the following command from the root folder of your Kedro project:
```bash
kedro viz
```
A browser tab opens automatically to serve the visualisation at `http://127.0.0.1:4141/`.
Kedro-Viz also supports the following additional arguments on the command line:
```bash
Usage: kedro viz [OPTIONS]
Visualise a Kedro pipeline using Kedro-Viz.
Options:
--host TEXT Host that viz will listen to. Defaults to
localhost.
--port INTEGER TCP port that viz will listen to. Defaults to
4141.
--browser / --no-browser Whether to open viz interface in the default
browser or not. Browser will only be opened if
host is localhost. Defaults to True.
--load-file FILE Path to load the pipeline JSON file
--save-file FILE Path to save the pipeline JSON file
--pipeline TEXT Name of the registered pipeline to visualise. If not
set, the default pipeline is visualised
-e, --env TEXT Kedro configuration environment. If not specified,
catalog config in `local` will be used
--autoreload Autoreload viz server when a Python or YAML file change in
the Kedro project
--params TEXT Specify extra parameters that you want to pass to
the context initializer. Items must be separated
by comma, keys - by colon, example:
param1:value1,param2:value2. Each parameter is
split by the first comma, so parameter values are
allowed to contain colons, parameter keys are not.
To pass a nested dictionary as parameter, separate
keys by '.', example: param_group.param1:value1.
-h, --help Show this message and exit.
```
### Experiment Tracking usage
To enable [experiment tracking](https://kedro.readthedocs.io/en/stable/08_logging/02_experiment_tracking.html) in Kedro-Viz, you need to add the Kedro-Viz `SQLiteStore` to your Kedro project.
This can be done by adding the below code to `settings.py` in the `src` folder of your Kedro project.
```python
from kedro_viz.integrations.kedro.sqlite_store import SQLiteStore
from pathlib import Path
SESSION_STORE_CLASS = SQLiteStore
SESSION_STORE_ARGS = {"path": str(Path(__file__).parents[2] / "data")}
```
Once the above set-up is complete, tracking datasets can be used to track relevant data for Kedro runs. More information on how to use tracking datasets can be found [here](https://kedro.readthedocs.io/en/stable/08_logging/02_experiment_tracking.html)
**Notes:**
- Experiment Tracking is only available for Kedro-Viz >= 4.0.2 and Kedro >= 0.17.5
- Prior to Kedro 0.17.6, when using tracking datasets, you will have to explicitly mark the datasets as `versioned` for it to show up properly in Kedro-Viz experiment tracking tab. From Kedro >= 0.17.6, this is done automatically:
```yaml
train_evaluation.r2_score_linear_regression:
type: tracking.MetricsDataSet
filepath: ${base_location}/09_tracking/linear_score.json
versioned: true
```
### Standalone React component usage
To use Kedro-Viz as a standalone React component, import the component and supply a data JSON as prop:
```javascript
import KedroViz from '@quantumblack/kedro-viz';
const MyApp = () => (
);
```
The JSON can be obtained by running:
```bash
kedro viz --save-file=filename.json
```
We also recommend wrapping the `Kedro-Viz` component with a parent HTML/JSX element that has a specified height (as seen in the above example) in order for Kedro-Viz to be styled properly.
## Feature Flags
Kedro-Viz uses features flags to roll out some experimental features. The following flags are currently in use:
| Flag | Description |
| ----------- | --------------------------------------------------------------------------------------- |
| sizewarning | From release v3.9.1. Show a warning before rendering very large graphs (default `true`) |
| expandAllPipelines | From release v4.3.2. Expand all modular pipelines on first load (default `false`) |
To enable or disable a flag, click on the settings icon in the toolbar and toggle the flag on/off.
Kedro-Viz also logs a message in your browser's [developer console](https://developer.mozilla.org/en-US/docs/Learn/Common_questions/What_are_browser_developer_tools#The_JavaScript_console) to show the available flags and their values as currently set on your machine.
## Maintainers
Kedro-Viz is maintained by the [kedro team](https://kedro.readthedocs.io/en/stable/12_faq/01_faq.html#who-maintains-kedro) and a number of [contributors from across the world](https://github.com/kedro-org/Kedro-Viz/contributors).
## Contribution
If you want to contribute to Kedro-Viz, please check out our [contributing guide](./CONTRIBUTING.md).
## License
Kedro-Viz is licensed under the [Apache 2.0](https://github.com/kedro-org/kedro-viz/blob/main/LICENSE.md) License.
## Citation
If you're an academic, Kedro-Viz can also help you, for example, as a tool to visualise how your publication's pipeline is structured. Find our citation reference on [Zenodo](https://doi.org/10.5281/zenodo.4277218).
%package -n python3-kedro-viz
Summary: Kedro-Viz helps visualise Kedro data and analytics pipelines
Provides: python-kedro-viz
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-kedro-viz
# Kedro-Viz
![Kedro-Viz Pipeline Visualisation](./.github/img/banner.png)
โจ Data Science Pipelines. Beautifully Designed โจ
Live Demo: https://demo.kedro.org/
[![CircleCI](https://circleci.com/gh/kedro-org/kedro-viz/tree/main.svg?style=shield)](https://circleci.com/gh/kedro-org/kedro-viz/tree/main)
[![npm version](https://img.shields.io/npm/v/@quantumblack/kedro-viz.svg?color=cc3534)](https://badge.fury.io/js/%40quantumblack%2Fkedro-viz)
[![Python Version](https://img.shields.io/badge/python-3.7%20%7C%203.8%20%7C%203.9%20%7C%203.10-orange.svg)](https://pypi.org/project/kedro-viz/)
[![PyPI version](https://img.shields.io/pypi/v/kedro-viz.svg?color=yellow)](https://pypi.org/project/kedro-viz/)
[![License](https://img.shields.io/badge/license-Apache%202.0-3da639.svg)](https://opensource.org/licenses/Apache-2.0)
[![DOI](https://zenodo.org/badge/DOI/10.5281/zenodo.4355948.svg)](https://doi.org/10.5281/zenodo.4355948)
[![code style: prettier](https://img.shields.io/badge/code_style-prettier-ff69b4.svg)](https://github.com/prettier/prettier)
## Introduction
Kedro-Viz is an interactive development tool for building data science pipelines with [Kedro](https://github.com/kedro-org/kedro). Kedro-Viz also allows users to view and compare different runs in the Kedro project.
## Features
- โจ Complete visualisation of a Kedro project and its pipelines
- ๐จ Supports light & dark themes out of the box
- ๐ Scales to big pipelines with hundreds of nodes
- ๐ Highly interactive, filterable and searchable
- ๐ฌ Focus mode for modular pipeline visualisation
- ๐ Rich metadata side panel to display parameters, plots, etc.
- ๐ Supports all types of [Plotly charts](https://plotly.com/javascript/)
- โป๏ธ Autoreload on code change
- ๐งช Supports tracking and comparing runs in a Kedro project
- ๐ฉ Many more to come
## Installation
There are two ways you can use Kedro-Viz:
- As a [Kedro plugin](https://kedro.readthedocs.io/en/stable/07_extend_kedro/04_plugins.html) (the most common way).
To install Kedro-Viz as a Kedro plugin:
```bash
pip install kedro-viz
```
- As a standalone React component (for embedding Kedro-Viz in your web application).
To install the standalone React component:
```bash
npm install @quantumblack/kedro-viz
```
## Usage
### CLI Usage
To launch Kedro-Viz from the command line as a Kedro plugin, use the following command from the root folder of your Kedro project:
```bash
kedro viz
```
A browser tab opens automatically to serve the visualisation at `http://127.0.0.1:4141/`.
Kedro-Viz also supports the following additional arguments on the command line:
```bash
Usage: kedro viz [OPTIONS]
Visualise a Kedro pipeline using Kedro-Viz.
Options:
--host TEXT Host that viz will listen to. Defaults to
localhost.
--port INTEGER TCP port that viz will listen to. Defaults to
4141.
--browser / --no-browser Whether to open viz interface in the default
browser or not. Browser will only be opened if
host is localhost. Defaults to True.
--load-file FILE Path to load the pipeline JSON file
--save-file FILE Path to save the pipeline JSON file
--pipeline TEXT Name of the registered pipeline to visualise. If not
set, the default pipeline is visualised
-e, --env TEXT Kedro configuration environment. If not specified,
catalog config in `local` will be used
--autoreload Autoreload viz server when a Python or YAML file change in
the Kedro project
--params TEXT Specify extra parameters that you want to pass to
the context initializer. Items must be separated
by comma, keys - by colon, example:
param1:value1,param2:value2. Each parameter is
split by the first comma, so parameter values are
allowed to contain colons, parameter keys are not.
To pass a nested dictionary as parameter, separate
keys by '.', example: param_group.param1:value1.
-h, --help Show this message and exit.
```
### Experiment Tracking usage
To enable [experiment tracking](https://kedro.readthedocs.io/en/stable/08_logging/02_experiment_tracking.html) in Kedro-Viz, you need to add the Kedro-Viz `SQLiteStore` to your Kedro project.
This can be done by adding the below code to `settings.py` in the `src` folder of your Kedro project.
```python
from kedro_viz.integrations.kedro.sqlite_store import SQLiteStore
from pathlib import Path
SESSION_STORE_CLASS = SQLiteStore
SESSION_STORE_ARGS = {"path": str(Path(__file__).parents[2] / "data")}
```
Once the above set-up is complete, tracking datasets can be used to track relevant data for Kedro runs. More information on how to use tracking datasets can be found [here](https://kedro.readthedocs.io/en/stable/08_logging/02_experiment_tracking.html)
**Notes:**
- Experiment Tracking is only available for Kedro-Viz >= 4.0.2 and Kedro >= 0.17.5
- Prior to Kedro 0.17.6, when using tracking datasets, you will have to explicitly mark the datasets as `versioned` for it to show up properly in Kedro-Viz experiment tracking tab. From Kedro >= 0.17.6, this is done automatically:
```yaml
train_evaluation.r2_score_linear_regression:
type: tracking.MetricsDataSet
filepath: ${base_location}/09_tracking/linear_score.json
versioned: true
```
### Standalone React component usage
To use Kedro-Viz as a standalone React component, import the component and supply a data JSON as prop:
```javascript
import KedroViz from '@quantumblack/kedro-viz';
const MyApp = () => (
);
```
The JSON can be obtained by running:
```bash
kedro viz --save-file=filename.json
```
We also recommend wrapping the `Kedro-Viz` component with a parent HTML/JSX element that has a specified height (as seen in the above example) in order for Kedro-Viz to be styled properly.
## Feature Flags
Kedro-Viz uses features flags to roll out some experimental features. The following flags are currently in use:
| Flag | Description |
| ----------- | --------------------------------------------------------------------------------------- |
| sizewarning | From release v3.9.1. Show a warning before rendering very large graphs (default `true`) |
| expandAllPipelines | From release v4.3.2. Expand all modular pipelines on first load (default `false`) |
To enable or disable a flag, click on the settings icon in the toolbar and toggle the flag on/off.
Kedro-Viz also logs a message in your browser's [developer console](https://developer.mozilla.org/en-US/docs/Learn/Common_questions/What_are_browser_developer_tools#The_JavaScript_console) to show the available flags and their values as currently set on your machine.
## Maintainers
Kedro-Viz is maintained by the [kedro team](https://kedro.readthedocs.io/en/stable/12_faq/01_faq.html#who-maintains-kedro) and a number of [contributors from across the world](https://github.com/kedro-org/Kedro-Viz/contributors).
## Contribution
If you want to contribute to Kedro-Viz, please check out our [contributing guide](./CONTRIBUTING.md).
## License
Kedro-Viz is licensed under the [Apache 2.0](https://github.com/kedro-org/kedro-viz/blob/main/LICENSE.md) License.
## Citation
If you're an academic, Kedro-Viz can also help you, for example, as a tool to visualise how your publication's pipeline is structured. Find our citation reference on [Zenodo](https://doi.org/10.5281/zenodo.4277218).
%package help
Summary: Development documents and examples for kedro-viz
Provides: python3-kedro-viz-doc
%description help
# Kedro-Viz
![Kedro-Viz Pipeline Visualisation](./.github/img/banner.png)
โจ Data Science Pipelines. Beautifully Designed โจ
Live Demo: https://demo.kedro.org/
[![CircleCI](https://circleci.com/gh/kedro-org/kedro-viz/tree/main.svg?style=shield)](https://circleci.com/gh/kedro-org/kedro-viz/tree/main)
[![npm version](https://img.shields.io/npm/v/@quantumblack/kedro-viz.svg?color=cc3534)](https://badge.fury.io/js/%40quantumblack%2Fkedro-viz)
[![Python Version](https://img.shields.io/badge/python-3.7%20%7C%203.8%20%7C%203.9%20%7C%203.10-orange.svg)](https://pypi.org/project/kedro-viz/)
[![PyPI version](https://img.shields.io/pypi/v/kedro-viz.svg?color=yellow)](https://pypi.org/project/kedro-viz/)
[![License](https://img.shields.io/badge/license-Apache%202.0-3da639.svg)](https://opensource.org/licenses/Apache-2.0)
[![DOI](https://zenodo.org/badge/DOI/10.5281/zenodo.4355948.svg)](https://doi.org/10.5281/zenodo.4355948)
[![code style: prettier](https://img.shields.io/badge/code_style-prettier-ff69b4.svg)](https://github.com/prettier/prettier)
## Introduction
Kedro-Viz is an interactive development tool for building data science pipelines with [Kedro](https://github.com/kedro-org/kedro). Kedro-Viz also allows users to view and compare different runs in the Kedro project.
## Features
- โจ Complete visualisation of a Kedro project and its pipelines
- ๐จ Supports light & dark themes out of the box
- ๐ Scales to big pipelines with hundreds of nodes
- ๐ Highly interactive, filterable and searchable
- ๐ฌ Focus mode for modular pipeline visualisation
- ๐ Rich metadata side panel to display parameters, plots, etc.
- ๐ Supports all types of [Plotly charts](https://plotly.com/javascript/)
- โป๏ธ Autoreload on code change
- ๐งช Supports tracking and comparing runs in a Kedro project
- ๐ฉ Many more to come
## Installation
There are two ways you can use Kedro-Viz:
- As a [Kedro plugin](https://kedro.readthedocs.io/en/stable/07_extend_kedro/04_plugins.html) (the most common way).
To install Kedro-Viz as a Kedro plugin:
```bash
pip install kedro-viz
```
- As a standalone React component (for embedding Kedro-Viz in your web application).
To install the standalone React component:
```bash
npm install @quantumblack/kedro-viz
```
## Usage
### CLI Usage
To launch Kedro-Viz from the command line as a Kedro plugin, use the following command from the root folder of your Kedro project:
```bash
kedro viz
```
A browser tab opens automatically to serve the visualisation at `http://127.0.0.1:4141/`.
Kedro-Viz also supports the following additional arguments on the command line:
```bash
Usage: kedro viz [OPTIONS]
Visualise a Kedro pipeline using Kedro-Viz.
Options:
--host TEXT Host that viz will listen to. Defaults to
localhost.
--port INTEGER TCP port that viz will listen to. Defaults to
4141.
--browser / --no-browser Whether to open viz interface in the default
browser or not. Browser will only be opened if
host is localhost. Defaults to True.
--load-file FILE Path to load the pipeline JSON file
--save-file FILE Path to save the pipeline JSON file
--pipeline TEXT Name of the registered pipeline to visualise. If not
set, the default pipeline is visualised
-e, --env TEXT Kedro configuration environment. If not specified,
catalog config in `local` will be used
--autoreload Autoreload viz server when a Python or YAML file change in
the Kedro project
--params TEXT Specify extra parameters that you want to pass to
the context initializer. Items must be separated
by comma, keys - by colon, example:
param1:value1,param2:value2. Each parameter is
split by the first comma, so parameter values are
allowed to contain colons, parameter keys are not.
To pass a nested dictionary as parameter, separate
keys by '.', example: param_group.param1:value1.
-h, --help Show this message and exit.
```
### Experiment Tracking usage
To enable [experiment tracking](https://kedro.readthedocs.io/en/stable/08_logging/02_experiment_tracking.html) in Kedro-Viz, you need to add the Kedro-Viz `SQLiteStore` to your Kedro project.
This can be done by adding the below code to `settings.py` in the `src` folder of your Kedro project.
```python
from kedro_viz.integrations.kedro.sqlite_store import SQLiteStore
from pathlib import Path
SESSION_STORE_CLASS = SQLiteStore
SESSION_STORE_ARGS = {"path": str(Path(__file__).parents[2] / "data")}
```
Once the above set-up is complete, tracking datasets can be used to track relevant data for Kedro runs. More information on how to use tracking datasets can be found [here](https://kedro.readthedocs.io/en/stable/08_logging/02_experiment_tracking.html)
**Notes:**
- Experiment Tracking is only available for Kedro-Viz >= 4.0.2 and Kedro >= 0.17.5
- Prior to Kedro 0.17.6, when using tracking datasets, you will have to explicitly mark the datasets as `versioned` for it to show up properly in Kedro-Viz experiment tracking tab. From Kedro >= 0.17.6, this is done automatically:
```yaml
train_evaluation.r2_score_linear_regression:
type: tracking.MetricsDataSet
filepath: ${base_location}/09_tracking/linear_score.json
versioned: true
```
### Standalone React component usage
To use Kedro-Viz as a standalone React component, import the component and supply a data JSON as prop:
```javascript
import KedroViz from '@quantumblack/kedro-viz';
const MyApp = () => (
);
```
The JSON can be obtained by running:
```bash
kedro viz --save-file=filename.json
```
We also recommend wrapping the `Kedro-Viz` component with a parent HTML/JSX element that has a specified height (as seen in the above example) in order for Kedro-Viz to be styled properly.
## Feature Flags
Kedro-Viz uses features flags to roll out some experimental features. The following flags are currently in use:
| Flag | Description |
| ----------- | --------------------------------------------------------------------------------------- |
| sizewarning | From release v3.9.1. Show a warning before rendering very large graphs (default `true`) |
| expandAllPipelines | From release v4.3.2. Expand all modular pipelines on first load (default `false`) |
To enable or disable a flag, click on the settings icon in the toolbar and toggle the flag on/off.
Kedro-Viz also logs a message in your browser's [developer console](https://developer.mozilla.org/en-US/docs/Learn/Common_questions/What_are_browser_developer_tools#The_JavaScript_console) to show the available flags and their values as currently set on your machine.
## Maintainers
Kedro-Viz is maintained by the [kedro team](https://kedro.readthedocs.io/en/stable/12_faq/01_faq.html#who-maintains-kedro) and a number of [contributors from across the world](https://github.com/kedro-org/Kedro-Viz/contributors).
## Contribution
If you want to contribute to Kedro-Viz, please check out our [contributing guide](./CONTRIBUTING.md).
## License
Kedro-Viz is licensed under the [Apache 2.0](https://github.com/kedro-org/kedro-viz/blob/main/LICENSE.md) License.
## Citation
If you're an academic, Kedro-Viz can also help you, for example, as a tool to visualise how your publication's pipeline is structured. Find our citation reference on [Zenodo](https://doi.org/10.5281/zenodo.4277218).
%prep
%autosetup -n kedro-viz-6.0.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-kedro-viz -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 6.0.1-1
- Package Spec generated