%global _empty_manifest_terminate_build 0 Name: python-username Version: 2.1.0 Release: 1 Summary: Get the current username License: MIT URL: https://projects.abranhe.com/username Source0: https://mirrors.nju.edu.cn/pypi/web/packages/9c/9e/236d179f14fa30e29b92705dad2631224e5aa58b1f15a07f6a556f3ed580/username-2.1.0.tar.gz BuildArch: noarch %description




username get the current username

## Install ```console $ pip install username ``` ## Usage ```python import username print(username()) # 'abranhe' ``` ## API ### username() Get current username ## Related - [username-cli](https://github.com/abranhe/username-cli): cli for this package. ## License MIT © [Abraham Hernandez](https://github.com/abranhe) %package -n python3-username Summary: Get the current username Provides: python-username BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-username




username get the current username

## Install ```console $ pip install username ``` ## Usage ```python import username print(username()) # 'abranhe' ``` ## API ### username() Get current username ## Related - [username-cli](https://github.com/abranhe/username-cli): cli for this package. ## License MIT © [Abraham Hernandez](https://github.com/abranhe) %package help Summary: Development documents and examples for username Provides: python3-username-doc %description help




username get the current username

## Install ```console $ pip install username ``` ## Usage ```python import username print(username()) # 'abranhe' ``` ## API ### username() Get current username ## Related - [username-cli](https://github.com/abranhe/username-cli): cli for this package. ## License MIT © [Abraham Hernandez](https://github.com/abranhe) %prep %autosetup -n username-2.1.0 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-username -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Sun Apr 23 2023 Python_Bot - 2.1.0-1 - Package Spec generated