%global _empty_manifest_terminate_build 0
Name: python-webdriverdownloader
Version: 1.1.0.3
Release: 1
Summary: Python module and CLI tool for facilitating download and deploy of WebDriver binaries.
License: MIT
URL: https://github.com/leonidessaguisagjr/webdriverdownloader
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/97/24/bf92c519770a7a673f11a76e0f218c60881c46dc81d9f7d43f00c6cd07cb/webdriverdownloader-1.1.0.3.tar.gz
BuildArch: noarch
Requires: python3-beautifulsoup4
Requires: python3-requests
Requires: python3-tqdm
%description
Python module to facilitate downloading and deploying `WebDriver `_
binaries. The classes in this module can be used to automatically search for
and download the latest version (or a specific version) of a WebDriver binary
(will download to ``$HOME/webdriver`` or ``/usr/local/webdriver`` if run with
``sudo``), extract the binary from the downloaded archive and create a symlink
in either ``/usr/local/bin`` (if run with ``sudo``) or ``$HOME/bin``.
Note: For non-root users, the ``$HOME/bin`` directory may not be in the search
PATH. If you are unable to add this directory your search path, a workaround
is to capture the return value from the ``download()`` or ``download_and_install()``
method (see the docstrings for those methods for more information on the return
values) and pass the path to the downloaded webdriver binary as a parameter to
the constructor for the Selenium WebDriver instance. See the documentation for
the ``executable_path`` parameter for the relevant WebDriver class for more
information.
%package -n python3-webdriverdownloader
Summary: Python module and CLI tool for facilitating download and deploy of WebDriver binaries.
Provides: python-webdriverdownloader
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-webdriverdownloader
Python module to facilitate downloading and deploying `WebDriver `_
binaries. The classes in this module can be used to automatically search for
and download the latest version (or a specific version) of a WebDriver binary
(will download to ``$HOME/webdriver`` or ``/usr/local/webdriver`` if run with
``sudo``), extract the binary from the downloaded archive and create a symlink
in either ``/usr/local/bin`` (if run with ``sudo``) or ``$HOME/bin``.
Note: For non-root users, the ``$HOME/bin`` directory may not be in the search
PATH. If you are unable to add this directory your search path, a workaround
is to capture the return value from the ``download()`` or ``download_and_install()``
method (see the docstrings for those methods for more information on the return
values) and pass the path to the downloaded webdriver binary as a parameter to
the constructor for the Selenium WebDriver instance. See the documentation for
the ``executable_path`` parameter for the relevant WebDriver class for more
information.
%package help
Summary: Development documents and examples for webdriverdownloader
Provides: python3-webdriverdownloader-doc
%description help
Python module to facilitate downloading and deploying `WebDriver `_
binaries. The classes in this module can be used to automatically search for
and download the latest version (or a specific version) of a WebDriver binary
(will download to ``$HOME/webdriver`` or ``/usr/local/webdriver`` if run with
``sudo``), extract the binary from the downloaded archive and create a symlink
in either ``/usr/local/bin`` (if run with ``sudo``) or ``$HOME/bin``.
Note: For non-root users, the ``$HOME/bin`` directory may not be in the search
PATH. If you are unable to add this directory your search path, a workaround
is to capture the return value from the ``download()`` or ``download_and_install()``
method (see the docstrings for those methods for more information on the return
values) and pass the path to the downloaded webdriver binary as a parameter to
the constructor for the Selenium WebDriver instance. See the documentation for
the ``executable_path`` parameter for the relevant WebDriver class for more
information.
%prep
%autosetup -n webdriverdownloader-1.1.0.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-webdriverdownloader -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 1.1.0.3-1
- Package Spec generated