%global _empty_manifest_terminate_build 0
Name: python-cdk-kubesphere
Version: 2.0.315
Release: 1
Summary: CDK construct library to deploy KubeSphere on AWS
License: Apache-2.0
URL: https://github.com/pahud/cdk-kubesphere.git
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/bc/32/a1b360f73bb2d8562dc6f1ad1421807a9a2fb42904dd61664ec389da2848/cdk-kubesphere-2.0.315.tar.gz
BuildArch: noarch
Requires: python3-aws-cdk-lib
Requires: python3-constructs
Requires: python3-jsii
Requires: python3-publication
Requires: python3-typeguard
%description
[![NPM version](https://badge.fury.io/js/cdk-kubesphere.svg)](https://badge.fury.io/js/cdk-kubesphere)
[![PyPI version](https://badge.fury.io/py/cdk-kubesphere.svg)](https://badge.fury.io/py/cdk-kubesphere)
![Release](https://github.com/pahud/cdk-kubesphere/workflows/Release/badge.svg)
# cdk-kubesphere
**cdk-kubesphere** is a CDK construct library that allows you to create [KubeSphere](https://kubesphere.io/) on AWS with CDK in TypeScript, JavaScript or Python.
# Sample
```python
import { KubeSphere } from 'cdk-kubesphere';
const app = new cdk.App();
const stack = new cdk.Stack(app, 'cdk-kubesphere-demo');
// deploy a default KubeSphere service on a new Amazon EKS cluster
new KubeSphere(stack, 'KubeSphere');
```
Behind the scene, the `KubeSphere` construct creates a default Amazon EKS cluster and `KubeSphere` serivce with helm chart([ks-installer](https://github.com/kubesphere/ks-installer)) on it.
View helm command
AWS CDK will helm install the `ks-installer` on the cluster:
```sh
helm install ks-installer \
--repo https://charts.kubesphere.io/test \
--namespace=kubesphere-system \
--generate-name \
--create-namespace
```
## KubeSphere App Store
Use `appStore` to enable the [KubeSphere App Store](https://kubesphere.io/docs/pluggable-components/app-store/) support.
```python
new KubeSphere(stack, 'KubeSphere', {
appStore: true,
});
```
View helm command
AWS CDK will helm install the `ks-installer` on the cluster:
```sh
helm install ks-installer \
--set openpitrix.enabled=true \
--repo https://charts.kubesphere.io/test \
--namespace=kubesphere-system \
--generate-name \
--create-namespace
```
# Using existing Amazon EKS clusters
You are allowed to deploy `KubeSphere` in any existing Amazon EKS cluster.
```python
const cluster = eks.Cluster.fromClusterAttributes(this, 'MyCluster', {
clusterName: 'my-cluster-name',
kubectlRoleArn: 'arn:aws:iam::1111111:role/iam-role-that-has-masters-access',
});
// deploy a default KubeSphere service on the existing Amazon EKS cluster
new KubeSphere(stack, 'KubeSphere', { cluster });
```
See [Using existing clusters](https://github.com/aws/aws-cdk/tree/master/packages/%40aws-cdk/aws-eks#using-existing-clusters) to learn how to import existing cluster in AWS CDK.
# Console
Run the following command to create a `port-forward` from localhost:8888 to `ks-console:80`
```sh
kubectl -n kubesphere-system port-forward service/ks-console 8888:80
```
Open `http://localhost:8888` and enter the default username/password(`admin/P@88w0rd`) to enter the admin console.
%package -n python3-cdk-kubesphere
Summary: CDK construct library to deploy KubeSphere on AWS
Provides: python-cdk-kubesphere
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-cdk-kubesphere
[![NPM version](https://badge.fury.io/js/cdk-kubesphere.svg)](https://badge.fury.io/js/cdk-kubesphere)
[![PyPI version](https://badge.fury.io/py/cdk-kubesphere.svg)](https://badge.fury.io/py/cdk-kubesphere)
![Release](https://github.com/pahud/cdk-kubesphere/workflows/Release/badge.svg)
# cdk-kubesphere
**cdk-kubesphere** is a CDK construct library that allows you to create [KubeSphere](https://kubesphere.io/) on AWS with CDK in TypeScript, JavaScript or Python.
# Sample
```python
import { KubeSphere } from 'cdk-kubesphere';
const app = new cdk.App();
const stack = new cdk.Stack(app, 'cdk-kubesphere-demo');
// deploy a default KubeSphere service on a new Amazon EKS cluster
new KubeSphere(stack, 'KubeSphere');
```
Behind the scene, the `KubeSphere` construct creates a default Amazon EKS cluster and `KubeSphere` serivce with helm chart([ks-installer](https://github.com/kubesphere/ks-installer)) on it.
View helm command
AWS CDK will helm install the `ks-installer` on the cluster:
```sh
helm install ks-installer \
--repo https://charts.kubesphere.io/test \
--namespace=kubesphere-system \
--generate-name \
--create-namespace
```
## KubeSphere App Store
Use `appStore` to enable the [KubeSphere App Store](https://kubesphere.io/docs/pluggable-components/app-store/) support.
```python
new KubeSphere(stack, 'KubeSphere', {
appStore: true,
});
```
View helm command
AWS CDK will helm install the `ks-installer` on the cluster:
```sh
helm install ks-installer \
--set openpitrix.enabled=true \
--repo https://charts.kubesphere.io/test \
--namespace=kubesphere-system \
--generate-name \
--create-namespace
```
# Using existing Amazon EKS clusters
You are allowed to deploy `KubeSphere` in any existing Amazon EKS cluster.
```python
const cluster = eks.Cluster.fromClusterAttributes(this, 'MyCluster', {
clusterName: 'my-cluster-name',
kubectlRoleArn: 'arn:aws:iam::1111111:role/iam-role-that-has-masters-access',
});
// deploy a default KubeSphere service on the existing Amazon EKS cluster
new KubeSphere(stack, 'KubeSphere', { cluster });
```
See [Using existing clusters](https://github.com/aws/aws-cdk/tree/master/packages/%40aws-cdk/aws-eks#using-existing-clusters) to learn how to import existing cluster in AWS CDK.
# Console
Run the following command to create a `port-forward` from localhost:8888 to `ks-console:80`
```sh
kubectl -n kubesphere-system port-forward service/ks-console 8888:80
```
Open `http://localhost:8888` and enter the default username/password(`admin/P@88w0rd`) to enter the admin console.
%package help
Summary: Development documents and examples for cdk-kubesphere
Provides: python3-cdk-kubesphere-doc
%description help
[![NPM version](https://badge.fury.io/js/cdk-kubesphere.svg)](https://badge.fury.io/js/cdk-kubesphere)
[![PyPI version](https://badge.fury.io/py/cdk-kubesphere.svg)](https://badge.fury.io/py/cdk-kubesphere)
![Release](https://github.com/pahud/cdk-kubesphere/workflows/Release/badge.svg)
# cdk-kubesphere
**cdk-kubesphere** is a CDK construct library that allows you to create [KubeSphere](https://kubesphere.io/) on AWS with CDK in TypeScript, JavaScript or Python.
# Sample
```python
import { KubeSphere } from 'cdk-kubesphere';
const app = new cdk.App();
const stack = new cdk.Stack(app, 'cdk-kubesphere-demo');
// deploy a default KubeSphere service on a new Amazon EKS cluster
new KubeSphere(stack, 'KubeSphere');
```
Behind the scene, the `KubeSphere` construct creates a default Amazon EKS cluster and `KubeSphere` serivce with helm chart([ks-installer](https://github.com/kubesphere/ks-installer)) on it.
View helm command
AWS CDK will helm install the `ks-installer` on the cluster:
```sh
helm install ks-installer \
--repo https://charts.kubesphere.io/test \
--namespace=kubesphere-system \
--generate-name \
--create-namespace
```
## KubeSphere App Store
Use `appStore` to enable the [KubeSphere App Store](https://kubesphere.io/docs/pluggable-components/app-store/) support.
```python
new KubeSphere(stack, 'KubeSphere', {
appStore: true,
});
```
View helm command
AWS CDK will helm install the `ks-installer` on the cluster:
```sh
helm install ks-installer \
--set openpitrix.enabled=true \
--repo https://charts.kubesphere.io/test \
--namespace=kubesphere-system \
--generate-name \
--create-namespace
```
# Using existing Amazon EKS clusters
You are allowed to deploy `KubeSphere` in any existing Amazon EKS cluster.
```python
const cluster = eks.Cluster.fromClusterAttributes(this, 'MyCluster', {
clusterName: 'my-cluster-name',
kubectlRoleArn: 'arn:aws:iam::1111111:role/iam-role-that-has-masters-access',
});
// deploy a default KubeSphere service on the existing Amazon EKS cluster
new KubeSphere(stack, 'KubeSphere', { cluster });
```
See [Using existing clusters](https://github.com/aws/aws-cdk/tree/master/packages/%40aws-cdk/aws-eks#using-existing-clusters) to learn how to import existing cluster in AWS CDK.
# Console
Run the following command to create a `port-forward` from localhost:8888 to `ks-console:80`
```sh
kubectl -n kubesphere-system port-forward service/ks-console 8888:80
```
Open `http://localhost:8888` and enter the default username/password(`admin/P@88w0rd`) to enter the admin console.
%prep
%autosetup -n cdk-kubesphere-2.0.315
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-cdk-kubesphere -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 2.0.315-1
- Package Spec generated