%global _empty_manifest_terminate_build 0
Name: python-PyKrige
Version: 1.7.0
Release: 1
Summary: Kriging Toolkit for Python.
License: BSD-3-Clause
URL: https://github.com/GeoStat-Framework/PyKrige
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2c/d4/712e81c60423a036442acd11f30590c101b579de5e3531633b93b84b0112/PyKrige-1.7.0.tar.gz
Requires: python3-numpy
Requires: python3-scipy
Requires: python3-gstools
Requires: python3-scipy
Requires: python3-pillow
Requires: python3-scikit-learn
Requires: python3-m2r2
Requires: python3-matplotlib
Requires: python3-numpydoc
Requires: python3-sphinx
Requires: python3-sphinx-gallery
Requires: python3-sphinx-rtd-theme
Requires: python3-matplotlib
Requires: python3-scikit-learn
Requires: python3-pytest-cov
Requires: python3-scikit-learn
Requires: python3-gstools
%description
# PyKrige
[![DOI](https://zenodo.org/badge/DOI/10.5281/zenodo.3738604.svg)](https://doi.org/10.5281/zenodo.3738604)
[![PyPI version](https://badge.fury.io/py/PyKrige.svg)](https://badge.fury.io/py/PyKrige)
[![Conda Version](https://img.shields.io/conda/vn/conda-forge/pykrige.svg)](https://anaconda.org/conda-forge/pykrige)
[![Build Status](https://github.com/GeoStat-Framework/PyKrige/workflows/Continuous%20Integration/badge.svg?branch=main)](https://github.com/GeoStat-Framework/PyKrige/actions)
[![Coverage Status](https://coveralls.io/repos/github/GeoStat-Framework/PyKrige/badge.svg?branch=main)](https://coveralls.io/github/GeoStat-Framework/PyKrige?branch=main)
[![Documentation Status](https://readthedocs.org/projects/pykrige/badge/?version=stable)](http://pykrige.readthedocs.io/en/stable/?badge=stable)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
Kriging Toolkit for Python.
## Purpose
The code supports 2D and 3D ordinary and universal kriging. Standard
variogram models (linear, power, spherical, gaussian, exponential) are
built in, but custom variogram models can also be used. The 2D universal
kriging code currently supports regional-linear, point-logarithmic, and
external drift terms, while the 3D universal kriging code supports a
regional-linear drift term in all three spatial dimensions. Both
universal kriging classes also support generic 'specified' and
'functional' drift capabilities. With the 'specified' drift capability,
the user may manually specify the values of the drift(s) at each data
point and all grid points. With the 'functional' drift capability, the
user may provide callable function(s) of the spatial coordinates that
define the drift(s). The package includes a module that contains
functions that should be useful in working with ASCII grid files (`\*.asc`).
See the documentation at for more
details and examples.
## Installation
PyKrige requires Python 3.5+ as well as numpy, scipy. It can be
installed from PyPi with,
``` bash
pip install pykrige
```
scikit-learn is an optional dependency needed for parameter tuning and
regression kriging. matplotlib is an optional dependency needed for
plotting.
If you use conda, PyKrige can be installed from the conda-forge channel with,
``` bash
conda install -c conda-forge pykrige
```
## Features
### Kriging algorithms
- `OrdinaryKriging`: 2D ordinary kriging with estimated mean
- `UniversalKriging`: 2D universal kriging providing drift terms
- `OrdinaryKriging3D`: 3D ordinary kriging
- `UniversalKriging3D`: 3D universal kriging
- `RegressionKriging`: An implementation of Regression-Kriging
- `ClassificationKriging`: An implementation of Simplicial Indicator
Kriging
### Wrappers
- `rk.Krige`: A scikit-learn wrapper class for Ordinary and Universal
Kriging
### Tools
- `kriging_tools.write_asc_grid`: Writes gridded data to ASCII grid file (`\*.asc`)
- `kriging_tools.read_asc_grid`: Reads ASCII grid file (`\*.asc`)
- `kriging_tools.write_zmap_grid`: Writes gridded data to zmap file (`\*.zmap`)
- `kriging_tools.read_zmap_grid`: Reads zmap file (`\*.zmap`)
### Kriging Parameters Tuning
A scikit-learn compatible API for parameter tuning by cross-validation
is exposed in
[sklearn.model\_selection.GridSearchCV](http://scikit-learn.org/stable/modules/generated/sklearn.model_selection.GridSearchCV.html).
See the [Krige
CV](http://pykrige.readthedocs.io/en/latest/examples/08_krige_cv.html#sphx-glr-examples-08-krige-cv-py)
example for a more practical illustration.
### Regression Kriging
[Regression kriging](https://en.wikipedia.org/wiki/Regression-Kriging)
can be performed with
[pykrige.rk.RegressionKriging](http://pykrige.readthedocs.io/en/latest/examples/07_regression_kriging2d.html).
This class takes as parameters a scikit-learn regression model, and
details of either the `OrdinaryKriging` or the `UniversalKriging`
class, and performs a correction step on the ML regression prediction.
A demonstration of the regression kriging is provided in the
[corresponding
example](http://pykrige.readthedocs.io/en/latest/examples/07_regression_kriging2d.html#sphx-glr-examples-07-regression-kriging2d-py).
### Classification Kriging
[Simplifical Indicator
kriging](https://www.sciencedirect.com/science/article/abs/pii/S1002070508600254)
can be performed with
[pykrige.ck.ClassificationKriging](http://pykrige.readthedocs.io/en/latest/examples/10_classification_kriging2d.html).
This class takes as parameters a scikit-learn classification model, and
details of either the `OrdinaryKriging` or the `UniversalKriging` class,
and performs a correction step on the ML classification prediction.
A demonstration of the classification kriging is provided in the
[corresponding
example](http://pykrige.readthedocs.io/en/latest/examples/10_classification_kriging2d.html#sphx-glr-examples-10-classification-kriging2d-py).
## License
PyKrige uses the BSD 3-Clause License.
%package -n python3-PyKrige
Summary: Kriging Toolkit for Python.
Provides: python-PyKrige
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-PyKrige
# PyKrige
[![DOI](https://zenodo.org/badge/DOI/10.5281/zenodo.3738604.svg)](https://doi.org/10.5281/zenodo.3738604)
[![PyPI version](https://badge.fury.io/py/PyKrige.svg)](https://badge.fury.io/py/PyKrige)
[![Conda Version](https://img.shields.io/conda/vn/conda-forge/pykrige.svg)](https://anaconda.org/conda-forge/pykrige)
[![Build Status](https://github.com/GeoStat-Framework/PyKrige/workflows/Continuous%20Integration/badge.svg?branch=main)](https://github.com/GeoStat-Framework/PyKrige/actions)
[![Coverage Status](https://coveralls.io/repos/github/GeoStat-Framework/PyKrige/badge.svg?branch=main)](https://coveralls.io/github/GeoStat-Framework/PyKrige?branch=main)
[![Documentation Status](https://readthedocs.org/projects/pykrige/badge/?version=stable)](http://pykrige.readthedocs.io/en/stable/?badge=stable)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
Kriging Toolkit for Python.
## Purpose
The code supports 2D and 3D ordinary and universal kriging. Standard
variogram models (linear, power, spherical, gaussian, exponential) are
built in, but custom variogram models can also be used. The 2D universal
kriging code currently supports regional-linear, point-logarithmic, and
external drift terms, while the 3D universal kriging code supports a
regional-linear drift term in all three spatial dimensions. Both
universal kriging classes also support generic 'specified' and
'functional' drift capabilities. With the 'specified' drift capability,
the user may manually specify the values of the drift(s) at each data
point and all grid points. With the 'functional' drift capability, the
user may provide callable function(s) of the spatial coordinates that
define the drift(s). The package includes a module that contains
functions that should be useful in working with ASCII grid files (`\*.asc`).
See the documentation at for more
details and examples.
## Installation
PyKrige requires Python 3.5+ as well as numpy, scipy. It can be
installed from PyPi with,
``` bash
pip install pykrige
```
scikit-learn is an optional dependency needed for parameter tuning and
regression kriging. matplotlib is an optional dependency needed for
plotting.
If you use conda, PyKrige can be installed from the conda-forge channel with,
``` bash
conda install -c conda-forge pykrige
```
## Features
### Kriging algorithms
- `OrdinaryKriging`: 2D ordinary kriging with estimated mean
- `UniversalKriging`: 2D universal kriging providing drift terms
- `OrdinaryKriging3D`: 3D ordinary kriging
- `UniversalKriging3D`: 3D universal kriging
- `RegressionKriging`: An implementation of Regression-Kriging
- `ClassificationKriging`: An implementation of Simplicial Indicator
Kriging
### Wrappers
- `rk.Krige`: A scikit-learn wrapper class for Ordinary and Universal
Kriging
### Tools
- `kriging_tools.write_asc_grid`: Writes gridded data to ASCII grid file (`\*.asc`)
- `kriging_tools.read_asc_grid`: Reads ASCII grid file (`\*.asc`)
- `kriging_tools.write_zmap_grid`: Writes gridded data to zmap file (`\*.zmap`)
- `kriging_tools.read_zmap_grid`: Reads zmap file (`\*.zmap`)
### Kriging Parameters Tuning
A scikit-learn compatible API for parameter tuning by cross-validation
is exposed in
[sklearn.model\_selection.GridSearchCV](http://scikit-learn.org/stable/modules/generated/sklearn.model_selection.GridSearchCV.html).
See the [Krige
CV](http://pykrige.readthedocs.io/en/latest/examples/08_krige_cv.html#sphx-glr-examples-08-krige-cv-py)
example for a more practical illustration.
### Regression Kriging
[Regression kriging](https://en.wikipedia.org/wiki/Regression-Kriging)
can be performed with
[pykrige.rk.RegressionKriging](http://pykrige.readthedocs.io/en/latest/examples/07_regression_kriging2d.html).
This class takes as parameters a scikit-learn regression model, and
details of either the `OrdinaryKriging` or the `UniversalKriging`
class, and performs a correction step on the ML regression prediction.
A demonstration of the regression kriging is provided in the
[corresponding
example](http://pykrige.readthedocs.io/en/latest/examples/07_regression_kriging2d.html#sphx-glr-examples-07-regression-kriging2d-py).
### Classification Kriging
[Simplifical Indicator
kriging](https://www.sciencedirect.com/science/article/abs/pii/S1002070508600254)
can be performed with
[pykrige.ck.ClassificationKriging](http://pykrige.readthedocs.io/en/latest/examples/10_classification_kriging2d.html).
This class takes as parameters a scikit-learn classification model, and
details of either the `OrdinaryKriging` or the `UniversalKriging` class,
and performs a correction step on the ML classification prediction.
A demonstration of the classification kriging is provided in the
[corresponding
example](http://pykrige.readthedocs.io/en/latest/examples/10_classification_kriging2d.html#sphx-glr-examples-10-classification-kriging2d-py).
## License
PyKrige uses the BSD 3-Clause License.
%package help
Summary: Development documents and examples for PyKrige
Provides: python3-PyKrige-doc
%description help
# PyKrige
[![DOI](https://zenodo.org/badge/DOI/10.5281/zenodo.3738604.svg)](https://doi.org/10.5281/zenodo.3738604)
[![PyPI version](https://badge.fury.io/py/PyKrige.svg)](https://badge.fury.io/py/PyKrige)
[![Conda Version](https://img.shields.io/conda/vn/conda-forge/pykrige.svg)](https://anaconda.org/conda-forge/pykrige)
[![Build Status](https://github.com/GeoStat-Framework/PyKrige/workflows/Continuous%20Integration/badge.svg?branch=main)](https://github.com/GeoStat-Framework/PyKrige/actions)
[![Coverage Status](https://coveralls.io/repos/github/GeoStat-Framework/PyKrige/badge.svg?branch=main)](https://coveralls.io/github/GeoStat-Framework/PyKrige?branch=main)
[![Documentation Status](https://readthedocs.org/projects/pykrige/badge/?version=stable)](http://pykrige.readthedocs.io/en/stable/?badge=stable)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
Kriging Toolkit for Python.
## Purpose
The code supports 2D and 3D ordinary and universal kriging. Standard
variogram models (linear, power, spherical, gaussian, exponential) are
built in, but custom variogram models can also be used. The 2D universal
kriging code currently supports regional-linear, point-logarithmic, and
external drift terms, while the 3D universal kriging code supports a
regional-linear drift term in all three spatial dimensions. Both
universal kriging classes also support generic 'specified' and
'functional' drift capabilities. With the 'specified' drift capability,
the user may manually specify the values of the drift(s) at each data
point and all grid points. With the 'functional' drift capability, the
user may provide callable function(s) of the spatial coordinates that
define the drift(s). The package includes a module that contains
functions that should be useful in working with ASCII grid files (`\*.asc`).
See the documentation at for more
details and examples.
## Installation
PyKrige requires Python 3.5+ as well as numpy, scipy. It can be
installed from PyPi with,
``` bash
pip install pykrige
```
scikit-learn is an optional dependency needed for parameter tuning and
regression kriging. matplotlib is an optional dependency needed for
plotting.
If you use conda, PyKrige can be installed from the conda-forge channel with,
``` bash
conda install -c conda-forge pykrige
```
## Features
### Kriging algorithms
- `OrdinaryKriging`: 2D ordinary kriging with estimated mean
- `UniversalKriging`: 2D universal kriging providing drift terms
- `OrdinaryKriging3D`: 3D ordinary kriging
- `UniversalKriging3D`: 3D universal kriging
- `RegressionKriging`: An implementation of Regression-Kriging
- `ClassificationKriging`: An implementation of Simplicial Indicator
Kriging
### Wrappers
- `rk.Krige`: A scikit-learn wrapper class for Ordinary and Universal
Kriging
### Tools
- `kriging_tools.write_asc_grid`: Writes gridded data to ASCII grid file (`\*.asc`)
- `kriging_tools.read_asc_grid`: Reads ASCII grid file (`\*.asc`)
- `kriging_tools.write_zmap_grid`: Writes gridded data to zmap file (`\*.zmap`)
- `kriging_tools.read_zmap_grid`: Reads zmap file (`\*.zmap`)
### Kriging Parameters Tuning
A scikit-learn compatible API for parameter tuning by cross-validation
is exposed in
[sklearn.model\_selection.GridSearchCV](http://scikit-learn.org/stable/modules/generated/sklearn.model_selection.GridSearchCV.html).
See the [Krige
CV](http://pykrige.readthedocs.io/en/latest/examples/08_krige_cv.html#sphx-glr-examples-08-krige-cv-py)
example for a more practical illustration.
### Regression Kriging
[Regression kriging](https://en.wikipedia.org/wiki/Regression-Kriging)
can be performed with
[pykrige.rk.RegressionKriging](http://pykrige.readthedocs.io/en/latest/examples/07_regression_kriging2d.html).
This class takes as parameters a scikit-learn regression model, and
details of either the `OrdinaryKriging` or the `UniversalKriging`
class, and performs a correction step on the ML regression prediction.
A demonstration of the regression kriging is provided in the
[corresponding
example](http://pykrige.readthedocs.io/en/latest/examples/07_regression_kriging2d.html#sphx-glr-examples-07-regression-kriging2d-py).
### Classification Kriging
[Simplifical Indicator
kriging](https://www.sciencedirect.com/science/article/abs/pii/S1002070508600254)
can be performed with
[pykrige.ck.ClassificationKriging](http://pykrige.readthedocs.io/en/latest/examples/10_classification_kriging2d.html).
This class takes as parameters a scikit-learn classification model, and
details of either the `OrdinaryKriging` or the `UniversalKriging` class,
and performs a correction step on the ML classification prediction.
A demonstration of the classification kriging is provided in the
[corresponding
example](http://pykrige.readthedocs.io/en/latest/examples/10_classification_kriging2d.html#sphx-glr-examples-10-classification-kriging2d-py).
## License
PyKrige uses the BSD 3-Clause License.
%prep
%autosetup -n PyKrige-1.7.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-PyKrige -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 1.7.0-1
- Package Spec generated