%global _empty_manifest_terminate_build 0
Name: python-pyreadr
Version: 0.4.7
Release: 1
Summary: Reads/writes R RData and Rds files into/from pandas data frames.
License: AGPLv3
URL: https://github.com/ofajardo/pyreadr
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/42/eb/5c1eda6f61ddb3d31119eb6669491601bc8da9ee5030b386e51644ab5001/pyreadr-0.4.7.tar.gz
Requires: python3-pandas
%description
A Python package to read and write R RData and Rds files
into/from pandas data frames. It does not need to have R or other external
dependencies installed.
It is based on the C library librdata and
a modified version of the cython wrapper jamovi-readstat.
Please visit out project home page for more information:
https://github.com/ofajardo/pyreadr
%package -n python3-pyreadr
Summary: Reads/writes R RData and Rds files into/from pandas data frames.
Provides: python-pyreadr
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-pyreadr
A Python package to read and write R RData and Rds files
into/from pandas data frames. It does not need to have R or other external
dependencies installed.
It is based on the C library librdata and
a modified version of the cython wrapper jamovi-readstat.
Please visit out project home page for more information:
https://github.com/ofajardo/pyreadr
%package help
Summary: Development documents and examples for pyreadr
Provides: python3-pyreadr-doc
%description help
A Python package to read and write R RData and Rds files
into/from pandas data frames. It does not need to have R or other external
dependencies installed.
It is based on the C library librdata and
a modified version of the cython wrapper jamovi-readstat.
Please visit out project home page for more information:
https://github.com/ofajardo/pyreadr
%prep
%autosetup -n pyreadr-0.4.7
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pyreadr -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 0.4.7-1
- Package Spec generated