%global _empty_manifest_terminate_build 0 Name: python-values Version: 2020.12.3 Release: 1 Summary: values.get(input) - create list from input License: Unlicense URL: https://github.com/andrewp-as-is/values.py Source0: https://mirrors.nju.edu.cn/pypi/web/packages/cc/18/952219903bde3175113927866c19b536cfcea3259cd4e3fdacb8604723f6/values-2020.12.3.tar.gz BuildArch: noarch %description [![](https://img.shields.io/pypi/v/values.svg?maxAge=3600)](https://pypi.org/project/values/) [![](https://img.shields.io/badge/License-Unlicense-blue.svg?longCache=True)](https://unlicense.org/) ### Installation ```bash $ [sudo] pip install values ``` #### Examples ```python >>> import values >>> values.get(1) [1] >>> values.get("string") ["string"] >>> values.get([1,2]) [1,2] >>> values.get(None) [] ```

readme42.com

%package -n python3-values Summary: values.get(input) - create list from input Provides: python-values BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-values [![](https://img.shields.io/pypi/v/values.svg?maxAge=3600)](https://pypi.org/project/values/) [![](https://img.shields.io/badge/License-Unlicense-blue.svg?longCache=True)](https://unlicense.org/) ### Installation ```bash $ [sudo] pip install values ``` #### Examples ```python >>> import values >>> values.get(1) [1] >>> values.get("string") ["string"] >>> values.get([1,2]) [1,2] >>> values.get(None) [] ```

readme42.com

%package help Summary: Development documents and examples for values Provides: python3-values-doc %description help [![](https://img.shields.io/pypi/v/values.svg?maxAge=3600)](https://pypi.org/project/values/) [![](https://img.shields.io/badge/License-Unlicense-blue.svg?longCache=True)](https://unlicense.org/) ### Installation ```bash $ [sudo] pip install values ``` #### Examples ```python >>> import values >>> values.get(1) [1] >>> values.get("string") ["string"] >>> values.get([1,2]) [1,2] >>> values.get(None) [] ```

readme42.com

%prep %autosetup -n values-2020.12.3 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-values -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Tue Apr 25 2023 Python_Bot - 2020.12.3-1 - Package Spec generated