%global _empty_manifest_terminate_build 0
Name: python-pypotrace
Version: 0.3
Release: 1
Summary: potrace Python bindings
License: GPL
URL: https://pypi.org/project/pypotrace/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d7/58/bcd8a2b090e51100e690c61c245974b923911255757fd3367f0aa8c2c0cb/pypotrace-0.3.tar.gz
BuildArch: noarch
Requires: python3-numpy
%description
These bindings provide an object oriented API to the `potrace`_ library.
The full API documentation is on ``_.
%package -n python3-pypotrace
Summary: potrace Python bindings
Provides: python-pypotrace
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pypotrace
These bindings provide an object oriented API to the `potrace`_ library.
The full API documentation is on ``_.
%package help
Summary: Development documents and examples for pypotrace
Provides: python3-pypotrace-doc
%description help
These bindings provide an object oriented API to the `potrace`_ library.
The full API documentation is on ``_.
%prep
%autosetup -n pypotrace-0.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pypotrace -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 25 2023 Python_Bot - 0.3-1
- Package Spec generated