%global _empty_manifest_terminate_build 0
Name: python-fastkml
Version: 0.12
Release: 1
Summary: Fast KML processing in python
License: LGPL
URL: https://github.com/cleder/fastkml
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/93/ef/6ed974aa4e014d05a609870d771acb6fe5f4c820d248a883b739595f001c/fastkml-0.12.tar.gz
BuildArch: noarch
Requires: python3-pygeoif
Requires: python3-dateutil
%description
Fastkml is a library to read, write and manipulate KML files. It aims to keep
it simple and fast (using lxml_ if available). Fast refers to the time you
spend to write and read KML files as well as the time you spend to get
aquainted to the library or to create KML objects. It aims to provide all of
the functionality that KML clients such as `OpenLayers
`_, `Google Maps `_, and
`Google Earth `_ provides.
Geometries are handled as pygeoif_ or, if installed, shapely_ objects.
Fastkml is continually tested
Is Maintained and documented:
Supports python 2 and 3:
%package -n python3-fastkml
Summary: Fast KML processing in python
Provides: python-fastkml
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-fastkml
Fastkml is a library to read, write and manipulate KML files. It aims to keep
it simple and fast (using lxml_ if available). Fast refers to the time you
spend to write and read KML files as well as the time you spend to get
aquainted to the library or to create KML objects. It aims to provide all of
the functionality that KML clients such as `OpenLayers
`_, `Google Maps `_, and
`Google Earth `_ provides.
Geometries are handled as pygeoif_ or, if installed, shapely_ objects.
Fastkml is continually tested
Is Maintained and documented:
Supports python 2 and 3:
%package help
Summary: Development documents and examples for fastkml
Provides: python3-fastkml-doc
%description help
Fastkml is a library to read, write and manipulate KML files. It aims to keep
it simple and fast (using lxml_ if available). Fast refers to the time you
spend to write and read KML files as well as the time you spend to get
aquainted to the library or to create KML objects. It aims to provide all of
the functionality that KML clients such as `OpenLayers
`_, `Google Maps `_, and
`Google Earth `_ provides.
Geometries are handled as pygeoif_ or, if installed, shapely_ objects.
Fastkml is continually tested
Is Maintained and documented:
Supports python 2 and 3:
%prep
%autosetup -n fastkml-0.12
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-fastkml -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 25 2023 Python_Bot - 0.12-1
- Package Spec generated