%global _empty_manifest_terminate_build 0
Name: python-jovian
Version: 0.2.47
Release: 1
Summary: Jovian Python SDK
License: MIT License
URL: https://jovian.ai/?utm_source=pypi
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ec/14/8f24f3d3952be12e671dcc60bc16814b523323ed5b237a4aa9b26d28b5c6/jovian-0.2.47.tar.gz
BuildArch: noarch
Requires: python3-requests
Requires: python3-uuid
Requires: python3-pyyaml
Requires: python3-click
%description
# Jovian: Learning Platform for Data Science & ML.
[![Documentation Status](https://readthedocs.org/projects/jovian-py/badge/?version=latest)](https://jovian.ai/docs/)
[![Python application](https://github.com/JovianML/jovian-py/workflows/Python%20application/badge.svg)](https://github.com/JovianML/jovian-py/actions?query=branch%3Amaster)
[![Code Coverage](https://codecov.io/gh/JovianML/jovian-py/branch/master/graph/badge.svg)](https://codecov.io/gh/JovianML/jovian-py)
[Jovian](https://www.jovian.ai?utm_source) is a platform for sharing and collaboraring on Jupyter notebooks and data science projects. `jovian-py` is an open-source Python package for uploading your data science code, Jupyter notebooks, ML models, hyperparameters, metrics etc. to your Jovian account.
- [Upload and share Jupyter Notebooks](https://jovian.ai/docs/user-guide/upload.html)
- [Reproduce Notebooks from Jovian](https://jovian.ai/docs/user-guide/reproduce.html)
- [Notebooks as version, view Diffs between versions](https://jovian.ai/docs/user-guide/version.html)
- [Attaching utility files and model outputs with the Notebook](https://jovian.ai/docs/user-guide/attach.html)
- [Tracking Datasets, Hyperparameters and Metrics](https://jovian.ai/docs/user-guide/track.html)
- [Comparing and Analyzing all the experiments](https://jovian.ai/docs/user-guide/compare.html)
- [Collaborate with teammates/colleagues](https://jovian.ai/docs/user-guide/collaborate.html)
- [Stay connected with your model training, live updates with Slack Notifications](https://jovian.ai/docs/user-guide/integrations.html)
- [Embed Jupyter Notebooks and Cell upload on Jovian](https://jovian.ai/docs/user-guide/embed.html)
## Installation
```
pip install jovian --upgrade
```
> **Caution**:
>
> If you get a `Permission denied` error, try installing with sudo permission (on Linux/Mac).
>
> ```
> sudo pip install jovian --upgrade
> ```
>
> Another alternative is to try installing with the `--user` flag, but you’ll need to ensure that the target directory is added to your system `PATH`.
>
> ```
> pip install jovian --upgrade --user
> ```
Visit [Docs](https://jovian.ai/docs/) for more.
## Contribution Guidelines
If you want to contribute to **jovian**(Python package), review the [**Contribution Page**](https://github.com/JovianML/jovian-py/blob/master/CONTRIBUTING.md).
## Contact
Mail : hello@jovian.ai
Forum: [Data Science Forum](https://jovian.ai/forum/)
Twitter : [@JovianML](https://twitter.com/JovianML)
YouTube: [YouTube Channel](https://www.youtube.com/jovianml)
LinkedIn: [LinkedIn Page](https://www.linkedin.com/company/jovianml/)
%package -n python3-jovian
Summary: Jovian Python SDK
Provides: python-jovian
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-jovian
# Jovian: Learning Platform for Data Science & ML.
[![Documentation Status](https://readthedocs.org/projects/jovian-py/badge/?version=latest)](https://jovian.ai/docs/)
[![Python application](https://github.com/JovianML/jovian-py/workflows/Python%20application/badge.svg)](https://github.com/JovianML/jovian-py/actions?query=branch%3Amaster)
[![Code Coverage](https://codecov.io/gh/JovianML/jovian-py/branch/master/graph/badge.svg)](https://codecov.io/gh/JovianML/jovian-py)
[Jovian](https://www.jovian.ai?utm_source) is a platform for sharing and collaboraring on Jupyter notebooks and data science projects. `jovian-py` is an open-source Python package for uploading your data science code, Jupyter notebooks, ML models, hyperparameters, metrics etc. to your Jovian account.
- [Upload and share Jupyter Notebooks](https://jovian.ai/docs/user-guide/upload.html)
- [Reproduce Notebooks from Jovian](https://jovian.ai/docs/user-guide/reproduce.html)
- [Notebooks as version, view Diffs between versions](https://jovian.ai/docs/user-guide/version.html)
- [Attaching utility files and model outputs with the Notebook](https://jovian.ai/docs/user-guide/attach.html)
- [Tracking Datasets, Hyperparameters and Metrics](https://jovian.ai/docs/user-guide/track.html)
- [Comparing and Analyzing all the experiments](https://jovian.ai/docs/user-guide/compare.html)
- [Collaborate with teammates/colleagues](https://jovian.ai/docs/user-guide/collaborate.html)
- [Stay connected with your model training, live updates with Slack Notifications](https://jovian.ai/docs/user-guide/integrations.html)
- [Embed Jupyter Notebooks and Cell upload on Jovian](https://jovian.ai/docs/user-guide/embed.html)
## Installation
```
pip install jovian --upgrade
```
> **Caution**:
>
> If you get a `Permission denied` error, try installing with sudo permission (on Linux/Mac).
>
> ```
> sudo pip install jovian --upgrade
> ```
>
> Another alternative is to try installing with the `--user` flag, but you’ll need to ensure that the target directory is added to your system `PATH`.
>
> ```
> pip install jovian --upgrade --user
> ```
Visit [Docs](https://jovian.ai/docs/) for more.
## Contribution Guidelines
If you want to contribute to **jovian**(Python package), review the [**Contribution Page**](https://github.com/JovianML/jovian-py/blob/master/CONTRIBUTING.md).
## Contact
Mail : hello@jovian.ai
Forum: [Data Science Forum](https://jovian.ai/forum/)
Twitter : [@JovianML](https://twitter.com/JovianML)
YouTube: [YouTube Channel](https://www.youtube.com/jovianml)
LinkedIn: [LinkedIn Page](https://www.linkedin.com/company/jovianml/)
%package help
Summary: Development documents and examples for jovian
Provides: python3-jovian-doc
%description help
# Jovian: Learning Platform for Data Science & ML.
[![Documentation Status](https://readthedocs.org/projects/jovian-py/badge/?version=latest)](https://jovian.ai/docs/)
[![Python application](https://github.com/JovianML/jovian-py/workflows/Python%20application/badge.svg)](https://github.com/JovianML/jovian-py/actions?query=branch%3Amaster)
[![Code Coverage](https://codecov.io/gh/JovianML/jovian-py/branch/master/graph/badge.svg)](https://codecov.io/gh/JovianML/jovian-py)
[Jovian](https://www.jovian.ai?utm_source) is a platform for sharing and collaboraring on Jupyter notebooks and data science projects. `jovian-py` is an open-source Python package for uploading your data science code, Jupyter notebooks, ML models, hyperparameters, metrics etc. to your Jovian account.
- [Upload and share Jupyter Notebooks](https://jovian.ai/docs/user-guide/upload.html)
- [Reproduce Notebooks from Jovian](https://jovian.ai/docs/user-guide/reproduce.html)
- [Notebooks as version, view Diffs between versions](https://jovian.ai/docs/user-guide/version.html)
- [Attaching utility files and model outputs with the Notebook](https://jovian.ai/docs/user-guide/attach.html)
- [Tracking Datasets, Hyperparameters and Metrics](https://jovian.ai/docs/user-guide/track.html)
- [Comparing and Analyzing all the experiments](https://jovian.ai/docs/user-guide/compare.html)
- [Collaborate with teammates/colleagues](https://jovian.ai/docs/user-guide/collaborate.html)
- [Stay connected with your model training, live updates with Slack Notifications](https://jovian.ai/docs/user-guide/integrations.html)
- [Embed Jupyter Notebooks and Cell upload on Jovian](https://jovian.ai/docs/user-guide/embed.html)
## Installation
```
pip install jovian --upgrade
```
> **Caution**:
>
> If you get a `Permission denied` error, try installing with sudo permission (on Linux/Mac).
>
> ```
> sudo pip install jovian --upgrade
> ```
>
> Another alternative is to try installing with the `--user` flag, but you’ll need to ensure that the target directory is added to your system `PATH`.
>
> ```
> pip install jovian --upgrade --user
> ```
Visit [Docs](https://jovian.ai/docs/) for more.
## Contribution Guidelines
If you want to contribute to **jovian**(Python package), review the [**Contribution Page**](https://github.com/JovianML/jovian-py/blob/master/CONTRIBUTING.md).
## Contact
Mail : hello@jovian.ai
Forum: [Data Science Forum](https://jovian.ai/forum/)
Twitter : [@JovianML](https://twitter.com/JovianML)
YouTube: [YouTube Channel](https://www.youtube.com/jovianml)
LinkedIn: [LinkedIn Page](https://www.linkedin.com/company/jovianml/)
%prep
%autosetup -n jovian-0.2.47
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-jovian -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 25 2023 Python_Bot - 0.2.47-1
- Package Spec generated