%global _empty_manifest_terminate_build 0
Name:		python-sqlalchemy-postgres-copy
Version:	0.5.0
Release:	1
Summary:	Utilities for using PostgreSQL COPY with SQLAlchemy
License:	Copyright 2016 Joshua Carp
URL:		https://github.com/jmcarp/sqlalchemy-postgres-copy
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/0e/f7/ef7b8ad0c0793cb8cc4e41e53ca055d58b4698b79c530fb8cd2bd0970192/sqlalchemy-postgres-copy-0.5.0.tar.gz
BuildArch:	noarch

Requires:	python3-psycopg2
Requires:	python3-six
Requires:	python3-sqlalchemy

%description
        **sqlalchemy-postgres-copy** is a utility library that wraps the PostgreSQL COPY_ command for use with SQLAlchemy. The COPY command offers performant exports from PostgreSQL to TSV, CSV, or binary files, as well as imports from files to PostgresSQL tables. Using COPY is typically much more efficient than importing and exporting data using Python.

%package -n python3-sqlalchemy-postgres-copy
Summary:	Utilities for using PostgreSQL COPY with SQLAlchemy
Provides:	python-sqlalchemy-postgres-copy
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-sqlalchemy-postgres-copy
        **sqlalchemy-postgres-copy** is a utility library that wraps the PostgreSQL COPY_ command for use with SQLAlchemy. The COPY command offers performant exports from PostgreSQL to TSV, CSV, or binary files, as well as imports from files to PostgresSQL tables. Using COPY is typically much more efficient than importing and exporting data using Python.

%package help
Summary:	Development documents and examples for sqlalchemy-postgres-copy
Provides:	python3-sqlalchemy-postgres-copy-doc
%description help
        **sqlalchemy-postgres-copy** is a utility library that wraps the PostgreSQL COPY_ command for use with SQLAlchemy. The COPY command offers performant exports from PostgreSQL to TSV, CSV, or binary files, as well as imports from files to PostgresSQL tables. Using COPY is typically much more efficient than importing and exporting data using Python.

%prep
%autosetup -n sqlalchemy-postgres-copy-0.5.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-sqlalchemy-postgres-copy -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 25 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.0-1
- Package Spec generated