%global _empty_manifest_terminate_build 0
Name: python-pathmatch
Version: 0.2.2
Release: 1
Summary: Path matching utilities
License: MIT License
URL: https://github.com/demurgos/py-pathmatch
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ed/98/7ef76707728a9f82c30917e807e0e6d5925c6f1b90913c8bef36f30795c0/pathmatch-0.2.2.tar.gz
BuildArch: noarch
%description
Python implementation of ``git``'s ``wildmatch`` and `POSIX.1-2008 `_ ``fnmatch``.
The aim of this package is to provide a file matching module complying with the POSIX standard and
allow compatibility with ``git``.
%package -n python3-pathmatch
Summary: Path matching utilities
Provides: python-pathmatch
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pathmatch
Python implementation of ``git``'s ``wildmatch`` and `POSIX.1-2008 `_ ``fnmatch``.
The aim of this package is to provide a file matching module complying with the POSIX standard and
allow compatibility with ``git``.
%package help
Summary: Development documents and examples for pathmatch
Provides: python3-pathmatch-doc
%description help
Python implementation of ``git``'s ``wildmatch`` and `POSIX.1-2008 `_ ``fnmatch``.
The aim of this package is to provide a file matching module complying with the POSIX standard and
allow compatibility with ``git``.
%prep
%autosetup -n pathmatch-0.2.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pathmatch -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 25 2023 Python_Bot - 0.2.2-1
- Package Spec generated