%global _empty_manifest_terminate_build 0
Name: python-facexlib
Version: 0.3.0
Release: 1
Summary: Basic face library
License: Apache License 2.0
URL: https://github.com/xinntao/facexlib
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e1/93/c820cd2c6315b635934770808e0b01ed4db257ec33bcf803909dcf4bce15/facexlib-0.3.0.tar.gz
BuildArch: noarch
Requires: python3-filterpy
Requires: python3-numba
Requires: python3-numpy
Requires: python3-opencv-python
Requires: python3-Pillow
Requires: python3-scipy
Requires: python3-torch
Requires: python3-torchvision
Requires: python3-tqdm
%description
**facexlib** aims at providing ready-to-use **face-related** functions based on current SOTA open-source methods.
Only PyTorch reference codes are available. For training or fine-tuning, please refer to their original repositories listed below.
Note that we just provide a collection of these algorithms. You need to refer to their original LICENCEs for your intended use.
If facexlib is helpful in your projects, please help to :star: this repo. Thanks:blush:
%package -n python3-facexlib
Summary: Basic face library
Provides: python-facexlib
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-facexlib
**facexlib** aims at providing ready-to-use **face-related** functions based on current SOTA open-source methods.
Only PyTorch reference codes are available. For training or fine-tuning, please refer to their original repositories listed below.
Note that we just provide a collection of these algorithms. You need to refer to their original LICENCEs for your intended use.
If facexlib is helpful in your projects, please help to :star: this repo. Thanks:blush:
%package help
Summary: Development documents and examples for facexlib
Provides: python3-facexlib-doc
%description help
**facexlib** aims at providing ready-to-use **face-related** functions based on current SOTA open-source methods.
Only PyTorch reference codes are available. For training or fine-tuning, please refer to their original repositories listed below.
Note that we just provide a collection of these algorithms. You need to refer to their original LICENCEs for your intended use.
If facexlib is helpful in your projects, please help to :star: this repo. Thanks:blush:
%prep
%autosetup -n facexlib-0.3.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-facexlib -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 25 2023 Python_Bot - 0.3.0-1
- Package Spec generated