%global _empty_manifest_terminate_build 0
Name: python-keepa
Version: 1.3.5
Release: 1
Summary: Interfaces with keepa.com
License: Apache Software License
URL: https://github.com/akaszynski/keepa
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b8/00/fc05785b5af2e06b37c1c9019beed053b3d4c57b3162cd1fd2598c681279/keepa-1.3.5.tar.gz
BuildArch: noarch
%description
This Python module allows you to interface with the API at `Keepa
`_ to query for Amazon product information and
history. It also contains a plotting module to allow for plotting of
a product.
See API pricing at `Keepa API `_
Documentation can be found on readthedocs at `keepa Documentation `_.
%package -n python3-keepa
Summary: Interfaces with keepa.com
Provides: python-keepa
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-keepa
This Python module allows you to interface with the API at `Keepa
`_ to query for Amazon product information and
history. It also contains a plotting module to allow for plotting of
a product.
See API pricing at `Keepa API `_
Documentation can be found on readthedocs at `keepa Documentation `_.
%package help
Summary: Development documents and examples for keepa
Provides: python3-keepa-doc
%description help
This Python module allows you to interface with the API at `Keepa
`_ to query for Amazon product information and
history. It also contains a plotting module to allow for plotting of
a product.
See API pricing at `Keepa API `_
Documentation can be found on readthedocs at `keepa Documentation `_.
%prep
%autosetup -n keepa-1.3.5
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-keepa -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 25 2023 Python_Bot - 1.3.5-1
- Package Spec generated