%global _empty_manifest_terminate_build 0
Name:		python-boto3facade
Version:	0.5.9
Release:	1
Summary:	A simple facade for Boto3
License:	MIT
URL:		http://github.com/findhotel/boto3facade
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/88/2e/3e00b7f01e15d75fb82ab32b605651a7f8d382b6488bb4d0da3d82c503db/boto3facade-0.5.9.tar.gz
BuildArch:	noarch


%description
[![Build Status](https://travis-ci.org/FindHotel/boto3facade.svg?branch=master)](https://travis-ci.org/FindHotel/boto3facade)
[![PyPI](https://img.shields.io/pypi/v/boto3facade.svg?style=flat)](https://pypi.python.org/pypi/boto3facade)
A simple facade for [boto3][boto3] that makes some common tasks easier. The 
`boto3facade` module is not intended to be used directly but as a shared
components of projects that use boto3.
[boto3]: https://github.com/boto/boto3
## Installation
To install the development version:
```
    pip install git+https://github.com/FindHotel/boto3facade
```
To install the latest stable release:
```
    pip install boto3facade
```
## Quickstart
The `boto3facade` package contains a collection of modules that implement
facades to different AWS services. For instance the `boto3facade.ec2` module
implements the facade to [AWS EC2 service][ec2]. Each of these modules 
typically contain just one class, named as the corresponding AWS service. E.g.
the `boto3facade.ec2` module contains an `Ec2` class. In some cases, there may
also be public module functions that implement utilities that don't require
access to the [AWS boto3 SDK][boto3]. For instance in the EC2 facade:
[ec2]: https://aws.amazon.com/ec2/
```python
import boto3facade.ec2 as ec2
# Get the name of the role associated to the EC2 instance
if ec2.in_ec2():
    # If this code is running in an EC2 instance
    role_name = ec2.get_instance_profile_role()
else:
    role_name = None
```
Facade methods that actually use `boto3` are always implemented as instance
methods:
```python
from boto3facade.ec2 import Ec2
# Create the facade object
my_ec2_facade = Ec2()
# Get the list of AMIs that have tags matching the provided ones
ami_tags = {'Name': 'niceimage', 'Version', 'latest'}
ami_list = my_ec2_facade.get_ami_by_tag(ami_tags)
# Get the SecurityGroup boto3 resource with a certain name
my_sg = my_ec2_facade.get_sg_by_name('sgname')
```
## Development
```
    make develop
    . .env/bin/activate
```
## Contact
If you have questions, bug reports, suggestions, etc. please create an issue on
the [GitHub project page](http://github.com/FindHotel/boto3facade).
## License
This software is licensed under the [MIT license](http://en.wikipedia.org/wiki/MIT_License)
See [License file](https://github.com/FindHotel/boto3facade/blob/master/LICENSE)
© 2016 German Gomez-Herrero, and FindHotel.

%package -n python3-boto3facade
Summary:	A simple facade for Boto3
Provides:	python-boto3facade
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-boto3facade
[![Build Status](https://travis-ci.org/FindHotel/boto3facade.svg?branch=master)](https://travis-ci.org/FindHotel/boto3facade)
[![PyPI](https://img.shields.io/pypi/v/boto3facade.svg?style=flat)](https://pypi.python.org/pypi/boto3facade)
A simple facade for [boto3][boto3] that makes some common tasks easier. The 
`boto3facade` module is not intended to be used directly but as a shared
components of projects that use boto3.
[boto3]: https://github.com/boto/boto3
## Installation
To install the development version:
```
    pip install git+https://github.com/FindHotel/boto3facade
```
To install the latest stable release:
```
    pip install boto3facade
```
## Quickstart
The `boto3facade` package contains a collection of modules that implement
facades to different AWS services. For instance the `boto3facade.ec2` module
implements the facade to [AWS EC2 service][ec2]. Each of these modules 
typically contain just one class, named as the corresponding AWS service. E.g.
the `boto3facade.ec2` module contains an `Ec2` class. In some cases, there may
also be public module functions that implement utilities that don't require
access to the [AWS boto3 SDK][boto3]. For instance in the EC2 facade:
[ec2]: https://aws.amazon.com/ec2/
```python
import boto3facade.ec2 as ec2
# Get the name of the role associated to the EC2 instance
if ec2.in_ec2():
    # If this code is running in an EC2 instance
    role_name = ec2.get_instance_profile_role()
else:
    role_name = None
```
Facade methods that actually use `boto3` are always implemented as instance
methods:
```python
from boto3facade.ec2 import Ec2
# Create the facade object
my_ec2_facade = Ec2()
# Get the list of AMIs that have tags matching the provided ones
ami_tags = {'Name': 'niceimage', 'Version', 'latest'}
ami_list = my_ec2_facade.get_ami_by_tag(ami_tags)
# Get the SecurityGroup boto3 resource with a certain name
my_sg = my_ec2_facade.get_sg_by_name('sgname')
```
## Development
```
    make develop
    . .env/bin/activate
```
## Contact
If you have questions, bug reports, suggestions, etc. please create an issue on
the [GitHub project page](http://github.com/FindHotel/boto3facade).
## License
This software is licensed under the [MIT license](http://en.wikipedia.org/wiki/MIT_License)
See [License file](https://github.com/FindHotel/boto3facade/blob/master/LICENSE)
© 2016 German Gomez-Herrero, and FindHotel.

%package help
Summary:	Development documents and examples for boto3facade
Provides:	python3-boto3facade-doc
%description help
[![Build Status](https://travis-ci.org/FindHotel/boto3facade.svg?branch=master)](https://travis-ci.org/FindHotel/boto3facade)
[![PyPI](https://img.shields.io/pypi/v/boto3facade.svg?style=flat)](https://pypi.python.org/pypi/boto3facade)
A simple facade for [boto3][boto3] that makes some common tasks easier. The 
`boto3facade` module is not intended to be used directly but as a shared
components of projects that use boto3.
[boto3]: https://github.com/boto/boto3
## Installation
To install the development version:
```
    pip install git+https://github.com/FindHotel/boto3facade
```
To install the latest stable release:
```
    pip install boto3facade
```
## Quickstart
The `boto3facade` package contains a collection of modules that implement
facades to different AWS services. For instance the `boto3facade.ec2` module
implements the facade to [AWS EC2 service][ec2]. Each of these modules 
typically contain just one class, named as the corresponding AWS service. E.g.
the `boto3facade.ec2` module contains an `Ec2` class. In some cases, there may
also be public module functions that implement utilities that don't require
access to the [AWS boto3 SDK][boto3]. For instance in the EC2 facade:
[ec2]: https://aws.amazon.com/ec2/
```python
import boto3facade.ec2 as ec2
# Get the name of the role associated to the EC2 instance
if ec2.in_ec2():
    # If this code is running in an EC2 instance
    role_name = ec2.get_instance_profile_role()
else:
    role_name = None
```
Facade methods that actually use `boto3` are always implemented as instance
methods:
```python
from boto3facade.ec2 import Ec2
# Create the facade object
my_ec2_facade = Ec2()
# Get the list of AMIs that have tags matching the provided ones
ami_tags = {'Name': 'niceimage', 'Version', 'latest'}
ami_list = my_ec2_facade.get_ami_by_tag(ami_tags)
# Get the SecurityGroup boto3 resource with a certain name
my_sg = my_ec2_facade.get_sg_by_name('sgname')
```
## Development
```
    make develop
    . .env/bin/activate
```
## Contact
If you have questions, bug reports, suggestions, etc. please create an issue on
the [GitHub project page](http://github.com/FindHotel/boto3facade).
## License
This software is licensed under the [MIT license](http://en.wikipedia.org/wiki/MIT_License)
See [License file](https://github.com/FindHotel/boto3facade/blob/master/LICENSE)
© 2016 German Gomez-Herrero, and FindHotel.

%prep
%autosetup -n boto3facade-0.5.9

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-boto3facade -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 25 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.9-1
- Package Spec generated