%global _empty_manifest_terminate_build 0
Name: python-caer
Version: 2.0.8
Release: 1
Summary: A lightweight Computer Vision library for high-performance AI research - Modern Computer Vision on the Fly.
License: MIT License
URL: https://github.com/jasmcaus/caer
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d8/d2/22ebe136e0f62bb93753c9f979fd2c899de5a0d63ca8d3afd7d8fa47dce3/caer-2.0.8.tar.gz
BuildArch: noarch
Requires: python3-mypy
Requires: python3-numpy
Requires: python3-opencv-contrib-python
Requires: python3-typing-extensions
%description
[][py-versions]
[][pypi-latest-version]
[][twitter-badge]
[][downloads]
[][docs]
[][license]
# Caer - Modern Computer Vision on the Fly
Caer is a *lightweight, high-performance* Vision library for high-performance AI research. We wrote this framework to simplify your approach towards Computer Vision by abstracting away unnecessary boilerplate code giving you the **flexibility** to quickly prototype deep learning models and research ideas. The end result is a library quite different in its design, that’s easy to understand, plays well with others, and is a lot of fun to use.
Our elegant, *type-checked* API and design philosophy makes Caer ideal for students, researchers, hobbyists and even experts in the fields of Deep Learning and Computer Vision.
## Overview
Caer is a Python library that consists of the following components:
| Component | Description |
| ---- | --- |
| [**caer**](https://github.com/jasmcaus/caer/) | A lightweight GPU-accelerated Computer Vision library for high-performance AI research |
| [**caer.color**](https://github.com/jasmcaus/caer/tree/master/caer/color) | Colorspace operations |
| [**caer.data**](https://github.com/jasmcaus/caer/tree/master/caer/data) | Standard high-quality test images and example data |
| [**caer.path**](https://github.com/jasmcaus/caer/tree/master/caer/path) | OS-specific path manipulations |
| [**caer.preprocessing**](https://github.com/jasmcaus/caer/tree/master/caer/preprocessing) | Image preprocessing utilities. |
| [**caer.transforms**](https://github.com/jasmcaus/caer/tree/master/caer/transforms) | Powerful image transformations and augmentations |
| [**caer.video**](https://github.com/jasmcaus/caer/tree/master/caer/video) | Video processing utilities |
Usually, Caer is used either as:
- a replacement for OpenCV to use the power of GPUs.
- a Computer Vision research platform that provides maximum flexibility and speed.
# Installation
See the Caer **[Installation][install]** guide for detailed installation instructions (including building from source).
Currently, `caer` supports releases of Python 3.6 onwards; Python 2 is not supported (nor recommended).
To install the current release:
```shell
$ pip install --upgrade caer
```
# Getting Started
## Minimal Example
```python
import caer
# Load a standard 640x427 test image that ships out-of-the-box with caer
sunrise = caer.data.sunrise(rgb=True)
# Resize the image to 400x400 while MAINTAINING aspect ratio
resized = caer.resize(sunrise, target_size=(400,400), preserve_aspect_ratio=True)
```
For more examples, see the [Caer demos](https://github.com/jasmcaus/caer/blob/master/examples/) or [Read the documentation](http://caer.rtfd.io)
# Resources
- [**PyPi**](https://pypi.org/project/caer)
- [**Documentation**](https://github.com/jasmcaus/caer/blob/master/docs/README.md)
- [**Issue tracking**](https://github.com/jasmcaus/caer/issues)
# Contributing
We appreciate all contributions, feedback and issues. If you plan to contribute new features, utility functions, or extensions to the core, please go through our [Contribution Guidelines][contributing].
To contribute, start working through the `caer` codebase, read the [Documentation][docs], navigate to the [Issues][issues] tab and start looking through interesting issues.
Current contributors can be viewed either from the [Contributors][contributors] file or by using the `caer.__contributors__` command.
# Asking for help
If you have any questions, please:
1. [Read the docs](https://caer.rtfd.io/en/latest/).
2. [Look it up in our Github Discussions (or add a new question)](https://github.com/jasmcaus/caer/discussions).
2. [Search through the issues](https://github.com/jasmcaus/caer/issues).
# License
Caer is open-source and released under the [MIT License](LICENSE).
# BibTeX
If you want to cite the framework feel free to use this (but only if you loved it 😊):
```bibtex
@article{jasmcaus,
title={Caer},
author={Dsouza, Jason},
journal={GitHub. Note: https://github.com/jasmcaus/caer},
volume={2},
year={2020-2021}
}
```
[contributing]: https://github.com/jasmcaus/caer/blob/master/.github/CONTRIBUTING.md
[docs]: https://caer.rtfd.io
[contributors]: https://github.com/jasmcaus/caer/blob/master/CONTRIBUTORS
[coc]: https://github.com/jasmcaus/caer/blob/master/CODE_OF_CONDUCT.md
[issues]: https://github.com/jasmcaus/caer/issues
[install]: https://github.com/jasmcaus/caer/blob/master/INSTALL.md
[demos]: https://github.com/jasmcaus/caer/blob/master/examples/
[twitter-badge]: https://twitter.com/jasmcaus
[downloads]: https://pepy.tech/project/caer
[py-versions]: https://pypi.org/project/caer/
[pypi-latest-version]: https://pypi.org/project/caer/
[license]: https://github.com/jasmcaus/caer/blob/master/LICENSE
%package -n python3-caer
Summary: A lightweight Computer Vision library for high-performance AI research - Modern Computer Vision on the Fly.
Provides: python-caer
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-caer
[][py-versions]
[][pypi-latest-version]
[][twitter-badge]
[][downloads]
[][docs]
[][license]
# Caer - Modern Computer Vision on the Fly
Caer is a *lightweight, high-performance* Vision library for high-performance AI research. We wrote this framework to simplify your approach towards Computer Vision by abstracting away unnecessary boilerplate code giving you the **flexibility** to quickly prototype deep learning models and research ideas. The end result is a library quite different in its design, that’s easy to understand, plays well with others, and is a lot of fun to use.
Our elegant, *type-checked* API and design philosophy makes Caer ideal for students, researchers, hobbyists and even experts in the fields of Deep Learning and Computer Vision.
## Overview
Caer is a Python library that consists of the following components:
| Component | Description |
| ---- | --- |
| [**caer**](https://github.com/jasmcaus/caer/) | A lightweight GPU-accelerated Computer Vision library for high-performance AI research |
| [**caer.color**](https://github.com/jasmcaus/caer/tree/master/caer/color) | Colorspace operations |
| [**caer.data**](https://github.com/jasmcaus/caer/tree/master/caer/data) | Standard high-quality test images and example data |
| [**caer.path**](https://github.com/jasmcaus/caer/tree/master/caer/path) | OS-specific path manipulations |
| [**caer.preprocessing**](https://github.com/jasmcaus/caer/tree/master/caer/preprocessing) | Image preprocessing utilities. |
| [**caer.transforms**](https://github.com/jasmcaus/caer/tree/master/caer/transforms) | Powerful image transformations and augmentations |
| [**caer.video**](https://github.com/jasmcaus/caer/tree/master/caer/video) | Video processing utilities |
Usually, Caer is used either as:
- a replacement for OpenCV to use the power of GPUs.
- a Computer Vision research platform that provides maximum flexibility and speed.
# Installation
See the Caer **[Installation][install]** guide for detailed installation instructions (including building from source).
Currently, `caer` supports releases of Python 3.6 onwards; Python 2 is not supported (nor recommended).
To install the current release:
```shell
$ pip install --upgrade caer
```
# Getting Started
## Minimal Example
```python
import caer
# Load a standard 640x427 test image that ships out-of-the-box with caer
sunrise = caer.data.sunrise(rgb=True)
# Resize the image to 400x400 while MAINTAINING aspect ratio
resized = caer.resize(sunrise, target_size=(400,400), preserve_aspect_ratio=True)
```
For more examples, see the [Caer demos](https://github.com/jasmcaus/caer/blob/master/examples/) or [Read the documentation](http://caer.rtfd.io)
# Resources
- [**PyPi**](https://pypi.org/project/caer)
- [**Documentation**](https://github.com/jasmcaus/caer/blob/master/docs/README.md)
- [**Issue tracking**](https://github.com/jasmcaus/caer/issues)
# Contributing
We appreciate all contributions, feedback and issues. If you plan to contribute new features, utility functions, or extensions to the core, please go through our [Contribution Guidelines][contributing].
To contribute, start working through the `caer` codebase, read the [Documentation][docs], navigate to the [Issues][issues] tab and start looking through interesting issues.
Current contributors can be viewed either from the [Contributors][contributors] file or by using the `caer.__contributors__` command.
# Asking for help
If you have any questions, please:
1. [Read the docs](https://caer.rtfd.io/en/latest/).
2. [Look it up in our Github Discussions (or add a new question)](https://github.com/jasmcaus/caer/discussions).
2. [Search through the issues](https://github.com/jasmcaus/caer/issues).
# License
Caer is open-source and released under the [MIT License](LICENSE).
# BibTeX
If you want to cite the framework feel free to use this (but only if you loved it 😊):
```bibtex
@article{jasmcaus,
title={Caer},
author={Dsouza, Jason},
journal={GitHub. Note: https://github.com/jasmcaus/caer},
volume={2},
year={2020-2021}
}
```
[contributing]: https://github.com/jasmcaus/caer/blob/master/.github/CONTRIBUTING.md
[docs]: https://caer.rtfd.io
[contributors]: https://github.com/jasmcaus/caer/blob/master/CONTRIBUTORS
[coc]: https://github.com/jasmcaus/caer/blob/master/CODE_OF_CONDUCT.md
[issues]: https://github.com/jasmcaus/caer/issues
[install]: https://github.com/jasmcaus/caer/blob/master/INSTALL.md
[demos]: https://github.com/jasmcaus/caer/blob/master/examples/
[twitter-badge]: https://twitter.com/jasmcaus
[downloads]: https://pepy.tech/project/caer
[py-versions]: https://pypi.org/project/caer/
[pypi-latest-version]: https://pypi.org/project/caer/
[license]: https://github.com/jasmcaus/caer/blob/master/LICENSE
%package help
Summary: Development documents and examples for caer
Provides: python3-caer-doc
%description help
[][py-versions]
[][pypi-latest-version]
[][twitter-badge]
[][downloads]
[][docs]
[][license]
# Caer - Modern Computer Vision on the Fly
Caer is a *lightweight, high-performance* Vision library for high-performance AI research. We wrote this framework to simplify your approach towards Computer Vision by abstracting away unnecessary boilerplate code giving you the **flexibility** to quickly prototype deep learning models and research ideas. The end result is a library quite different in its design, that’s easy to understand, plays well with others, and is a lot of fun to use.
Our elegant, *type-checked* API and design philosophy makes Caer ideal for students, researchers, hobbyists and even experts in the fields of Deep Learning and Computer Vision.
## Overview
Caer is a Python library that consists of the following components:
| Component | Description |
| ---- | --- |
| [**caer**](https://github.com/jasmcaus/caer/) | A lightweight GPU-accelerated Computer Vision library for high-performance AI research |
| [**caer.color**](https://github.com/jasmcaus/caer/tree/master/caer/color) | Colorspace operations |
| [**caer.data**](https://github.com/jasmcaus/caer/tree/master/caer/data) | Standard high-quality test images and example data |
| [**caer.path**](https://github.com/jasmcaus/caer/tree/master/caer/path) | OS-specific path manipulations |
| [**caer.preprocessing**](https://github.com/jasmcaus/caer/tree/master/caer/preprocessing) | Image preprocessing utilities. |
| [**caer.transforms**](https://github.com/jasmcaus/caer/tree/master/caer/transforms) | Powerful image transformations and augmentations |
| [**caer.video**](https://github.com/jasmcaus/caer/tree/master/caer/video) | Video processing utilities |
Usually, Caer is used either as:
- a replacement for OpenCV to use the power of GPUs.
- a Computer Vision research platform that provides maximum flexibility and speed.
# Installation
See the Caer **[Installation][install]** guide for detailed installation instructions (including building from source).
Currently, `caer` supports releases of Python 3.6 onwards; Python 2 is not supported (nor recommended).
To install the current release:
```shell
$ pip install --upgrade caer
```
# Getting Started
## Minimal Example
```python
import caer
# Load a standard 640x427 test image that ships out-of-the-box with caer
sunrise = caer.data.sunrise(rgb=True)
# Resize the image to 400x400 while MAINTAINING aspect ratio
resized = caer.resize(sunrise, target_size=(400,400), preserve_aspect_ratio=True)
```
For more examples, see the [Caer demos](https://github.com/jasmcaus/caer/blob/master/examples/) or [Read the documentation](http://caer.rtfd.io)
# Resources
- [**PyPi**](https://pypi.org/project/caer)
- [**Documentation**](https://github.com/jasmcaus/caer/blob/master/docs/README.md)
- [**Issue tracking**](https://github.com/jasmcaus/caer/issues)
# Contributing
We appreciate all contributions, feedback and issues. If you plan to contribute new features, utility functions, or extensions to the core, please go through our [Contribution Guidelines][contributing].
To contribute, start working through the `caer` codebase, read the [Documentation][docs], navigate to the [Issues][issues] tab and start looking through interesting issues.
Current contributors can be viewed either from the [Contributors][contributors] file or by using the `caer.__contributors__` command.
# Asking for help
If you have any questions, please:
1. [Read the docs](https://caer.rtfd.io/en/latest/).
2. [Look it up in our Github Discussions (or add a new question)](https://github.com/jasmcaus/caer/discussions).
2. [Search through the issues](https://github.com/jasmcaus/caer/issues).
# License
Caer is open-source and released under the [MIT License](LICENSE).
# BibTeX
If you want to cite the framework feel free to use this (but only if you loved it 😊):
```bibtex
@article{jasmcaus,
title={Caer},
author={Dsouza, Jason},
journal={GitHub. Note: https://github.com/jasmcaus/caer},
volume={2},
year={2020-2021}
}
```
[contributing]: https://github.com/jasmcaus/caer/blob/master/.github/CONTRIBUTING.md
[docs]: https://caer.rtfd.io
[contributors]: https://github.com/jasmcaus/caer/blob/master/CONTRIBUTORS
[coc]: https://github.com/jasmcaus/caer/blob/master/CODE_OF_CONDUCT.md
[issues]: https://github.com/jasmcaus/caer/issues
[install]: https://github.com/jasmcaus/caer/blob/master/INSTALL.md
[demos]: https://github.com/jasmcaus/caer/blob/master/examples/
[twitter-badge]: https://twitter.com/jasmcaus
[downloads]: https://pepy.tech/project/caer
[py-versions]: https://pypi.org/project/caer/
[pypi-latest-version]: https://pypi.org/project/caer/
[license]: https://github.com/jasmcaus/caer/blob/master/LICENSE
%prep
%autosetup -n caer-2.0.8
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-caer -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 25 2023 Python_Bot - 2.0.8-1
- Package Spec generated