%global _empty_manifest_terminate_build 0
Name: python-django-oauth2-provider
Version: 0.2.6.1
Release: 1
Summary: Provide OAuth2 access to your app
License: UNKNOWN
URL: https://github.com/caffeinehit/django-oauth2-provider
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e4/66/06221e1ca3be894f7834d05030df105587e4a5f1ba3477ad8e69f9376479/django-oauth2-provider-0.2.6.1.tar.gz
BuildArch: noarch
%description
*django-oauth2-provider* is a Django application that provides
customizable OAuth2\-authentication for your Django projects.
`Documentation `_
`Help `_
%package -n python3-django-oauth2-provider
Summary: Provide OAuth2 access to your app
Provides: python-django-oauth2-provider
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-django-oauth2-provider
*django-oauth2-provider* is a Django application that provides
customizable OAuth2\-authentication for your Django projects.
`Documentation `_
`Help `_
%package help
Summary: Development documents and examples for django-oauth2-provider
Provides: python3-django-oauth2-provider-doc
%description help
*django-oauth2-provider* is a Django application that provides
customizable OAuth2\-authentication for your Django projects.
`Documentation `_
`Help `_
%prep
%autosetup -n django-oauth2-provider-0.2.6.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-django-oauth2-provider -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.2.6.1-1
- Package Spec generated