%global _empty_manifest_terminate_build 0
Name: python-biosimulators-test-suite
Version: 0.1.87
Release: 1
Summary: Tools for validating that biosimulation tools are consistent with the BioSimulators standards
License: MIT
URL: https://github.com/biosimulators/Biosimulators_test_suite
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ea/f0/638d34261fd6757ebf4675156bb3813839e5fb9a5b0cee9ac61e2e40a560/biosimulators_test_suite-0.1.87.tar.gz
BuildArch: noarch
Requires: python3-PyPDF2
Requires: python3-biosimulators-utils[bngl,cellml,containers,lems,neuroml,sbml,smoldyn]
Requires: python3-cement
Requires: python3-docker
Requires: python3-natsort
Requires: python3-numpy
Requires: python3-dateutil
Requires: python3-pyyaml
Requires: python3-simplejson
Requires: python3-termcolor
Requires: python3-biosimulators-utils[logging]
Requires: python3-parameterized
Requires: python3-biosimulators-utils[logging]
Requires: python3-parameterized
%description
The BioSimulators test suite is a tool for validating that biosimulation
software tools implement the `BioSimulators conventions for
biosimulation
tools `__.
The test suite is composed of two parts:
- `A collection of example modeling projects `__. Each
project is represented by a single `COMBINE/OMEX
archive `__ that contains one or more
simulation experiments described using the `Simulation Experiment
Description Markup Language (SED-ML) `__ and one
or more models described using a format such as the `BioNetGen
Language (BNGL) `__ or the `Systems Biology
Markup Language (SBML) `__.
- Software for checking that biosimulation tools execute these projects
according to the BioSimulators conventions.
- Simulation tools support the `BioSimulators standard command-line
arguments `__.
- Simulation tools support the `BioSimulators conventions for Docker
images `__.
- Simulation tools follow the `BioSimulators conventions for
executing simulations described by SED-ML files in COMBINE/OMEX
archives `__.
- Simulation tools support the `BioSimulators conventions for the
outputs of SED-ML files in COMBINE/OMEX
archives `__.
%package -n python3-biosimulators-test-suite
Summary: Tools for validating that biosimulation tools are consistent with the BioSimulators standards
Provides: python-biosimulators-test-suite
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-biosimulators-test-suite
The BioSimulators test suite is a tool for validating that biosimulation
software tools implement the `BioSimulators conventions for
biosimulation
tools `__.
The test suite is composed of two parts:
- `A collection of example modeling projects `__. Each
project is represented by a single `COMBINE/OMEX
archive `__ that contains one or more
simulation experiments described using the `Simulation Experiment
Description Markup Language (SED-ML) `__ and one
or more models described using a format such as the `BioNetGen
Language (BNGL) `__ or the `Systems Biology
Markup Language (SBML) `__.
- Software for checking that biosimulation tools execute these projects
according to the BioSimulators conventions.
- Simulation tools support the `BioSimulators standard command-line
arguments `__.
- Simulation tools support the `BioSimulators conventions for Docker
images `__.
- Simulation tools follow the `BioSimulators conventions for
executing simulations described by SED-ML files in COMBINE/OMEX
archives `__.
- Simulation tools support the `BioSimulators conventions for the
outputs of SED-ML files in COMBINE/OMEX
archives `__.
%package help
Summary: Development documents and examples for biosimulators-test-suite
Provides: python3-biosimulators-test-suite-doc
%description help
The BioSimulators test suite is a tool for validating that biosimulation
software tools implement the `BioSimulators conventions for
biosimulation
tools `__.
The test suite is composed of two parts:
- `A collection of example modeling projects `__. Each
project is represented by a single `COMBINE/OMEX
archive `__ that contains one or more
simulation experiments described using the `Simulation Experiment
Description Markup Language (SED-ML) `__ and one
or more models described using a format such as the `BioNetGen
Language (BNGL) `__ or the `Systems Biology
Markup Language (SBML) `__.
- Software for checking that biosimulation tools execute these projects
according to the BioSimulators conventions.
- Simulation tools support the `BioSimulators standard command-line
arguments `__.
- Simulation tools support the `BioSimulators conventions for Docker
images `__.
- Simulation tools follow the `BioSimulators conventions for
executing simulations described by SED-ML files in COMBINE/OMEX
archives `__.
- Simulation tools support the `BioSimulators conventions for the
outputs of SED-ML files in COMBINE/OMEX
archives `__.
%prep
%autosetup -n biosimulators-test-suite-0.1.87
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-biosimulators-test-suite -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.1.87-1
- Package Spec generated