%global _empty_manifest_terminate_build 0
Name: python-kervi
Version: 0.21.5
Release: 1
Summary: A python framework for creating robotic and automation applications on Raspbery pi (and other platforms). UI is web based and generated on the fly based on configuration in python code.
License: MIT License
URL: https://kervi.org
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2d/ca/226075d2735fe713b0dc613c7a3a2c6b54c6eecf2c5ad1df1af4a4f9f4cf/kervi-0.21.5.tar.gz
BuildArch: noarch
%description
# kervi
Easy Python framework for robotic and automation projects.
The framework runs on all platforms that supports Python and have hardware support for Raspberry pi.
Wire up sensors, controllers and other devices to your Raspberry PI and link them to web based dashboards
and internal application logic.
Knowledge about web servers, html or web programming is not needed.
UI configuration is done in python code and the framework creates the web ui.
Features of the framework are:
* Python classes for handling sensors, displays, motors, gpio and other hardware.
* Python classes for handling user interactions from controllers on dashboards.
* Integrated camera handling (Raspberry PI camera at the moment)
* Device driver library for common devices
* Very easy dashboard setup.
* Dashboard UI is responsive and scales from mobile phones to desktop.
* Multi process oriented by spreading over more than one core.
* Multi device oriented by connecting multiple Raspberry Pi's in one large application.
* No web development knowledge is required as dashboard layout is handled in python.
[Read the full documentation](https://kervi.org/)
Install Kervi via pip:
On Raspberry Pi
```
sudo pip3 install kervi[rpi]
```
On other systems like windows and linux:
```
pip3 install kervi
```
After Kervi is installed, a commandline tool called *kervi* is available.
Via the commandline interface it is possible scaffold Kervi apps and
setup image and video handling on Raspberry PI.
Create your first app in an empty folder by executing:
```
kervi create application myapp "My first app"
```
Start your new app by executing:
```
python myapp.py
```
The following output should be displayed:
(example)
```
Starting kervi application, please wait
load sensors
load controllers
load cameras
init IPC
Your Kervi application is ready at http://192.168.0.120:8080
```
Goto the url specified
%package -n python3-kervi
Summary: A python framework for creating robotic and automation applications on Raspbery pi (and other platforms). UI is web based and generated on the fly based on configuration in python code.
Provides: python-kervi
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-kervi
# kervi
Easy Python framework for robotic and automation projects.
The framework runs on all platforms that supports Python and have hardware support for Raspberry pi.
Wire up sensors, controllers and other devices to your Raspberry PI and link them to web based dashboards
and internal application logic.
Knowledge about web servers, html or web programming is not needed.
UI configuration is done in python code and the framework creates the web ui.
Features of the framework are:
* Python classes for handling sensors, displays, motors, gpio and other hardware.
* Python classes for handling user interactions from controllers on dashboards.
* Integrated camera handling (Raspberry PI camera at the moment)
* Device driver library for common devices
* Very easy dashboard setup.
* Dashboard UI is responsive and scales from mobile phones to desktop.
* Multi process oriented by spreading over more than one core.
* Multi device oriented by connecting multiple Raspberry Pi's in one large application.
* No web development knowledge is required as dashboard layout is handled in python.
[Read the full documentation](https://kervi.org/)
Install Kervi via pip:
On Raspberry Pi
```
sudo pip3 install kervi[rpi]
```
On other systems like windows and linux:
```
pip3 install kervi
```
After Kervi is installed, a commandline tool called *kervi* is available.
Via the commandline interface it is possible scaffold Kervi apps and
setup image and video handling on Raspberry PI.
Create your first app in an empty folder by executing:
```
kervi create application myapp "My first app"
```
Start your new app by executing:
```
python myapp.py
```
The following output should be displayed:
(example)
```
Starting kervi application, please wait
load sensors
load controllers
load cameras
init IPC
Your Kervi application is ready at http://192.168.0.120:8080
```
Goto the url specified
%package help
Summary: Development documents and examples for kervi
Provides: python3-kervi-doc
%description help
# kervi
Easy Python framework for robotic and automation projects.
The framework runs on all platforms that supports Python and have hardware support for Raspberry pi.
Wire up sensors, controllers and other devices to your Raspberry PI and link them to web based dashboards
and internal application logic.
Knowledge about web servers, html or web programming is not needed.
UI configuration is done in python code and the framework creates the web ui.
Features of the framework are:
* Python classes for handling sensors, displays, motors, gpio and other hardware.
* Python classes for handling user interactions from controllers on dashboards.
* Integrated camera handling (Raspberry PI camera at the moment)
* Device driver library for common devices
* Very easy dashboard setup.
* Dashboard UI is responsive and scales from mobile phones to desktop.
* Multi process oriented by spreading over more than one core.
* Multi device oriented by connecting multiple Raspberry Pi's in one large application.
* No web development knowledge is required as dashboard layout is handled in python.
[Read the full documentation](https://kervi.org/)
Install Kervi via pip:
On Raspberry Pi
```
sudo pip3 install kervi[rpi]
```
On other systems like windows and linux:
```
pip3 install kervi
```
After Kervi is installed, a commandline tool called *kervi* is available.
Via the commandline interface it is possible scaffold Kervi apps and
setup image and video handling on Raspberry PI.
Create your first app in an empty folder by executing:
```
kervi create application myapp "My first app"
```
Start your new app by executing:
```
python myapp.py
```
The following output should be displayed:
(example)
```
Starting kervi application, please wait
load sensors
load controllers
load cameras
init IPC
Your Kervi application is ready at http://192.168.0.120:8080
```
Goto the url specified
%prep
%autosetup -n kervi-0.21.5
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-kervi -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.21.5-1
- Package Spec generated