%global _empty_manifest_terminate_build 0
Name: python-saleae
Version: 0.12.0
Release: 1
Summary: Library to control a Saleae
License: MIT
URL: https://github.com/ppannuto/python-saleae
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3a/22/8817b6c010bff926e77a2ad3485682a49a430fa6695b9ad1b4aa0a6fd123/saleae-0.12.0.tar.gz
BuildArch: noarch
%description
|travisci| |docs|
This library implements the control protocol for the
`Saleae Logic Analyzer `__. It is based off of the
documentation and example here:
https://github.com/saleae/SaleaeSocketApi
**IMPORTANT: You must enable the 'Remote Scripting Server' in Saleae.** Click
on "Options" in the top-right, the "Developer" tab, and check "Enable scripting
socket server". This should not require a restart.
This library requires Saleae Logic 1.2.x or greater. Unfortunately there is no
way to check the version of Logic running using the scripting protocol so this
is difficult to check at runtime.
Currently, this is basically a direct mapping of API calls with some small
sanity checking and conveniences. It has not been extensively tested beyond
my immediate needs, but it also should not have any known problems.
To get a feel for how the library works and what it can do, try the built-in demo:
#!/usr/bin/env python3
import saleae
saleae.demo()
Issues, updates, pull requests, etc should be directed
`to github `__.
%package -n python3-saleae
Summary: Library to control a Saleae
Provides: python-saleae
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-saleae
|travisci| |docs|
This library implements the control protocol for the
`Saleae Logic Analyzer `__. It is based off of the
documentation and example here:
https://github.com/saleae/SaleaeSocketApi
**IMPORTANT: You must enable the 'Remote Scripting Server' in Saleae.** Click
on "Options" in the top-right, the "Developer" tab, and check "Enable scripting
socket server". This should not require a restart.
This library requires Saleae Logic 1.2.x or greater. Unfortunately there is no
way to check the version of Logic running using the scripting protocol so this
is difficult to check at runtime.
Currently, this is basically a direct mapping of API calls with some small
sanity checking and conveniences. It has not been extensively tested beyond
my immediate needs, but it also should not have any known problems.
To get a feel for how the library works and what it can do, try the built-in demo:
#!/usr/bin/env python3
import saleae
saleae.demo()
Issues, updates, pull requests, etc should be directed
`to github `__.
%package help
Summary: Development documents and examples for saleae
Provides: python3-saleae-doc
%description help
|travisci| |docs|
This library implements the control protocol for the
`Saleae Logic Analyzer `__. It is based off of the
documentation and example here:
https://github.com/saleae/SaleaeSocketApi
**IMPORTANT: You must enable the 'Remote Scripting Server' in Saleae.** Click
on "Options" in the top-right, the "Developer" tab, and check "Enable scripting
socket server". This should not require a restart.
This library requires Saleae Logic 1.2.x or greater. Unfortunately there is no
way to check the version of Logic running using the scripting protocol so this
is difficult to check at runtime.
Currently, this is basically a direct mapping of API calls with some small
sanity checking and conveniences. It has not been extensively tested beyond
my immediate needs, but it also should not have any known problems.
To get a feel for how the library works and what it can do, try the built-in demo:
#!/usr/bin/env python3
import saleae
saleae.demo()
Issues, updates, pull requests, etc should be directed
`to github `__.
%prep
%autosetup -n saleae-0.12.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-saleae -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.12.0-1
- Package Spec generated