%global _empty_manifest_terminate_build 0
Name: python-oasislmf
Version: 1.27.2
Release: 1
Summary: Core loss modelling framework.
License: BSD 3-Clause
URL: https://github.com/OasisLMF/oasislmf
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/59/d0/9a91b28cb9354e721d261aed1e098a821b8dbdd6c524eaa7085c5267ec44/oasislmf-1.27.2.tar.gz
BuildArch: noarch
%description
[![ktools version](https://img.shields.io/github/tag/Oasislmf/ktools?label=ktools)](https://github.com/OasisLMF/ktools/releases)
[![PyPI version](https://badge.fury.io/py/oasislmf.svg)](https://badge.fury.io/py/oasislmf)
[![FM Testing Tool](https://colab.research.google.com/assets/colab-badge.svg)](https://colab.research.google.com/github/OasisLMF/OasisLMF/blob/develop/fm_testing_tool/FmTesting.ipynb)
[![Oasislmf Testing](https://github.com/OasisLMF/OasisLMF/actions/workflows/unittest.yml/badge.svg?branch=develop&event=push)](https://github.com/OasisLMF/OasisLMF/actions/workflows/unittest.yml)
[![PiWind output check](https://github.com/OasisLMF/OasisLMF/actions/workflows/piwind-test.yml/badge.svg?branch=develop&event=push)](https://github.com/OasisLMF/OasisLMF/actions/workflows/piwind-test.yml)
[![PiWind MDK](https://github.com/OasisLMF/OasisLMF/actions/workflows/piwind-mdk.yml/badge.svg?branch=develop&event=push)](https://github.com/OasisLMF/OasisLMF/actions/workflows/piwind-mdk.yml)
# OasisLMF
The `oasislmf` Python package, loosely called the *model development kit (MDK)* or the *MDK package*, provides a command line toolkit for developing, testing and running Oasis models end-to-end locally, or remotely via the Oasis API. It can generate ground-up losses (GUL), direct/insured losses (IL) and reinsurance losses (RIL). It can also generate deterministic losses at all these levels.
## Releases and maintenance
Releases are published on a monthly cadence which tracks our team's development cycle. The planned fixes, enhancements and features can be seen on the [project development board](https://github.com/orgs/OasisLMF/projects/37) before each release.
> Note: From April 2022 and on the oasis release cycle is changing, the monthly published versions are switching to become 'pre-release' builds and the Long term support releases (currently 1.15.x and 1.23.x) will be the new 'standard oasis releases' for production use.
In practice, this is a shift in release labels which should better align with the intended use cases. Monthly builds are viewed as intermediate releases for testing new features, while the standard releases (marked by an increase in the minor version number 1.27.0 -> 1.28.0)
are stable builds.
#### Example of the updated Release tags
(Current latest version) `1.25.1`
* April 8th - `1.26.0rc1` (Intermediate Monthly)
* May 5th - `1.26.0rc2` (Intermediate Monthly)
* June 2nd - `1.26.0rc3` (Intermediate Monthly)
* July 7th - `1.26.0` (Oasis Release for production),
* August 4th - `1.26.1` (Backported fixes for production),
* August 4th - `1.27.0rc1` (Intermediate Monthly),
#### Release Cycle (Intermediate Monthly)
Release candidates are published on the first Thursday of each month, and tagged as `rc` and can be installed using `pip install oasislmf --pre`
#### Release Cycle (Production Builds)
The 'Standard release' which will replace the LTS tags will work in the same way. These are stable versions of oasis intended for production use which will be published on a 6 monthly cycle (approximately).
Oasis will backport stability fixes and security updates from the Monthly builds which are released alongside the `intermediate monthly` builds. Backport branches will still keep the format `backports/..x`.
> Note: Backported fixes to the existing `LTS` release will continue to be tagged in the same way until the next main oasis release is published as `1.27.0`
## Features
For running models locally the CLI provides a `model` subcommand with the following options:
* `model generate-exposure-pre-analysis`: generate new Exposure input using user custom code (ex: geo-coding, exposure enhancement, or dis-aggregation...)
* `model generate-keys`: generates Oasis keys files from model lookups; these are essentially line items of (location ID, peril ID, coverage type ID, area peril ID, vulnerability ID) where peril ID and coverage type ID span the full set of perils and coverage types that the model supports; if the lookup is for a complex/custom model the keys file will have the same format except that area peril ID and vulnerability ID are replaced by a model data JSON string
* `model generate-oasis-files`: generates the Oasis input CSV files for losses (GUL, GUL + IL, or GUL + IL + RIL); it requires the provision of source exposure and optionally source accounts and reinsurance info. and scope files (in OED format), as well as assets for instantiating model lookups and generating keys files
* `model generate-losses`: generates losses (GUL, or GUL + IL, or GUL + IL + RIL) from a set of pre-existing Oasis files
* `model run`: runs the model from start to finish by generating losses (GUL, or GUL + IL, or GUL + IL + RIL) from the source exposure, and optionally source accounts and reinsurance info. and scope files (in OED or RMS format), as well as assets related to lookup instantiation and keys file generation
The optional `--summarise-exposure` flag can be issued with `model generate-oasis-files` and `model run` to generate a summary of Total Insured Values (TIVs) grouped by coverage type and peril. This produces the `exposure_summary_report.json` file.
For remote model execution the `api` subcommand provides the following main subcommand:
* `api run`: runs the model remotely (same as `model run`) but via the Oasis API
For generating deterministic losses an `exposure run` subcommand is available:
* `exposure run`: generates deterministic losses (GUL, or GUL + IL, or GUL + IL + RIL)
The reusable libraries are organised into several sub-packages, the most relevant of which from a model developer or user's perspective are:
* `api_client`
* `model_preparation`
* `model_execution`
* `utils`
## Minimum Python Requirements
Starting from 1st January 2019, Pandas will no longer be supporting Python 2. As Pandas is a key dependency of the MDK we are **dropping Python 2 (2.7) support** as of this release (1.3.4). The last version which still supports Python 2.7 is version `1.3.3` (published 12/03/2019).
Also for this release (and all future releases) a **minimum of Python 3.7 is required**.
## Installation
The latest released version of the package, or a specific package version, can be installed using `pip`:
pip install oasislmf[==]
Alternatively you can install the latest development version using:
pip install git+{https,ssh}://git@github.com/OasisLMF/OasisLMF
You can also install from a specific branch `` using:
pip install [-v] git+{https,ssh}://git@github.com/OasisLMF/OasisLMF.git@#egg=oasislmf
## Enable Bash completion
Bash completion is a functionality which bash helps users type their commands by presenting possible options when users press the tab key while typing a command.
Once oasislmf is installed you'll need to be activate the feature by sourcing a bash file. (only needs to be run once)
### Local
oasislmf admin enable-bash-complete
### Global
echo 'complete -C completer_oasislmf oasislmf' | sudo tee /usr/share/bash-completion/completions/oasislmf
## Dependencies
### System
The package provides a built-in lookup framework (`oasislmf.model_preparation.lookup.OasisLookup`) which uses the Rtree Python package, which in turn requires the `libspatialindex` spatial indexing C library.
https://libspatialindex.github.io/index.html
Linux users can install the development version of `libspatialindex` from the command line using `apt`.
[sudo] apt install -y libspatialindex-dev
and OS X users can do the same via `brew`.
brew install spatialindex
The PiWind demonstration model uses the built-in lookup framework, therefore running PiWind or any model which uses the built-in lookup, requires that you install `libspatialindex`.
#### GNU/Linux
For GNU/Linux the following is a specific list of required system libraries
* **Debian**: g++ compiler build-essential, libtool, zlib1g-dev autoconf on debian distros
sudo apt install g++ build-essential libtool zlib1g-dev autoconf
* **Red Hat**: 'Development Tools' and zlib-devel
### Python
Package Python dependencies are controlled by `pip-tools`. To install the development dependencies first, install `pip-tools` using:
pip install pip-tools
and run:
pip-sync
To add new dependencies to the development requirements add the package name to `requirements.in` or
to add a new dependency to the installed package add the package name to `requirements-package.in`.
Version specifiers can be supplied to the packages but these should be kept as loose as possible so that
all packages can be easily updated and there will be fewer conflict when installing.
After adding packages to either `*.in` file:
pip-compile && pip-sync
should be ran ensuring the development dependencies are kept up to date.
## Testing
To test the code style run:
flake8
To test against all supported python versions run:
tox
To test against your currently installed version of python run:
py.test
To run the full test suite run:
./runtests.sh
## Publishing
Before publishing the latest version of the package make you sure increment the `__version__` value in `oasislmf/__init__.py`, and commit the change. You'll also need to install the `twine` Python package which `setuptools` uses for publishing packages on PyPI. If publishing wheels then you'll also need to install the `wheel` Python package.
### Using the `publish` subcommand in `setup.py`
The distribution format can be either a source distribution or a platform-specific wheel. To publish the source distribution package run:
python setup.py publish --sdist
or to publish the platform specific wheel run:
python setup.py publish --wheel
### Creating a bdist for another platform
To create a distribution for a non-host platform use the `--plat-name` flag:
python setup.py bdist_wheel --plat-name Linux_x86_64
or
python setup.py bdist_wheel --plat-name Darwin_x86_64
### Manually publishing, with a GPG signature
The first step is to create the distribution package with the desired format: for the source distribution run:
python setup.py sdist
which will create a `.tar.gz` file in the `dist` subfolder, or for the platform specific wheel run:
python setup.py bdist_wheel
which will create `.whl` file in the `dist` subfolder. To attach a GPG signature using your default private key you can then run:
gpg --detach-sign -a dist/.{tar.gz,whl}
This will create `.asc` signature file named `.{tar.gz,whl}.asc` in `dist`. You can just publish the package with the signature using:
twine upload dist/.{tar.gz,whl} dist/.{tar.gz,whl}.asc
## Documentation
* Issues
* Releases
* General Oasis documentation
* Model Development Kit (MDK)
* Modules
## License
The code in this project is licensed under BSD 3-clause license.
%package -n python3-oasislmf
Summary: Core loss modelling framework.
Provides: python-oasislmf
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-oasislmf
[![ktools version](https://img.shields.io/github/tag/Oasislmf/ktools?label=ktools)](https://github.com/OasisLMF/ktools/releases)
[![PyPI version](https://badge.fury.io/py/oasislmf.svg)](https://badge.fury.io/py/oasislmf)
[![FM Testing Tool](https://colab.research.google.com/assets/colab-badge.svg)](https://colab.research.google.com/github/OasisLMF/OasisLMF/blob/develop/fm_testing_tool/FmTesting.ipynb)
[![Oasislmf Testing](https://github.com/OasisLMF/OasisLMF/actions/workflows/unittest.yml/badge.svg?branch=develop&event=push)](https://github.com/OasisLMF/OasisLMF/actions/workflows/unittest.yml)
[![PiWind output check](https://github.com/OasisLMF/OasisLMF/actions/workflows/piwind-test.yml/badge.svg?branch=develop&event=push)](https://github.com/OasisLMF/OasisLMF/actions/workflows/piwind-test.yml)
[![PiWind MDK](https://github.com/OasisLMF/OasisLMF/actions/workflows/piwind-mdk.yml/badge.svg?branch=develop&event=push)](https://github.com/OasisLMF/OasisLMF/actions/workflows/piwind-mdk.yml)
# OasisLMF
The `oasislmf` Python package, loosely called the *model development kit (MDK)* or the *MDK package*, provides a command line toolkit for developing, testing and running Oasis models end-to-end locally, or remotely via the Oasis API. It can generate ground-up losses (GUL), direct/insured losses (IL) and reinsurance losses (RIL). It can also generate deterministic losses at all these levels.
## Releases and maintenance
Releases are published on a monthly cadence which tracks our team's development cycle. The planned fixes, enhancements and features can be seen on the [project development board](https://github.com/orgs/OasisLMF/projects/37) before each release.
> Note: From April 2022 and on the oasis release cycle is changing, the monthly published versions are switching to become 'pre-release' builds and the Long term support releases (currently 1.15.x and 1.23.x) will be the new 'standard oasis releases' for production use.
In practice, this is a shift in release labels which should better align with the intended use cases. Monthly builds are viewed as intermediate releases for testing new features, while the standard releases (marked by an increase in the minor version number 1.27.0 -> 1.28.0)
are stable builds.
#### Example of the updated Release tags
(Current latest version) `1.25.1`
* April 8th - `1.26.0rc1` (Intermediate Monthly)
* May 5th - `1.26.0rc2` (Intermediate Monthly)
* June 2nd - `1.26.0rc3` (Intermediate Monthly)
* July 7th - `1.26.0` (Oasis Release for production),
* August 4th - `1.26.1` (Backported fixes for production),
* August 4th - `1.27.0rc1` (Intermediate Monthly),
#### Release Cycle (Intermediate Monthly)
Release candidates are published on the first Thursday of each month, and tagged as `rc` and can be installed using `pip install oasislmf --pre`
#### Release Cycle (Production Builds)
The 'Standard release' which will replace the LTS tags will work in the same way. These are stable versions of oasis intended for production use which will be published on a 6 monthly cycle (approximately).
Oasis will backport stability fixes and security updates from the Monthly builds which are released alongside the `intermediate monthly` builds. Backport branches will still keep the format `backports/..x`.
> Note: Backported fixes to the existing `LTS` release will continue to be tagged in the same way until the next main oasis release is published as `1.27.0`
## Features
For running models locally the CLI provides a `model` subcommand with the following options:
* `model generate-exposure-pre-analysis`: generate new Exposure input using user custom code (ex: geo-coding, exposure enhancement, or dis-aggregation...)
* `model generate-keys`: generates Oasis keys files from model lookups; these are essentially line items of (location ID, peril ID, coverage type ID, area peril ID, vulnerability ID) where peril ID and coverage type ID span the full set of perils and coverage types that the model supports; if the lookup is for a complex/custom model the keys file will have the same format except that area peril ID and vulnerability ID are replaced by a model data JSON string
* `model generate-oasis-files`: generates the Oasis input CSV files for losses (GUL, GUL + IL, or GUL + IL + RIL); it requires the provision of source exposure and optionally source accounts and reinsurance info. and scope files (in OED format), as well as assets for instantiating model lookups and generating keys files
* `model generate-losses`: generates losses (GUL, or GUL + IL, or GUL + IL + RIL) from a set of pre-existing Oasis files
* `model run`: runs the model from start to finish by generating losses (GUL, or GUL + IL, or GUL + IL + RIL) from the source exposure, and optionally source accounts and reinsurance info. and scope files (in OED or RMS format), as well as assets related to lookup instantiation and keys file generation
The optional `--summarise-exposure` flag can be issued with `model generate-oasis-files` and `model run` to generate a summary of Total Insured Values (TIVs) grouped by coverage type and peril. This produces the `exposure_summary_report.json` file.
For remote model execution the `api` subcommand provides the following main subcommand:
* `api run`: runs the model remotely (same as `model run`) but via the Oasis API
For generating deterministic losses an `exposure run` subcommand is available:
* `exposure run`: generates deterministic losses (GUL, or GUL + IL, or GUL + IL + RIL)
The reusable libraries are organised into several sub-packages, the most relevant of which from a model developer or user's perspective are:
* `api_client`
* `model_preparation`
* `model_execution`
* `utils`
## Minimum Python Requirements
Starting from 1st January 2019, Pandas will no longer be supporting Python 2. As Pandas is a key dependency of the MDK we are **dropping Python 2 (2.7) support** as of this release (1.3.4). The last version which still supports Python 2.7 is version `1.3.3` (published 12/03/2019).
Also for this release (and all future releases) a **minimum of Python 3.7 is required**.
## Installation
The latest released version of the package, or a specific package version, can be installed using `pip`:
pip install oasislmf[==]
Alternatively you can install the latest development version using:
pip install git+{https,ssh}://git@github.com/OasisLMF/OasisLMF
You can also install from a specific branch `` using:
pip install [-v] git+{https,ssh}://git@github.com/OasisLMF/OasisLMF.git@#egg=oasislmf
## Enable Bash completion
Bash completion is a functionality which bash helps users type their commands by presenting possible options when users press the tab key while typing a command.
Once oasislmf is installed you'll need to be activate the feature by sourcing a bash file. (only needs to be run once)
### Local
oasislmf admin enable-bash-complete
### Global
echo 'complete -C completer_oasislmf oasislmf' | sudo tee /usr/share/bash-completion/completions/oasislmf
## Dependencies
### System
The package provides a built-in lookup framework (`oasislmf.model_preparation.lookup.OasisLookup`) which uses the Rtree Python package, which in turn requires the `libspatialindex` spatial indexing C library.
https://libspatialindex.github.io/index.html
Linux users can install the development version of `libspatialindex` from the command line using `apt`.
[sudo] apt install -y libspatialindex-dev
and OS X users can do the same via `brew`.
brew install spatialindex
The PiWind demonstration model uses the built-in lookup framework, therefore running PiWind or any model which uses the built-in lookup, requires that you install `libspatialindex`.
#### GNU/Linux
For GNU/Linux the following is a specific list of required system libraries
* **Debian**: g++ compiler build-essential, libtool, zlib1g-dev autoconf on debian distros
sudo apt install g++ build-essential libtool zlib1g-dev autoconf
* **Red Hat**: 'Development Tools' and zlib-devel
### Python
Package Python dependencies are controlled by `pip-tools`. To install the development dependencies first, install `pip-tools` using:
pip install pip-tools
and run:
pip-sync
To add new dependencies to the development requirements add the package name to `requirements.in` or
to add a new dependency to the installed package add the package name to `requirements-package.in`.
Version specifiers can be supplied to the packages but these should be kept as loose as possible so that
all packages can be easily updated and there will be fewer conflict when installing.
After adding packages to either `*.in` file:
pip-compile && pip-sync
should be ran ensuring the development dependencies are kept up to date.
## Testing
To test the code style run:
flake8
To test against all supported python versions run:
tox
To test against your currently installed version of python run:
py.test
To run the full test suite run:
./runtests.sh
## Publishing
Before publishing the latest version of the package make you sure increment the `__version__` value in `oasislmf/__init__.py`, and commit the change. You'll also need to install the `twine` Python package which `setuptools` uses for publishing packages on PyPI. If publishing wheels then you'll also need to install the `wheel` Python package.
### Using the `publish` subcommand in `setup.py`
The distribution format can be either a source distribution or a platform-specific wheel. To publish the source distribution package run:
python setup.py publish --sdist
or to publish the platform specific wheel run:
python setup.py publish --wheel
### Creating a bdist for another platform
To create a distribution for a non-host platform use the `--plat-name` flag:
python setup.py bdist_wheel --plat-name Linux_x86_64
or
python setup.py bdist_wheel --plat-name Darwin_x86_64
### Manually publishing, with a GPG signature
The first step is to create the distribution package with the desired format: for the source distribution run:
python setup.py sdist
which will create a `.tar.gz` file in the `dist` subfolder, or for the platform specific wheel run:
python setup.py bdist_wheel
which will create `.whl` file in the `dist` subfolder. To attach a GPG signature using your default private key you can then run:
gpg --detach-sign -a dist/.{tar.gz,whl}
This will create `.asc` signature file named `.{tar.gz,whl}.asc` in `dist`. You can just publish the package with the signature using:
twine upload dist/.{tar.gz,whl} dist/.{tar.gz,whl}.asc
## Documentation
* Issues
* Releases
* General Oasis documentation
* Model Development Kit (MDK)
* Modules
## License
The code in this project is licensed under BSD 3-clause license.
%package help
Summary: Development documents and examples for oasislmf
Provides: python3-oasislmf-doc
%description help
[![ktools version](https://img.shields.io/github/tag/Oasislmf/ktools?label=ktools)](https://github.com/OasisLMF/ktools/releases)
[![PyPI version](https://badge.fury.io/py/oasislmf.svg)](https://badge.fury.io/py/oasislmf)
[![FM Testing Tool](https://colab.research.google.com/assets/colab-badge.svg)](https://colab.research.google.com/github/OasisLMF/OasisLMF/blob/develop/fm_testing_tool/FmTesting.ipynb)
[![Oasislmf Testing](https://github.com/OasisLMF/OasisLMF/actions/workflows/unittest.yml/badge.svg?branch=develop&event=push)](https://github.com/OasisLMF/OasisLMF/actions/workflows/unittest.yml)
[![PiWind output check](https://github.com/OasisLMF/OasisLMF/actions/workflows/piwind-test.yml/badge.svg?branch=develop&event=push)](https://github.com/OasisLMF/OasisLMF/actions/workflows/piwind-test.yml)
[![PiWind MDK](https://github.com/OasisLMF/OasisLMF/actions/workflows/piwind-mdk.yml/badge.svg?branch=develop&event=push)](https://github.com/OasisLMF/OasisLMF/actions/workflows/piwind-mdk.yml)
# OasisLMF
The `oasislmf` Python package, loosely called the *model development kit (MDK)* or the *MDK package*, provides a command line toolkit for developing, testing and running Oasis models end-to-end locally, or remotely via the Oasis API. It can generate ground-up losses (GUL), direct/insured losses (IL) and reinsurance losses (RIL). It can also generate deterministic losses at all these levels.
## Releases and maintenance
Releases are published on a monthly cadence which tracks our team's development cycle. The planned fixes, enhancements and features can be seen on the [project development board](https://github.com/orgs/OasisLMF/projects/37) before each release.
> Note: From April 2022 and on the oasis release cycle is changing, the monthly published versions are switching to become 'pre-release' builds and the Long term support releases (currently 1.15.x and 1.23.x) will be the new 'standard oasis releases' for production use.
In practice, this is a shift in release labels which should better align with the intended use cases. Monthly builds are viewed as intermediate releases for testing new features, while the standard releases (marked by an increase in the minor version number 1.27.0 -> 1.28.0)
are stable builds.
#### Example of the updated Release tags
(Current latest version) `1.25.1`
* April 8th - `1.26.0rc1` (Intermediate Monthly)
* May 5th - `1.26.0rc2` (Intermediate Monthly)
* June 2nd - `1.26.0rc3` (Intermediate Monthly)
* July 7th - `1.26.0` (Oasis Release for production),
* August 4th - `1.26.1` (Backported fixes for production),
* August 4th - `1.27.0rc1` (Intermediate Monthly),
#### Release Cycle (Intermediate Monthly)
Release candidates are published on the first Thursday of each month, and tagged as `rc` and can be installed using `pip install oasislmf --pre`
#### Release Cycle (Production Builds)
The 'Standard release' which will replace the LTS tags will work in the same way. These are stable versions of oasis intended for production use which will be published on a 6 monthly cycle (approximately).
Oasis will backport stability fixes and security updates from the Monthly builds which are released alongside the `intermediate monthly` builds. Backport branches will still keep the format `backports/..x`.
> Note: Backported fixes to the existing `LTS` release will continue to be tagged in the same way until the next main oasis release is published as `1.27.0`
## Features
For running models locally the CLI provides a `model` subcommand with the following options:
* `model generate-exposure-pre-analysis`: generate new Exposure input using user custom code (ex: geo-coding, exposure enhancement, or dis-aggregation...)
* `model generate-keys`: generates Oasis keys files from model lookups; these are essentially line items of (location ID, peril ID, coverage type ID, area peril ID, vulnerability ID) where peril ID and coverage type ID span the full set of perils and coverage types that the model supports; if the lookup is for a complex/custom model the keys file will have the same format except that area peril ID and vulnerability ID are replaced by a model data JSON string
* `model generate-oasis-files`: generates the Oasis input CSV files for losses (GUL, GUL + IL, or GUL + IL + RIL); it requires the provision of source exposure and optionally source accounts and reinsurance info. and scope files (in OED format), as well as assets for instantiating model lookups and generating keys files
* `model generate-losses`: generates losses (GUL, or GUL + IL, or GUL + IL + RIL) from a set of pre-existing Oasis files
* `model run`: runs the model from start to finish by generating losses (GUL, or GUL + IL, or GUL + IL + RIL) from the source exposure, and optionally source accounts and reinsurance info. and scope files (in OED or RMS format), as well as assets related to lookup instantiation and keys file generation
The optional `--summarise-exposure` flag can be issued with `model generate-oasis-files` and `model run` to generate a summary of Total Insured Values (TIVs) grouped by coverage type and peril. This produces the `exposure_summary_report.json` file.
For remote model execution the `api` subcommand provides the following main subcommand:
* `api run`: runs the model remotely (same as `model run`) but via the Oasis API
For generating deterministic losses an `exposure run` subcommand is available:
* `exposure run`: generates deterministic losses (GUL, or GUL + IL, or GUL + IL + RIL)
The reusable libraries are organised into several sub-packages, the most relevant of which from a model developer or user's perspective are:
* `api_client`
* `model_preparation`
* `model_execution`
* `utils`
## Minimum Python Requirements
Starting from 1st January 2019, Pandas will no longer be supporting Python 2. As Pandas is a key dependency of the MDK we are **dropping Python 2 (2.7) support** as of this release (1.3.4). The last version which still supports Python 2.7 is version `1.3.3` (published 12/03/2019).
Also for this release (and all future releases) a **minimum of Python 3.7 is required**.
## Installation
The latest released version of the package, or a specific package version, can be installed using `pip`:
pip install oasislmf[==]
Alternatively you can install the latest development version using:
pip install git+{https,ssh}://git@github.com/OasisLMF/OasisLMF
You can also install from a specific branch `` using:
pip install [-v] git+{https,ssh}://git@github.com/OasisLMF/OasisLMF.git@#egg=oasislmf
## Enable Bash completion
Bash completion is a functionality which bash helps users type their commands by presenting possible options when users press the tab key while typing a command.
Once oasislmf is installed you'll need to be activate the feature by sourcing a bash file. (only needs to be run once)
### Local
oasislmf admin enable-bash-complete
### Global
echo 'complete -C completer_oasislmf oasislmf' | sudo tee /usr/share/bash-completion/completions/oasislmf
## Dependencies
### System
The package provides a built-in lookup framework (`oasislmf.model_preparation.lookup.OasisLookup`) which uses the Rtree Python package, which in turn requires the `libspatialindex` spatial indexing C library.
https://libspatialindex.github.io/index.html
Linux users can install the development version of `libspatialindex` from the command line using `apt`.
[sudo] apt install -y libspatialindex-dev
and OS X users can do the same via `brew`.
brew install spatialindex
The PiWind demonstration model uses the built-in lookup framework, therefore running PiWind or any model which uses the built-in lookup, requires that you install `libspatialindex`.
#### GNU/Linux
For GNU/Linux the following is a specific list of required system libraries
* **Debian**: g++ compiler build-essential, libtool, zlib1g-dev autoconf on debian distros
sudo apt install g++ build-essential libtool zlib1g-dev autoconf
* **Red Hat**: 'Development Tools' and zlib-devel
### Python
Package Python dependencies are controlled by `pip-tools`. To install the development dependencies first, install `pip-tools` using:
pip install pip-tools
and run:
pip-sync
To add new dependencies to the development requirements add the package name to `requirements.in` or
to add a new dependency to the installed package add the package name to `requirements-package.in`.
Version specifiers can be supplied to the packages but these should be kept as loose as possible so that
all packages can be easily updated and there will be fewer conflict when installing.
After adding packages to either `*.in` file:
pip-compile && pip-sync
should be ran ensuring the development dependencies are kept up to date.
## Testing
To test the code style run:
flake8
To test against all supported python versions run:
tox
To test against your currently installed version of python run:
py.test
To run the full test suite run:
./runtests.sh
## Publishing
Before publishing the latest version of the package make you sure increment the `__version__` value in `oasislmf/__init__.py`, and commit the change. You'll also need to install the `twine` Python package which `setuptools` uses for publishing packages on PyPI. If publishing wheels then you'll also need to install the `wheel` Python package.
### Using the `publish` subcommand in `setup.py`
The distribution format can be either a source distribution or a platform-specific wheel. To publish the source distribution package run:
python setup.py publish --sdist
or to publish the platform specific wheel run:
python setup.py publish --wheel
### Creating a bdist for another platform
To create a distribution for a non-host platform use the `--plat-name` flag:
python setup.py bdist_wheel --plat-name Linux_x86_64
or
python setup.py bdist_wheel --plat-name Darwin_x86_64
### Manually publishing, with a GPG signature
The first step is to create the distribution package with the desired format: for the source distribution run:
python setup.py sdist
which will create a `.tar.gz` file in the `dist` subfolder, or for the platform specific wheel run:
python setup.py bdist_wheel
which will create `.whl` file in the `dist` subfolder. To attach a GPG signature using your default private key you can then run:
gpg --detach-sign -a dist/.{tar.gz,whl}
This will create `.asc` signature file named `.{tar.gz,whl}.asc` in `dist`. You can just publish the package with the signature using:
twine upload dist/.{tar.gz,whl} dist/.{tar.gz,whl}.asc
## Documentation
* Issues
* Releases
* General Oasis documentation
* Model Development Kit (MDK)
* Modules
## License
The code in this project is licensed under BSD 3-clause license.
%prep
%autosetup -n oasislmf-1.27.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-oasislmf -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.27.2-1
- Package Spec generated