%global _empty_manifest_terminate_build 0
Name: python-bakplane-python-sdk
Version: 1.81.0
Release: 1
Summary: A Python Client for Bakplane
License: AGPLv3
URL: https://github.com/openaristos/bakplane-python-sdk
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3f/2e/80bdafc9282c703c131ce11b4830f456064bc53c6dcd403a290ca669468c/bakplane-python-sdk-1.81.0.tar.gz
BuildArch: noarch
Requires: python3-grpcio
Requires: python3-grpcio-tools
Requires: python3-protobuf
Requires: python3-SQLAlchemy
Requires: python3-sqlalchemy-redshift
Requires: python3-psycopg2-binary
Requires: python3-farmhashpy
Requires: python3-boto3
Requires: python3-dominus-python-sdk
Requires: python3-click
Requires: python3-pandas
Requires: python3-cachetools
Requires: python3-stdnum
Requires: python3-sortedcontainers
Requires: python3-certifi
%description
# Bakplane Client for Python
Bakplane is the orchestration backbone for Dominus, FinFlo, and Fabrik.
This SDK can be used to control ingestion sessions, mastering executions, plugin installation, etc.
## Installation
Installing the bakplane python client takes just a few seconds:
```bash
pip install bakplane-python-sdk
```
## Spark
If you'd like to use Bakplane inside of Spark running in Docker:
```bash
docker run -it --rm -p 8888:8888 --name pyspark jupyter/pyspark-notebook
```
Inside of your notebook run:
```shell script
!pip install bakplane-python-sdk
```
>> Note: use `host.docker.internal` instead of `localhost` when testing.
## Documentation
If you're interested in learning more then read the documentation: https://docs.openaristos.io/
Copyright (C) 2021 Aristos Data, LLC
%package -n python3-bakplane-python-sdk
Summary: A Python Client for Bakplane
Provides: python-bakplane-python-sdk
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-bakplane-python-sdk
# Bakplane Client for Python
Bakplane is the orchestration backbone for Dominus, FinFlo, and Fabrik.
This SDK can be used to control ingestion sessions, mastering executions, plugin installation, etc.
## Installation
Installing the bakplane python client takes just a few seconds:
```bash
pip install bakplane-python-sdk
```
## Spark
If you'd like to use Bakplane inside of Spark running in Docker:
```bash
docker run -it --rm -p 8888:8888 --name pyspark jupyter/pyspark-notebook
```
Inside of your notebook run:
```shell script
!pip install bakplane-python-sdk
```
>> Note: use `host.docker.internal` instead of `localhost` when testing.
## Documentation
If you're interested in learning more then read the documentation: https://docs.openaristos.io/
Copyright (C) 2021 Aristos Data, LLC
%package help
Summary: Development documents and examples for bakplane-python-sdk
Provides: python3-bakplane-python-sdk-doc
%description help
# Bakplane Client for Python
Bakplane is the orchestration backbone for Dominus, FinFlo, and Fabrik.
This SDK can be used to control ingestion sessions, mastering executions, plugin installation, etc.
## Installation
Installing the bakplane python client takes just a few seconds:
```bash
pip install bakplane-python-sdk
```
## Spark
If you'd like to use Bakplane inside of Spark running in Docker:
```bash
docker run -it --rm -p 8888:8888 --name pyspark jupyter/pyspark-notebook
```
Inside of your notebook run:
```shell script
!pip install bakplane-python-sdk
```
>> Note: use `host.docker.internal` instead of `localhost` when testing.
## Documentation
If you're interested in learning more then read the documentation: https://docs.openaristos.io/
Copyright (C) 2021 Aristos Data, LLC
%prep
%autosetup -n bakplane-python-sdk-1.81.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-bakplane-python-sdk -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.81.0-1
- Package Spec generated