%global _empty_manifest_terminate_build 0
Name: python-intspan
Version: 1.6.1
Release: 1
Summary: Sets of integers like 1,3-7,33
License: Apache License 2.0
URL: https://bitbucket.org/jeunice/intspan
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/16/49/4b1bcbd6b257422fe1c9f2fef3e0215b80465a5a1f80434dc8b95e096c87/intspan-1.6.1.tar.gz
BuildArch: noarch
%description
| |travisci| |version| |versions| |impls| |wheel| |coverage| |br-coverage|
.. |travisci| image:: https://api.travis-ci.org/jonathaneunice/intspan.svg
:target: http://travis-ci.org/jonathaneunice/intspan
.. |version| image:: http://img.shields.io/pypi/v/intspan.svg?style=flat
:alt: PyPI Package latest release
:target: https://pypi.org/project/intspan
.. |versions| image:: https://img.shields.io/pypi/pyversions/intspan.svg
:alt: Supported versions
:target: https://pypi.org/project/intspan
.. |impls| image:: https://img.shields.io/pypi/implementation/intspan.svg
:alt: Supported implementations
:target: https://pypi.org/project/intspan
.. |wheel| image:: https://img.shields.io/pypi/wheel/intspan.svg
:alt: Wheel packaging support
:target: https://pypi.org/project/intspan
.. |coverage| image:: https://img.shields.io/badge/test_coverage-100%25-6600CC.svg
:alt: Test line coverage
:target: https://pypi.org/project/intspan
.. |br-coverage| image:: https://img.shields.io/badge/branch_coverage-100%25-6600CC.svg
:alt: Test branch coverage
:target: https://pypi.org/project/intspan
``intspan`` is a ``set`` subclass that conveniently represents sets of integers.
Sets can be created from, and displayed as, integer spans such as
``1-3,14,29,92-97`` rather than exhaustive member listings. Compare::
intspan('1-3,14,29,92-97')
[1, 2, 3, 14, 29, 92, 93, 94, 95, 96, 97]
Or worse, the unsorted, non-intuitive listings that crop up with Python's
native unordered sets, such as::
set([96, 1, 2, 3, 97, 14, 93, 92, 29, 94, 95])
While they all indicate the same values, ``intspan`` output is much more compact
and comprehensible. It better divulges the contiguous nature of segments of the
collection, making it easier for humans to quickly determine the "shape" of the
data and ascertain "what's missing?"
When iterating, ``pop()``-ing an item, or converting to a list, ``intspan``
behaves as if it were an ordered--in fact, sorted--collection. A key
implication is that, regardless of the order in which items are added,
an ``intspan`` will always be rendered in the most compact, organized
form possible.
The main draw is having a convenient way to specify, manage, and see output in
terms of ranges--for example, rows to process in a spreadsheet. It can also help
you quickly identify or report which items were *not* successfully processed in
a large dataset.
There is also an ordered ``intspanlist`` type that helps specify the
ordering of a set of elements.
See the full details on `Read the Docs
`_.
%package -n python3-intspan
Summary: Sets of integers like 1,3-7,33
Provides: python-intspan
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-intspan
| |travisci| |version| |versions| |impls| |wheel| |coverage| |br-coverage|
.. |travisci| image:: https://api.travis-ci.org/jonathaneunice/intspan.svg
:target: http://travis-ci.org/jonathaneunice/intspan
.. |version| image:: http://img.shields.io/pypi/v/intspan.svg?style=flat
:alt: PyPI Package latest release
:target: https://pypi.org/project/intspan
.. |versions| image:: https://img.shields.io/pypi/pyversions/intspan.svg
:alt: Supported versions
:target: https://pypi.org/project/intspan
.. |impls| image:: https://img.shields.io/pypi/implementation/intspan.svg
:alt: Supported implementations
:target: https://pypi.org/project/intspan
.. |wheel| image:: https://img.shields.io/pypi/wheel/intspan.svg
:alt: Wheel packaging support
:target: https://pypi.org/project/intspan
.. |coverage| image:: https://img.shields.io/badge/test_coverage-100%25-6600CC.svg
:alt: Test line coverage
:target: https://pypi.org/project/intspan
.. |br-coverage| image:: https://img.shields.io/badge/branch_coverage-100%25-6600CC.svg
:alt: Test branch coverage
:target: https://pypi.org/project/intspan
``intspan`` is a ``set`` subclass that conveniently represents sets of integers.
Sets can be created from, and displayed as, integer spans such as
``1-3,14,29,92-97`` rather than exhaustive member listings. Compare::
intspan('1-3,14,29,92-97')
[1, 2, 3, 14, 29, 92, 93, 94, 95, 96, 97]
Or worse, the unsorted, non-intuitive listings that crop up with Python's
native unordered sets, such as::
set([96, 1, 2, 3, 97, 14, 93, 92, 29, 94, 95])
While they all indicate the same values, ``intspan`` output is much more compact
and comprehensible. It better divulges the contiguous nature of segments of the
collection, making it easier for humans to quickly determine the "shape" of the
data and ascertain "what's missing?"
When iterating, ``pop()``-ing an item, or converting to a list, ``intspan``
behaves as if it were an ordered--in fact, sorted--collection. A key
implication is that, regardless of the order in which items are added,
an ``intspan`` will always be rendered in the most compact, organized
form possible.
The main draw is having a convenient way to specify, manage, and see output in
terms of ranges--for example, rows to process in a spreadsheet. It can also help
you quickly identify or report which items were *not* successfully processed in
a large dataset.
There is also an ordered ``intspanlist`` type that helps specify the
ordering of a set of elements.
See the full details on `Read the Docs
`_.
%package help
Summary: Development documents and examples for intspan
Provides: python3-intspan-doc
%description help
| |travisci| |version| |versions| |impls| |wheel| |coverage| |br-coverage|
.. |travisci| image:: https://api.travis-ci.org/jonathaneunice/intspan.svg
:target: http://travis-ci.org/jonathaneunice/intspan
.. |version| image:: http://img.shields.io/pypi/v/intspan.svg?style=flat
:alt: PyPI Package latest release
:target: https://pypi.org/project/intspan
.. |versions| image:: https://img.shields.io/pypi/pyversions/intspan.svg
:alt: Supported versions
:target: https://pypi.org/project/intspan
.. |impls| image:: https://img.shields.io/pypi/implementation/intspan.svg
:alt: Supported implementations
:target: https://pypi.org/project/intspan
.. |wheel| image:: https://img.shields.io/pypi/wheel/intspan.svg
:alt: Wheel packaging support
:target: https://pypi.org/project/intspan
.. |coverage| image:: https://img.shields.io/badge/test_coverage-100%25-6600CC.svg
:alt: Test line coverage
:target: https://pypi.org/project/intspan
.. |br-coverage| image:: https://img.shields.io/badge/branch_coverage-100%25-6600CC.svg
:alt: Test branch coverage
:target: https://pypi.org/project/intspan
``intspan`` is a ``set`` subclass that conveniently represents sets of integers.
Sets can be created from, and displayed as, integer spans such as
``1-3,14,29,92-97`` rather than exhaustive member listings. Compare::
intspan('1-3,14,29,92-97')
[1, 2, 3, 14, 29, 92, 93, 94, 95, 96, 97]
Or worse, the unsorted, non-intuitive listings that crop up with Python's
native unordered sets, such as::
set([96, 1, 2, 3, 97, 14, 93, 92, 29, 94, 95])
While they all indicate the same values, ``intspan`` output is much more compact
and comprehensible. It better divulges the contiguous nature of segments of the
collection, making it easier for humans to quickly determine the "shape" of the
data and ascertain "what's missing?"
When iterating, ``pop()``-ing an item, or converting to a list, ``intspan``
behaves as if it were an ordered--in fact, sorted--collection. A key
implication is that, regardless of the order in which items are added,
an ``intspan`` will always be rendered in the most compact, organized
form possible.
The main draw is having a convenient way to specify, manage, and see output in
terms of ranges--for example, rows to process in a spreadsheet. It can also help
you quickly identify or report which items were *not* successfully processed in
a large dataset.
There is also an ordered ``intspanlist`` type that helps specify the
ordering of a set of elements.
See the full details on `Read the Docs
`_.
%prep
%autosetup -n intspan-1.6.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-intspan -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.6.1-1
- Package Spec generated