%global _empty_manifest_terminate_build 0
Name: python-micropipenv
Version: 1.5.0
Release: 1
Summary: A simple wrapper around pip to support requirements.txt, Pipenv and Poetry files for containerized applications
License: LGPLv3+
URL: https://github.com/thoth-station/micropipenv
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/09/d8/7c836c4fdb3a3c7649d3c2e33606543c5801ee7d0c4a544f211cd7421abf/micropipenv-1.5.0.tar.gz
BuildArch: noarch
Requires: python3-pip
Requires: python3-flexmock
Requires: python3-pytest
Requires: python3-pytest-timeout
Requires: python3-pytest-venv
Requires: python3-packaging
Requires: python3-toml
%description
A lightweight wrapper for pip to support requirements.txt, Pipenv and Poetry
lock files or converting them to `pip-tools
`_ compatible output. Designed for
containerized Python applications but not limited to them.
For a brief video preview, `check this demo
`_ (the micropipenv
part starts at 9:00).
See also `micropipenv: Installing Python dependencies in containerized
applications
`__
for more info about this tool and a `blog post published about it
`__.
%package -n python3-micropipenv
Summary: A simple wrapper around pip to support requirements.txt, Pipenv and Poetry files for containerized applications
Provides: python-micropipenv
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-micropipenv
A lightweight wrapper for pip to support requirements.txt, Pipenv and Poetry
lock files or converting them to `pip-tools
`_ compatible output. Designed for
containerized Python applications but not limited to them.
For a brief video preview, `check this demo
`_ (the micropipenv
part starts at 9:00).
See also `micropipenv: Installing Python dependencies in containerized
applications
`__
for more info about this tool and a `blog post published about it
`__.
%package help
Summary: Development documents and examples for micropipenv
Provides: python3-micropipenv-doc
%description help
A lightweight wrapper for pip to support requirements.txt, Pipenv and Poetry
lock files or converting them to `pip-tools
`_ compatible output. Designed for
containerized Python applications but not limited to them.
For a brief video preview, `check this demo
`_ (the micropipenv
part starts at 9:00).
See also `micropipenv: Installing Python dependencies in containerized
applications
`__
for more info about this tool and a `blog post published about it
`__.
%prep
%autosetup -n micropipenv-1.5.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-micropipenv -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.5.0-1
- Package Spec generated