%global _empty_manifest_terminate_build 0
Name: python-MCsniperPY
Version: 3.5
Release: 1
Summary: Minecraft name sniper written in Python
License: MIT
URL: https://mcsniperpy.com
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/62/a6/c3d6897066db7cbcadbcfbd5977ce906ea55496297333001cb3564faf16d/MCsniperPY-3.5.tar.gz
BuildArch: noarch
Requires: python3-typer
Requires: python3-colorama
Requires: python3-aiohttp
Requires: python3-bs4
%description
⚠️ IMPORTANT ⚠️
DO NOT USE MCSNIPERPY -- READ BELOW
JUST DONT USE THIS IT DOESNT EVEN WORK
Use MCsniperGO for both of those features -
https://github.com/Kqzz/MCsniperGO
https://github.com/Kqzz/MCsniperGO
https://github.com/Kqzz/MCsniperGO
https://github.com/Kqzz/MCsniperGO
https://github.com/Kqzz/MCsniperGO
https://github.com/Kqzz/MCsniperGO
https://github.com/Kqzz/MCsniperGO
MCsniperPY
A Fast, async, and open source Minecraft name sniper.
Website
•
Docs
•
Donate
## Overview
- **Asynchronous** • MCsniperPY is asynchronous meaning it tends to be faster and more efficient than multithreaded name snipers
- **Open source** • MCsniperPY is open source, meaning you can look at everything that goes on behind the scenes to get you a name. This means you can be sure it doesn't steal your account.
- **Fast** • MCsniperPY is fast, but not so fast that your requests run out instantly.
%package -n python3-MCsniperPY
Summary: Minecraft name sniper written in Python
Provides: python-MCsniperPY
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-MCsniperPY
⚠️ IMPORTANT ⚠️
DO NOT USE MCSNIPERPY -- READ BELOW
JUST DONT USE THIS IT DOESNT EVEN WORK
Use MCsniperGO for both of those features -
https://github.com/Kqzz/MCsniperGO
https://github.com/Kqzz/MCsniperGO
https://github.com/Kqzz/MCsniperGO
https://github.com/Kqzz/MCsniperGO
https://github.com/Kqzz/MCsniperGO
https://github.com/Kqzz/MCsniperGO
https://github.com/Kqzz/MCsniperGO
MCsniperPY
A Fast, async, and open source Minecraft name sniper.
Website
•
Docs
•
Donate
## Overview
- **Asynchronous** • MCsniperPY is asynchronous meaning it tends to be faster and more efficient than multithreaded name snipers
- **Open source** • MCsniperPY is open source, meaning you can look at everything that goes on behind the scenes to get you a name. This means you can be sure it doesn't steal your account.
- **Fast** • MCsniperPY is fast, but not so fast that your requests run out instantly.
%package help
Summary: Development documents and examples for MCsniperPY
Provides: python3-MCsniperPY-doc
%description help
⚠️ IMPORTANT ⚠️
DO NOT USE MCSNIPERPY -- READ BELOW
JUST DONT USE THIS IT DOESNT EVEN WORK
Use MCsniperGO for both of those features -
https://github.com/Kqzz/MCsniperGO
https://github.com/Kqzz/MCsniperGO
https://github.com/Kqzz/MCsniperGO
https://github.com/Kqzz/MCsniperGO
https://github.com/Kqzz/MCsniperGO
https://github.com/Kqzz/MCsniperGO
https://github.com/Kqzz/MCsniperGO
MCsniperPY
A Fast, async, and open source Minecraft name sniper.
Website
•
Docs
•
Donate
## Overview
- **Asynchronous** • MCsniperPY is asynchronous meaning it tends to be faster and more efficient than multithreaded name snipers
- **Open source** • MCsniperPY is open source, meaning you can look at everything that goes on behind the scenes to get you a name. This means you can be sure it doesn't steal your account.
- **Fast** • MCsniperPY is fast, but not so fast that your requests run out instantly.
%prep
%autosetup -n MCsniperPY-3.5
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-MCsniperPY -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 3.5-1
- Package Spec generated