%global _empty_manifest_terminate_build 0
Name: python-AsyncLine
Version: 1.5.9.5
Release: 1
Summary: LINE Unofficial Python Library with Asyncio support and C++ Binding
License: MIT
URL: https://github.com/dyseo/AsyncLine
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/8b/d1/b034cf44746a5730addce1d62156e1af2dc6d7e76d10fd35c41195b64503/AsyncLine-1.5.9.5.tar.gz
BuildArch: noarch
Requires: python3-aiohttp
Requires: python3-aiostomp
Requires: python3-async-timeout
Requires: python3-asyncio-nats-client
Requires: python3-frugal
Requires: python3-pymongo
Requires: python3-requests
Requires: python3-rsa
Requires: python3-uvloop
%description
Line Messaging API for Python
PyPi
•
Releases
•
Community
.
.
.
## Important
Please be warned: `AsyncLine` is in a very early beta. You will encounter bugs when using it. In addition, there are very many rough edges. With that said, please try it out in your applications: I need your feedback to fix the bugs and file down the rough edges.
## Features
- Fully Asynchronously
- Slightly faster
- Easy to use
- Documented
- Type-hint everywhere
## Installation
- `pip3 install AsyncLine --upgrade`
## Simple usage
```python
from AsyncLine import LineNext
import asyncio
cli = LineNext('ios')
cli.login(name='your session name', qr=True)
"""
Args login:
name: string for create new session for next login, no effect if using token login
token: string of token for login using token, no need to create session name
mail: string of email that using for login using email, you can pass name session for custom session
default using string of email for name session
passwd: password of email used
cert: (string | optional) if you have cert pass at this args for easy login using email
sure you can use custom session name for this too
qr: boolean pass True if want to login using authQr, and you can use custom session name
e.g client.login(name="sync", qr=True) this needed for next login
"""
@cli.hooks(type=26, filters=Filters.command("hello"))
async def hello_message(client, msg):
await client.talk.sendMessage(msg.to, "Heyy!")
#Run bot
cli.poll.streams()
```
Please read [Example](examples) for more detail about usage this lib
## Author
Dyseo / [@Dyseo](https://line.me/ti/p/~line.bngsad)
## Base Source
Asynz / [Anysz](https://github.com/anysz)
## Getting Error
[Issues](https://github.com/dyseo/AsyncLine/issues) always open for this
## License
*AsyncLine* - Unofficially API Client library for Python
A short and simple permissive license with conditions only requiring preservation of copyright and license notices. Licensed works, modifications, and larger works may be distributed under different terms and without source code.
AsyncLine is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
%package -n python3-AsyncLine
Summary: LINE Unofficial Python Library with Asyncio support and C++ Binding
Provides: python-AsyncLine
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-AsyncLine
Line Messaging API for Python
PyPi
•
Releases
•
Community
.
.
.
## Important
Please be warned: `AsyncLine` is in a very early beta. You will encounter bugs when using it. In addition, there are very many rough edges. With that said, please try it out in your applications: I need your feedback to fix the bugs and file down the rough edges.
## Features
- Fully Asynchronously
- Slightly faster
- Easy to use
- Documented
- Type-hint everywhere
## Installation
- `pip3 install AsyncLine --upgrade`
## Simple usage
```python
from AsyncLine import LineNext
import asyncio
cli = LineNext('ios')
cli.login(name='your session name', qr=True)
"""
Args login:
name: string for create new session for next login, no effect if using token login
token: string of token for login using token, no need to create session name
mail: string of email that using for login using email, you can pass name session for custom session
default using string of email for name session
passwd: password of email used
cert: (string | optional) if you have cert pass at this args for easy login using email
sure you can use custom session name for this too
qr: boolean pass True if want to login using authQr, and you can use custom session name
e.g client.login(name="sync", qr=True) this needed for next login
"""
@cli.hooks(type=26, filters=Filters.command("hello"))
async def hello_message(client, msg):
await client.talk.sendMessage(msg.to, "Heyy!")
#Run bot
cli.poll.streams()
```
Please read [Example](examples) for more detail about usage this lib
## Author
Dyseo / [@Dyseo](https://line.me/ti/p/~line.bngsad)
## Base Source
Asynz / [Anysz](https://github.com/anysz)
## Getting Error
[Issues](https://github.com/dyseo/AsyncLine/issues) always open for this
## License
*AsyncLine* - Unofficially API Client library for Python
A short and simple permissive license with conditions only requiring preservation of copyright and license notices. Licensed works, modifications, and larger works may be distributed under different terms and without source code.
AsyncLine is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
%package help
Summary: Development documents and examples for AsyncLine
Provides: python3-AsyncLine-doc
%description help
Line Messaging API for Python
PyPi
•
Releases
•
Community
.
.
.
## Important
Please be warned: `AsyncLine` is in a very early beta. You will encounter bugs when using it. In addition, there are very many rough edges. With that said, please try it out in your applications: I need your feedback to fix the bugs and file down the rough edges.
## Features
- Fully Asynchronously
- Slightly faster
- Easy to use
- Documented
- Type-hint everywhere
## Installation
- `pip3 install AsyncLine --upgrade`
## Simple usage
```python
from AsyncLine import LineNext
import asyncio
cli = LineNext('ios')
cli.login(name='your session name', qr=True)
"""
Args login:
name: string for create new session for next login, no effect if using token login
token: string of token for login using token, no need to create session name
mail: string of email that using for login using email, you can pass name session for custom session
default using string of email for name session
passwd: password of email used
cert: (string | optional) if you have cert pass at this args for easy login using email
sure you can use custom session name for this too
qr: boolean pass True if want to login using authQr, and you can use custom session name
e.g client.login(name="sync", qr=True) this needed for next login
"""
@cli.hooks(type=26, filters=Filters.command("hello"))
async def hello_message(client, msg):
await client.talk.sendMessage(msg.to, "Heyy!")
#Run bot
cli.poll.streams()
```
Please read [Example](examples) for more detail about usage this lib
## Author
Dyseo / [@Dyseo](https://line.me/ti/p/~line.bngsad)
## Base Source
Asynz / [Anysz](https://github.com/anysz)
## Getting Error
[Issues](https://github.com/dyseo/AsyncLine/issues) always open for this
## License
*AsyncLine* - Unofficially API Client library for Python
A short and simple permissive license with conditions only requiring preservation of copyright and license notices. Licensed works, modifications, and larger works may be distributed under different terms and without source code.
AsyncLine is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
%prep
%autosetup -n AsyncLine-1.5.9.5
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-AsyncLine -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.5.9.5-1
- Package Spec generated