%global _empty_manifest_terminate_build 0
Name: python-flake8-SQL
Version: 0.4.1
Release: 1
Summary: Flake8 plugin that checks SQL code against opinionated style rules
License: MIT
URL: https://github.com/pgjones/flake8-sql
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/80/7b/a82825ecd4aca4e3be4394f31a1179f71bfcdae4d4325c908626d0e09461/flake8-SQL-0.4.1.tar.gz
BuildArch: noarch
Requires: python3-flake8
Requires: python3-setuptools
Requires: python3-sqlparse
%description
|Build Status|
Flake8-SQL is a `flake8 `__
plugin that looks for SQL queries and checks then against an
opinionated style. This style mostly follows `SQL Style Guide
`__, but differ in the two following
ways. Firstly alignement should be with the ``INTO`` rather than
``INSERT`` keyword, i.e.
INSERT INTO table (columns)
VALUES (values)
Secondly ``JOIN`` should be aligned to the left of the river, i.e.
SELECT *
FROM table1
JOIN table2 ON ...
%package -n python3-flake8-SQL
Summary: Flake8 plugin that checks SQL code against opinionated style rules
Provides: python-flake8-SQL
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-flake8-SQL
|Build Status|
Flake8-SQL is a `flake8 `__
plugin that looks for SQL queries and checks then against an
opinionated style. This style mostly follows `SQL Style Guide
`__, but differ in the two following
ways. Firstly alignement should be with the ``INTO`` rather than
``INSERT`` keyword, i.e.
INSERT INTO table (columns)
VALUES (values)
Secondly ``JOIN`` should be aligned to the left of the river, i.e.
SELECT *
FROM table1
JOIN table2 ON ...
%package help
Summary: Development documents and examples for flake8-SQL
Provides: python3-flake8-SQL-doc
%description help
|Build Status|
Flake8-SQL is a `flake8 `__
plugin that looks for SQL queries and checks then against an
opinionated style. This style mostly follows `SQL Style Guide
`__, but differ in the two following
ways. Firstly alignement should be with the ``INTO`` rather than
``INSERT`` keyword, i.e.
INSERT INTO table (columns)
VALUES (values)
Secondly ``JOIN`` should be aligned to the left of the river, i.e.
SELECT *
FROM table1
JOIN table2 ON ...
%prep
%autosetup -n flake8-SQL-0.4.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-flake8-SQL -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.4.1-1
- Package Spec generated