%global _empty_manifest_terminate_build 0
Name: python-youtube-data-api
Version: 0.0.21
Release: 1
Summary: youtube-data-api is a Python wrapper for the YouTube Data API.
License: MIT
URL: https://github.com/mabrownnyu/youtube-data-api
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/59/e8/a459b8b92968e5f9da21346dbf89b204773f72b3007a8f72d375e6bea601/youtube-data-api-0.0.21.tar.gz
BuildArch: noarch
Requires: python3-pandas
Requires: python3-requests
%description
# YouTube Data API
This is a Python client for the [YouTube Data API](https://developers.google.com/youtube/v3/). The `youtube-data-api` package is a wrapper to simplify [GET requests](https://www.w3schools.com/tags/ref_httpmethods.asp) and JSON response parsing from the API. This package was written for version 3 of the API, with some minor future proofing.
## Install
We recommend you [install this module using pip](https://pypi.org/project/youtube-data-api/):
```
pip install youtube-data-api
```
If you want to use it from source, you'll have to install the dependencies manually:
```
pip install -r requirements.txt
```
## Quickstart
In order to access the API, you'll need to get a [service key](https://developers.google.com/youtube/registering_an_application#Create_API_Keys) from the [Google Cloud Console](https://console.cloud.google.com/).
Once you have it you can use the API key to initiate the `YouTubeDataAPI` class.
```
from youtube_api import YouTubeDataAPI
api_key = 'AKAIXXXXXXXX'
yt = YouTubeDataAPI(api_key)
yt.search('alexandria ocasio-cortez')
```
The `yt` object calls functions that automate the collection of data fields that are both visable and not-visable to everyday users.
Please refer to the [documentation](http://bit.ly/YouTubeDataAPI) for details.
## Testing
Static json files used for test are stored in `./tests/data`.
To test, command line input `make test`.
For further information, please refer to `./tests/readme.md`.
## Authors
Written by Leon Yin and Megan Brown. Michael Liu helped write and document tests.
If you use this software in your research please cite it as:
```
@misc{leon_yin_2018_1414418,
author = {Leon Yin and
Megan Brown},
title = {SMAPPNYU/youtube-data-api},
month = sep,
year = 2018,
doi = {10.5281/zenodo.1414418},
url = {https://doi.org/10.5281/zenodo.1414418}
}
```
## Contributions
We are actively seeking core maintainers and contributors!
We will be documenting best practices and procedures for contributing code
If you see a typo or documentation that is not clear, please make a pull request!
%package -n python3-youtube-data-api
Summary: youtube-data-api is a Python wrapper for the YouTube Data API.
Provides: python-youtube-data-api
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-youtube-data-api
# YouTube Data API
This is a Python client for the [YouTube Data API](https://developers.google.com/youtube/v3/). The `youtube-data-api` package is a wrapper to simplify [GET requests](https://www.w3schools.com/tags/ref_httpmethods.asp) and JSON response parsing from the API. This package was written for version 3 of the API, with some minor future proofing.
## Install
We recommend you [install this module using pip](https://pypi.org/project/youtube-data-api/):
```
pip install youtube-data-api
```
If you want to use it from source, you'll have to install the dependencies manually:
```
pip install -r requirements.txt
```
## Quickstart
In order to access the API, you'll need to get a [service key](https://developers.google.com/youtube/registering_an_application#Create_API_Keys) from the [Google Cloud Console](https://console.cloud.google.com/).
Once you have it you can use the API key to initiate the `YouTubeDataAPI` class.
```
from youtube_api import YouTubeDataAPI
api_key = 'AKAIXXXXXXXX'
yt = YouTubeDataAPI(api_key)
yt.search('alexandria ocasio-cortez')
```
The `yt` object calls functions that automate the collection of data fields that are both visable and not-visable to everyday users.
Please refer to the [documentation](http://bit.ly/YouTubeDataAPI) for details.
## Testing
Static json files used for test are stored in `./tests/data`.
To test, command line input `make test`.
For further information, please refer to `./tests/readme.md`.
## Authors
Written by Leon Yin and Megan Brown. Michael Liu helped write and document tests.
If you use this software in your research please cite it as:
```
@misc{leon_yin_2018_1414418,
author = {Leon Yin and
Megan Brown},
title = {SMAPPNYU/youtube-data-api},
month = sep,
year = 2018,
doi = {10.5281/zenodo.1414418},
url = {https://doi.org/10.5281/zenodo.1414418}
}
```
## Contributions
We are actively seeking core maintainers and contributors!
We will be documenting best practices and procedures for contributing code
If you see a typo or documentation that is not clear, please make a pull request!
%package help
Summary: Development documents and examples for youtube-data-api
Provides: python3-youtube-data-api-doc
%description help
# YouTube Data API
This is a Python client for the [YouTube Data API](https://developers.google.com/youtube/v3/). The `youtube-data-api` package is a wrapper to simplify [GET requests](https://www.w3schools.com/tags/ref_httpmethods.asp) and JSON response parsing from the API. This package was written for version 3 of the API, with some minor future proofing.
## Install
We recommend you [install this module using pip](https://pypi.org/project/youtube-data-api/):
```
pip install youtube-data-api
```
If you want to use it from source, you'll have to install the dependencies manually:
```
pip install -r requirements.txt
```
## Quickstart
In order to access the API, you'll need to get a [service key](https://developers.google.com/youtube/registering_an_application#Create_API_Keys) from the [Google Cloud Console](https://console.cloud.google.com/).
Once you have it you can use the API key to initiate the `YouTubeDataAPI` class.
```
from youtube_api import YouTubeDataAPI
api_key = 'AKAIXXXXXXXX'
yt = YouTubeDataAPI(api_key)
yt.search('alexandria ocasio-cortez')
```
The `yt` object calls functions that automate the collection of data fields that are both visable and not-visable to everyday users.
Please refer to the [documentation](http://bit.ly/YouTubeDataAPI) for details.
## Testing
Static json files used for test are stored in `./tests/data`.
To test, command line input `make test`.
For further information, please refer to `./tests/readme.md`.
## Authors
Written by Leon Yin and Megan Brown. Michael Liu helped write and document tests.
If you use this software in your research please cite it as:
```
@misc{leon_yin_2018_1414418,
author = {Leon Yin and
Megan Brown},
title = {SMAPPNYU/youtube-data-api},
month = sep,
year = 2018,
doi = {10.5281/zenodo.1414418},
url = {https://doi.org/10.5281/zenodo.1414418}
}
```
## Contributions
We are actively seeking core maintainers and contributors!
We will be documenting best practices and procedures for contributing code
If you see a typo or documentation that is not clear, please make a pull request!
%prep
%autosetup -n youtube-data-api-0.0.21
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-youtube-data-api -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.0.21-1
- Package Spec generated