%global _empty_manifest_terminate_build 0
Name: python-excellxgene
Version: 2.9.4
Release: 1
Summary: Web application for exploration of large scale scRNA-seq datasets, upgraded to enable end-to-end interactive analysis.
License: MIT
URL: https://github.com/czbiohub/excellxgene
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/cb/4b/5f2cc8663b3624011df7f67dd350a081e878184d6d859518a447f05ddcd4/excellxgene-2.9.4.tar.gz
BuildArch: noarch
%description
# Exploratory CellxGene (ExCellxGene)
Video vignettes to come!
## V2.6.3
In the latest version, the internal file system used by excellxgene has been restructured. As a result, launching excellxgene on a dataset you have previously worked with will create a new folder with none of your previous work. You will need to migrate your work to the new version of excellxgene. The easiest way to do this is with the following:
1. Create a new conda environment (same instructions as in the installation section).
2. Pip install `excellxgene==2.6.3`
3. Launch the new version of excellxgene.
4. Upload the metadata/genesets/etc downloaded from the old version of excellxgene to the new version.
### Installation
1. Install miniconda if conda not available already:
```
wget https://repo.anaconda.com/miniconda/Miniconda3-latest-MacOSX-x86_64.sh -O ~/miniconda.sh
bash ~/miniconda.sh -b -p $HOME/miniconda
```
2. Create and activate a new environment:
```
conda create -n cxg python=3.8
conda activate cxg
```
3. Install excellxgene with pip:
```
pip install excellxgene
```
If your operating system is CentOS, then you may run into issues installing dependencies that require up-to-date `gcc` or `g++` compilers. Please install with the following and try reinstalling `excellxgene` with pip:
```
conda install -c conda-forge gcc cxx-compiler
```
4. Download the git repository to get the example datasets (assumes git is available, if not install it with conda install -c anaconda git)
```
git clone https://github.com/czbiohub/excellxgene
cd excellxgene
```
Datasets are stored in `example-dataset`
5. Launch excellxgene with:
```
excellxgene launch example-dataset
```
This should launch an excellxgene session with all the datasets in example-datasets/ loaded in.
If you're running excellxgene remotely, please launch with:
```
excellxgene launch example-datasets --host 0.0.0.0
```
Ping me on the Biohub slack (@Alec) if you have any questions!
%package -n python3-excellxgene
Summary: Web application for exploration of large scale scRNA-seq datasets, upgraded to enable end-to-end interactive analysis.
Provides: python-excellxgene
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-excellxgene
# Exploratory CellxGene (ExCellxGene)
Video vignettes to come!
## V2.6.3
In the latest version, the internal file system used by excellxgene has been restructured. As a result, launching excellxgene on a dataset you have previously worked with will create a new folder with none of your previous work. You will need to migrate your work to the new version of excellxgene. The easiest way to do this is with the following:
1. Create a new conda environment (same instructions as in the installation section).
2. Pip install `excellxgene==2.6.3`
3. Launch the new version of excellxgene.
4. Upload the metadata/genesets/etc downloaded from the old version of excellxgene to the new version.
### Installation
1. Install miniconda if conda not available already:
```
wget https://repo.anaconda.com/miniconda/Miniconda3-latest-MacOSX-x86_64.sh -O ~/miniconda.sh
bash ~/miniconda.sh -b -p $HOME/miniconda
```
2. Create and activate a new environment:
```
conda create -n cxg python=3.8
conda activate cxg
```
3. Install excellxgene with pip:
```
pip install excellxgene
```
If your operating system is CentOS, then you may run into issues installing dependencies that require up-to-date `gcc` or `g++` compilers. Please install with the following and try reinstalling `excellxgene` with pip:
```
conda install -c conda-forge gcc cxx-compiler
```
4. Download the git repository to get the example datasets (assumes git is available, if not install it with conda install -c anaconda git)
```
git clone https://github.com/czbiohub/excellxgene
cd excellxgene
```
Datasets are stored in `example-dataset`
5. Launch excellxgene with:
```
excellxgene launch example-dataset
```
This should launch an excellxgene session with all the datasets in example-datasets/ loaded in.
If you're running excellxgene remotely, please launch with:
```
excellxgene launch example-datasets --host 0.0.0.0
```
Ping me on the Biohub slack (@Alec) if you have any questions!
%package help
Summary: Development documents and examples for excellxgene
Provides: python3-excellxgene-doc
%description help
# Exploratory CellxGene (ExCellxGene)
Video vignettes to come!
## V2.6.3
In the latest version, the internal file system used by excellxgene has been restructured. As a result, launching excellxgene on a dataset you have previously worked with will create a new folder with none of your previous work. You will need to migrate your work to the new version of excellxgene. The easiest way to do this is with the following:
1. Create a new conda environment (same instructions as in the installation section).
2. Pip install `excellxgene==2.6.3`
3. Launch the new version of excellxgene.
4. Upload the metadata/genesets/etc downloaded from the old version of excellxgene to the new version.
### Installation
1. Install miniconda if conda not available already:
```
wget https://repo.anaconda.com/miniconda/Miniconda3-latest-MacOSX-x86_64.sh -O ~/miniconda.sh
bash ~/miniconda.sh -b -p $HOME/miniconda
```
2. Create and activate a new environment:
```
conda create -n cxg python=3.8
conda activate cxg
```
3. Install excellxgene with pip:
```
pip install excellxgene
```
If your operating system is CentOS, then you may run into issues installing dependencies that require up-to-date `gcc` or `g++` compilers. Please install with the following and try reinstalling `excellxgene` with pip:
```
conda install -c conda-forge gcc cxx-compiler
```
4. Download the git repository to get the example datasets (assumes git is available, if not install it with conda install -c anaconda git)
```
git clone https://github.com/czbiohub/excellxgene
cd excellxgene
```
Datasets are stored in `example-dataset`
5. Launch excellxgene with:
```
excellxgene launch example-dataset
```
This should launch an excellxgene session with all the datasets in example-datasets/ loaded in.
If you're running excellxgene remotely, please launch with:
```
excellxgene launch example-datasets --host 0.0.0.0
```
Ping me on the Biohub slack (@Alec) if you have any questions!
%prep
%autosetup -n excellxgene-2.9.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-excellxgene -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 2.9.4-1
- Package Spec generated