%global _empty_manifest_terminate_build 0
Name: python-snipsskills
Version: 0.1.6.26
Release: 1
Summary: Snips Skills Manager
License: MIT
URL: https://github.com/snipsco/snipsskills
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/be/09/8b8c7002f170df930d76af513ad72e0dddc020254c107a0500f66b98f58d/snipsskills-0.1.6.26.tar.gz
BuildArch: noarch
Requires: python3-docopt
Requires: python3-dateutil
Requires: python3-Jinja2
Requires: python3-pyyaml
Requires: python3-pip
Requires: python3-snipsskillscore
Requires: python3-coverage
Requires: python3-pytest
Requires: python3-pytest-cov
%description
|Build Status| |PyPI| |MIT License|
The Snips Skills Manager is a tool for easily setting up and managing a Snips assistant.
A single configuration file, the `Snipsfile `_, is required to create a Snips assistant. In it, you specify:
- The URL of your assistant, as created in the `Snips Console `_
- The `skills `_ you want to install
- Bindings between intents and skills
- If required, additional parameters for you skill, such as an API key or the address of a lamp
- Various configuration parameters, such as language and logging preferences.
Check out `Awesome Snips `_, a curated list of Snips skills, assistants and other resources to get you started. In particular, make sure to read the `Getting Started guide `_.
%package -n python3-snipsskills
Summary: Snips Skills Manager
Provides: python-snipsskills
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-snipsskills
|Build Status| |PyPI| |MIT License|
The Snips Skills Manager is a tool for easily setting up and managing a Snips assistant.
A single configuration file, the `Snipsfile `_, is required to create a Snips assistant. In it, you specify:
- The URL of your assistant, as created in the `Snips Console `_
- The `skills `_ you want to install
- Bindings between intents and skills
- If required, additional parameters for you skill, such as an API key or the address of a lamp
- Various configuration parameters, such as language and logging preferences.
Check out `Awesome Snips `_, a curated list of Snips skills, assistants and other resources to get you started. In particular, make sure to read the `Getting Started guide `_.
%package help
Summary: Development documents and examples for snipsskills
Provides: python3-snipsskills-doc
%description help
|Build Status| |PyPI| |MIT License|
The Snips Skills Manager is a tool for easily setting up and managing a Snips assistant.
A single configuration file, the `Snipsfile `_, is required to create a Snips assistant. In it, you specify:
- The URL of your assistant, as created in the `Snips Console `_
- The `skills `_ you want to install
- Bindings between intents and skills
- If required, additional parameters for you skill, such as an API key or the address of a lamp
- Various configuration parameters, such as language and logging preferences.
Check out `Awesome Snips `_, a curated list of Snips skills, assistants and other resources to get you started. In particular, make sure to read the `Getting Started guide `_.
%prep
%autosetup -n snipsskills-0.1.6.26
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-snipsskills -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.1.6.26-1
- Package Spec generated