%global _empty_manifest_terminate_build 0 Name: python-duality Version: 5.4.5 Release: 1 Summary: Decorator library for the creation of CLI applications and scripts. License: Apache Software License URL: http://github.com/dkundih/duality Source0: https://mirrors.nju.edu.cn/pypi/web/packages/83/04/07931062f7b13879268333b26bd924efbe4a107fcc91630b0ba1247eb9f4/duality-5.4.5.tar.gz BuildArch: noarch %description Decorator library for the creation of CLI applications and scripts. Use permitted according to the terms of use and conditions set by the attached license. **Example of use - SCRIPT** Example code over a Car object. - DualityApp.script (v5.3.3) Example use in the terminal. - DualityApp.script (v5.3.3) **Example of use - WHEEL** Example code over a Car object. - DualityApp.wheel (v5.3.3) Example use in the terminal. - DualityApp.wheel (v5.3.3) Visit my Data Library at https://github.com/dkundih/DataLibrary in order to see the demonstration of use in practical examples. **Example of use - APPLY CUSTOM COLORING** Example code for the creation of a university with custom coloring defined in the 'myset' dictionary. (v5.3.3) NOTE: Fore coloring is defined as F(c, m, y, k, r, g, b) - for example, 'Fr' stands for fore coloring in red. Background coloring is defined as B(c, m, y, k, r, g, b) - for example, 'Br' stands for background coloring in red. Dictionary keys must be named as shown, only coloring values are subject to change. In order to apply custom coloring, define color_mode = 'custom', custom_color_mode = your_dictionary_name_here. Example use in the terminal with custom coloring applied. (v5.3.3) **Installation** ```sh # using pip pip install duality ``` **Import** ```sh # for Python environment import duality ``` **A word from the author!** The module itself, it's maintenance, updates and stability, logo, videos, promotional materials and everything associated with duality are done by **David Kundih** from **Croatia**.
My name is David Kundih and I am a Master of Engineering in Sustainable Mobility and Logistics, currently specializing in Digital Transformation of Traffic and Logistics using Python, JavaScript, HTML and CSS.
%package -n python3-duality Summary: Decorator library for the creation of CLI applications and scripts. Provides: python-duality BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-duality Decorator library for the creation of CLI applications and scripts. Use permitted according to the terms of use and conditions set by the attached license. **Example of use - SCRIPT** Example code over a Car object. - DualityApp.script (v5.3.3) Example use in the terminal. - DualityApp.script (v5.3.3) **Example of use - WHEEL** Example code over a Car object. - DualityApp.wheel (v5.3.3) Example use in the terminal. - DualityApp.wheel (v5.3.3) Visit my Data Library at https://github.com/dkundih/DataLibrary in order to see the demonstration of use in practical examples. **Example of use - APPLY CUSTOM COLORING** Example code for the creation of a university with custom coloring defined in the 'myset' dictionary. (v5.3.3) NOTE: Fore coloring is defined as F(c, m, y, k, r, g, b) - for example, 'Fr' stands for fore coloring in red. Background coloring is defined as B(c, m, y, k, r, g, b) - for example, 'Br' stands for background coloring in red. Dictionary keys must be named as shown, only coloring values are subject to change. In order to apply custom coloring, define color_mode = 'custom', custom_color_mode = your_dictionary_name_here. Example use in the terminal with custom coloring applied. (v5.3.3) **Installation** ```sh # using pip pip install duality ``` **Import** ```sh # for Python environment import duality ``` **A word from the author!** The module itself, it's maintenance, updates and stability, logo, videos, promotional materials and everything associated with duality are done by **David Kundih** from **Croatia**.
My name is David Kundih and I am a Master of Engineering in Sustainable Mobility and Logistics, currently specializing in Digital Transformation of Traffic and Logistics using Python, JavaScript, HTML and CSS.
%package help Summary: Development documents and examples for duality Provides: python3-duality-doc %description help Decorator library for the creation of CLI applications and scripts. Use permitted according to the terms of use and conditions set by the attached license. **Example of use - SCRIPT** Example code over a Car object. - DualityApp.script (v5.3.3) Example use in the terminal. - DualityApp.script (v5.3.3) **Example of use - WHEEL** Example code over a Car object. - DualityApp.wheel (v5.3.3) Example use in the terminal. - DualityApp.wheel (v5.3.3) Visit my Data Library at https://github.com/dkundih/DataLibrary in order to see the demonstration of use in practical examples. **Example of use - APPLY CUSTOM COLORING** Example code for the creation of a university with custom coloring defined in the 'myset' dictionary. (v5.3.3) NOTE: Fore coloring is defined as F(c, m, y, k, r, g, b) - for example, 'Fr' stands for fore coloring in red. Background coloring is defined as B(c, m, y, k, r, g, b) - for example, 'Br' stands for background coloring in red. Dictionary keys must be named as shown, only coloring values are subject to change. In order to apply custom coloring, define color_mode = 'custom', custom_color_mode = your_dictionary_name_here. Example use in the terminal with custom coloring applied. (v5.3.3) **Installation** ```sh # using pip pip install duality ``` **Import** ```sh # for Python environment import duality ``` **A word from the author!** The module itself, it's maintenance, updates and stability, logo, videos, promotional materials and everything associated with duality are done by **David Kundih** from **Croatia**.
My name is David Kundih and I am a Master of Engineering in Sustainable Mobility and Logistics, currently specializing in Digital Transformation of Traffic and Logistics using Python, JavaScript, HTML and CSS.
%prep
%autosetup -n duality-5.4.5
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-duality -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot