%global _empty_manifest_terminate_build 0
Name:		python-signatory
Version:	1.2.6.1.9.0
Release:	1
Summary:	Differentiable computations of the signature and logsignature transforms, on both CPU and GPU.
License:	Apache-2.0
URL:		https://github.com/patrick-kidger/signatory
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/f5/60/b88949987377607876794e6b37351521148a658317b0bda422921d803ce7/signatory-1.2.6.1.9.0.tar.gz


%description
For example, if you are using PyTorch 1.7.1 and want Signatory 1.2.4, then you should run:
    pip install signatory==1.2.4.1.7.1 --no-cache-dir --force-reinstall

%package -n python3-signatory
Summary:	Differentiable computations of the signature and logsignature transforms, on both CPU and GPU.
Provides:	python-signatory
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
BuildRequires:	python3-cffi
BuildRequires:	gcc
BuildRequires:	gdb
%description -n python3-signatory
For example, if you are using PyTorch 1.7.1 and want Signatory 1.2.4, then you should run:
    pip install signatory==1.2.4.1.7.1 --no-cache-dir --force-reinstall

%package help
Summary:	Development documents and examples for signatory
Provides:	python3-signatory-doc
%description help
For example, if you are using PyTorch 1.7.1 and want Signatory 1.2.4, then you should run:
    pip install signatory==1.2.4.1.7.1 --no-cache-dir --force-reinstall

%prep
%autosetup -n signatory-1.2.6.1.9.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-signatory -f filelist.lst
%dir %{python3_sitearch}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.6.1.9.0-1
- Package Spec generated