%global _empty_manifest_terminate_build 0
Name: python-pybroom
Version: 0.2
Release: 1
Summary: Make tidy DataFrames from messy fit/model results.
License: MIT
URL: http://pybroom.readthedocs.io/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/59/e2/69bf314fb580f81884eeb8b3b7ee78bfb025630237f4fbdd6f7ad8cf278b/pybroom-0.2.tar.gz
BuildArch: noarch
%description
**Pybroom** is a small python 3+ library for converting collections of
fit results (curve fitting or other optimizations)
to `Pandas `__
`DataFrame `__
in tidy format (or long-form)
`(Wickham 2014) `__.
Once fit results are in tidy DataFrames, it is possible to leverage
`common patterns `__
for tidy data analysis. Furthermore powerful visual
explorations using multi-facet plots becomes easy thanks to libraries
like `seaborn `__ natively
supporting tidy DataFrames.
See the `pybroom homepage `__ for more info.
%package -n python3-pybroom
Summary: Make tidy DataFrames from messy fit/model results.
Provides: python-pybroom
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pybroom
**Pybroom** is a small python 3+ library for converting collections of
fit results (curve fitting or other optimizations)
to `Pandas `__
`DataFrame `__
in tidy format (or long-form)
`(Wickham 2014) `__.
Once fit results are in tidy DataFrames, it is possible to leverage
`common patterns `__
for tidy data analysis. Furthermore powerful visual
explorations using multi-facet plots becomes easy thanks to libraries
like `seaborn `__ natively
supporting tidy DataFrames.
See the `pybroom homepage `__ for more info.
%package help
Summary: Development documents and examples for pybroom
Provides: python3-pybroom-doc
%description help
**Pybroom** is a small python 3+ library for converting collections of
fit results (curve fitting or other optimizations)
to `Pandas `__
`DataFrame `__
in tidy format (or long-form)
`(Wickham 2014) `__.
Once fit results are in tidy DataFrames, it is possible to leverage
`common patterns `__
for tidy data analysis. Furthermore powerful visual
explorations using multi-facet plots becomes easy thanks to libraries
like `seaborn `__ natively
supporting tidy DataFrames.
See the `pybroom homepage `__ for more info.
%prep
%autosetup -n pybroom-0.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pybroom -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.2-1
- Package Spec generated