%global _empty_manifest_terminate_build 0
Name: python-cppcheck-junit
Version: 2.3.0
Release: 1
Summary: Converts Cppcheck XML output to JUnit format.
License: MIT
URL: https://github.com/johnthagen/cppcheck-junit
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/da/6a/445991970abdcd0a383ff275c150fa120b3a6730d99f31843161def68150/cppcheck-junit-2.3.0.tar.gz
BuildArch: noarch
Requires: python3-exitstatus
%description
Tool that converts `cppcheck `_ XML output to JUnit XML format.
Use on your CI servers to get more helpful feedback.
%package -n python3-cppcheck-junit
Summary: Converts Cppcheck XML output to JUnit format.
Provides: python-cppcheck-junit
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-cppcheck-junit
Tool that converts `cppcheck `_ XML output to JUnit XML format.
Use on your CI servers to get more helpful feedback.
%package help
Summary: Development documents and examples for cppcheck-junit
Provides: python3-cppcheck-junit-doc
%description help
Tool that converts `cppcheck `_ XML output to JUnit XML format.
Use on your CI servers to get more helpful feedback.
%prep
%autosetup -n cppcheck-junit-2.3.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-cppcheck-junit -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 2.3.0-1
- Package Spec generated