%global _empty_manifest_terminate_build 0
Name: python-cdp-backend
Version: 4.0.9
Release: 1
Summary: Data storage utilities and processing pipelines used by CDP instances.
License: MIT License
URL: https://github.com/CouncilDataProject/cdp-backend
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/9d/15/cebb9f1f61ce01bdc7025176e852c6be94416fb09d9d6b721b587cd5f0ad/cdp-backend-4.0.9.tar.gz
BuildArch: noarch
Requires: python3-aiohttp
Requires: python3-backoff
Requires: python3-dataclasses-json
Requires: python3-fireo
Requires: python3-fsspec
Requires: python3-gcsfs
Requires: python3-google-cloud-firestore
Requires: python3-PyYAML
Requires: python3-requests
Requires: python3-bokeh
Requires: python3-ipython
Requires: python3-m2r2
Requires: python3-Sphinx
Requires: python3-furo
Requires: python3-numpydoc
Requires: python3-sphinx-copybutton
Requires: python3-docutils
Requires: python3-flask
Requires: python3-functions-framework
Requires: python3-ffmpeg-python
Requires: python3-black
Requires: python3-check-manifest
Requires: python3-ruff
Requires: python3-mypy
Requires: python3-pre-commit
Requires: python3-types-requests
Requires: python3-types-pytz
Requires: python3-types-PyYAML
Requires: python3-dask[distributed]
Requires: python3-faster-whisper
Requires: python3-ffmpeg-python
Requires: python3-graphviz
Requires: python3-imageio
Requires: python3-imageio-ffmpeg
Requires: python3-m3u8-To-MP4
Requires: python3-nltk
Requires: python3-numpy
Requires: python3-pandas
Requires: python3-prefect
Requires: python3-pyarrow
Requires: python3-pydub
Requires: python3-rapidfuzz
Requires: python3-spacy
Requires: python3-spacy-transformers
Requires: python3-torch
Requires: python3-tqdm
Requires: python3-transformers
Requires: python3-vimeo-downloader
Requires: python3-yt-dlp
Requires: python3-coverage
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-pytest-raises
Requires: python3-networkx
Requires: python3-pydot
%description
## Council Data Project
Council Data Project is an open-source project dedicated to providing journalists, activists, researchers, and all members of each community we serve with the tools they need to stay informed and hold their Council Members accountable.
For more information about Council Data Project, please visit [our website](https://councildataproject.org/).
## About
`cdp-backend` is used to maintain the database models, infrastructure stack, and all pipelines for CDP Instance web applications.
The central goal is to create a single library that manages the whole backend of any CDP Instance.
## Installation
**Stable Release (with just data access dependencies):** `pip install cdp-backend`
**Stable Release (with full pipeline dependencies):** `pip install cdp-backend[pipeline]`
**Development Head:** `pip install git+https://github.com/CouncilDataProject/cdp-backend.git`
**Dev Installation:** For devs, please ensure that you have [dot / graphviz](https://graphviz.org/download/) installed before working with tests and auto-documentation generation.
## Infrastructure
Please see [dev-infrastructure](./dev-infrastructure) for defaults on dev deployments.
## Documentation
For full package documentation please visit [councildataproject.org/cdp-backend](https://councildataproject.org/cdp-backend).
## Development
See [CONTRIBUTING.md](CONTRIBUTING.md) for information related to development of this repository.
## Citation
If you have found CDP software, data, or ideas useful in your own work, please consider citing us:
Brown et al., (2021). Council Data Project: Software for Municipal Data Collection, Analysis, and Publication. Journal of Open Source Software, 6(68), 3904, https://doi.org/10.21105/joss.03904
```bibtex
@article{Brown2021,
doi = {10.21105/joss.03904},
url = {https://doi.org/10.21105/joss.03904},
year = {2021},
publisher = {The Open Journal},
volume = {6},
number = {68},
pages = {3904},
author = {Eva Maxfield Brown and To Huynh and Isaac Na and Brian Ledbetter and Hawk Ticehurst and Sarah Liu and Emily Gilles and Katlyn M. f. Greene and Sung Cho and Shak Ragoler and Nicholas Weber},
title = {{Council Data Project: Software for Municipal Data Collection, Analysis, and Publication}},
journal = {Journal of Open Source Software}
}
```
## License
**MIT License**
%package -n python3-cdp-backend
Summary: Data storage utilities and processing pipelines used by CDP instances.
Provides: python-cdp-backend
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-cdp-backend
## Council Data Project
Council Data Project is an open-source project dedicated to providing journalists, activists, researchers, and all members of each community we serve with the tools they need to stay informed and hold their Council Members accountable.
For more information about Council Data Project, please visit [our website](https://councildataproject.org/).
## About
`cdp-backend` is used to maintain the database models, infrastructure stack, and all pipelines for CDP Instance web applications.
The central goal is to create a single library that manages the whole backend of any CDP Instance.
## Installation
**Stable Release (with just data access dependencies):** `pip install cdp-backend`
**Stable Release (with full pipeline dependencies):** `pip install cdp-backend[pipeline]`
**Development Head:** `pip install git+https://github.com/CouncilDataProject/cdp-backend.git`
**Dev Installation:** For devs, please ensure that you have [dot / graphviz](https://graphviz.org/download/) installed before working with tests and auto-documentation generation.
## Infrastructure
Please see [dev-infrastructure](./dev-infrastructure) for defaults on dev deployments.
## Documentation
For full package documentation please visit [councildataproject.org/cdp-backend](https://councildataproject.org/cdp-backend).
## Development
See [CONTRIBUTING.md](CONTRIBUTING.md) for information related to development of this repository.
## Citation
If you have found CDP software, data, or ideas useful in your own work, please consider citing us:
Brown et al., (2021). Council Data Project: Software for Municipal Data Collection, Analysis, and Publication. Journal of Open Source Software, 6(68), 3904, https://doi.org/10.21105/joss.03904
```bibtex
@article{Brown2021,
doi = {10.21105/joss.03904},
url = {https://doi.org/10.21105/joss.03904},
year = {2021},
publisher = {The Open Journal},
volume = {6},
number = {68},
pages = {3904},
author = {Eva Maxfield Brown and To Huynh and Isaac Na and Brian Ledbetter and Hawk Ticehurst and Sarah Liu and Emily Gilles and Katlyn M. f. Greene and Sung Cho and Shak Ragoler and Nicholas Weber},
title = {{Council Data Project: Software for Municipal Data Collection, Analysis, and Publication}},
journal = {Journal of Open Source Software}
}
```
## License
**MIT License**
%package help
Summary: Development documents and examples for cdp-backend
Provides: python3-cdp-backend-doc
%description help
## Council Data Project
Council Data Project is an open-source project dedicated to providing journalists, activists, researchers, and all members of each community we serve with the tools they need to stay informed and hold their Council Members accountable.
For more information about Council Data Project, please visit [our website](https://councildataproject.org/).
## About
`cdp-backend` is used to maintain the database models, infrastructure stack, and all pipelines for CDP Instance web applications.
The central goal is to create a single library that manages the whole backend of any CDP Instance.
## Installation
**Stable Release (with just data access dependencies):** `pip install cdp-backend`
**Stable Release (with full pipeline dependencies):** `pip install cdp-backend[pipeline]`
**Development Head:** `pip install git+https://github.com/CouncilDataProject/cdp-backend.git`
**Dev Installation:** For devs, please ensure that you have [dot / graphviz](https://graphviz.org/download/) installed before working with tests and auto-documentation generation.
## Infrastructure
Please see [dev-infrastructure](./dev-infrastructure) for defaults on dev deployments.
## Documentation
For full package documentation please visit [councildataproject.org/cdp-backend](https://councildataproject.org/cdp-backend).
## Development
See [CONTRIBUTING.md](CONTRIBUTING.md) for information related to development of this repository.
## Citation
If you have found CDP software, data, or ideas useful in your own work, please consider citing us:
Brown et al., (2021). Council Data Project: Software for Municipal Data Collection, Analysis, and Publication. Journal of Open Source Software, 6(68), 3904, https://doi.org/10.21105/joss.03904
```bibtex
@article{Brown2021,
doi = {10.21105/joss.03904},
url = {https://doi.org/10.21105/joss.03904},
year = {2021},
publisher = {The Open Journal},
volume = {6},
number = {68},
pages = {3904},
author = {Eva Maxfield Brown and To Huynh and Isaac Na and Brian Ledbetter and Hawk Ticehurst and Sarah Liu and Emily Gilles and Katlyn M. f. Greene and Sung Cho and Shak Ragoler and Nicholas Weber},
title = {{Council Data Project: Software for Municipal Data Collection, Analysis, and Publication}},
journal = {Journal of Open Source Software}
}
```
## License
**MIT License**
%prep
%autosetup -n cdp-backend-4.0.9
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-cdp-backend -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 4.0.9-1
- Package Spec generated