%global _empty_manifest_terminate_build 0
Name: python-discordbotdash
Version: 1.2.3
Release: 1
Summary: A python package for testing/managing your discord.py bot in browser.
License: MIT
URL: https://github.com/xCloudzx/discordbotdash
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c3/be/8c4d26cfd78b5acf0932fa7f60a10da301ee5637bca706668f942708eaf6/discordbotdash-1.2.3.tar.gz
BuildArch: noarch
%description
# discordbotdash
A discord.py package for testing Discord bots in your browser and viewing statistics. You can turn commands on and off, see the code for them, and view your shards with their respective latencies. This is still in development and more features will come.
## Installation
* PyPi
1. Run `pip install discordbotdash` for the latest version.
## Usage - Example
Once you have installed it, you can easily open up a dashboard in your browser:
```py
import discord
from discord.ext import commands
import discordbotdash.dash as dbd
bot = commands.AutoShardedBot("!")
@bot.event
async def on_ready():
dbd.openDash(bot)
# optional port: dbd.openDash(bot, port=5000)
bot.run("token")
```
Ensure that you are opening the dashboard before you are running the bot with `bot.run`. Your dashboard will be open on `127.0.0.1:5000`, or a different port if you have specified one, once you have run `openDash`.
## Changelog
* You can now specify a port or leave it unspecified to default to 5000.
* Added console to view events and eval() with your bot.
## Screenshots
### Cogs
### Commands
### Shards
### Console
## Contributing
* Pull Requests for new features are always welcome.
* If you have a suggestion or a bug to report, open an issue.
%package -n python3-discordbotdash
Summary: A python package for testing/managing your discord.py bot in browser.
Provides: python-discordbotdash
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-discordbotdash
# discordbotdash
A discord.py package for testing Discord bots in your browser and viewing statistics. You can turn commands on and off, see the code for them, and view your shards with their respective latencies. This is still in development and more features will come.
## Installation
* PyPi
1. Run `pip install discordbotdash` for the latest version.
## Usage - Example
Once you have installed it, you can easily open up a dashboard in your browser:
```py
import discord
from discord.ext import commands
import discordbotdash.dash as dbd
bot = commands.AutoShardedBot("!")
@bot.event
async def on_ready():
dbd.openDash(bot)
# optional port: dbd.openDash(bot, port=5000)
bot.run("token")
```
Ensure that you are opening the dashboard before you are running the bot with `bot.run`. Your dashboard will be open on `127.0.0.1:5000`, or a different port if you have specified one, once you have run `openDash`.
## Changelog
* You can now specify a port or leave it unspecified to default to 5000.
* Added console to view events and eval() with your bot.
## Screenshots
### Cogs
### Commands
### Shards
### Console
## Contributing
* Pull Requests for new features are always welcome.
* If you have a suggestion or a bug to report, open an issue.
%package help
Summary: Development documents and examples for discordbotdash
Provides: python3-discordbotdash-doc
%description help
# discordbotdash
A discord.py package for testing Discord bots in your browser and viewing statistics. You can turn commands on and off, see the code for them, and view your shards with their respective latencies. This is still in development and more features will come.
## Installation
* PyPi
1. Run `pip install discordbotdash` for the latest version.
## Usage - Example
Once you have installed it, you can easily open up a dashboard in your browser:
```py
import discord
from discord.ext import commands
import discordbotdash.dash as dbd
bot = commands.AutoShardedBot("!")
@bot.event
async def on_ready():
dbd.openDash(bot)
# optional port: dbd.openDash(bot, port=5000)
bot.run("token")
```
Ensure that you are opening the dashboard before you are running the bot with `bot.run`. Your dashboard will be open on `127.0.0.1:5000`, or a different port if you have specified one, once you have run `openDash`.
## Changelog
* You can now specify a port or leave it unspecified to default to 5000.
* Added console to view events and eval() with your bot.
## Screenshots
### Cogs
### Commands
### Shards
### Console
## Contributing
* Pull Requests for new features are always welcome.
* If you have a suggestion or a bug to report, open an issue.
%prep
%autosetup -n discordbotdash-1.2.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-discordbotdash -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.2.3-1
- Package Spec generated