%global _empty_manifest_terminate_build 0
Name: python-imgcat
Version: 0.5.0
Release: 1
Summary: imgcat as Python API and CLI
License: MIT
URL: https://github.com/wookayin/python-imgcat
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d4/56/1c3277dd00e8014e9499d8f654f7179d84edf4a07bf4b7932410625057aa/imgcat-0.5.0.tar.gz
BuildArch: noarch
%description
[](https://pypi.python.org/pypi/imgcat)
[](https://travis-ci.org/wookayin/python-imgcat)
[](LICENSE)
The imgcat CLI, written in Python (and Python API, too).
It works with [iTerm2](https://www.iterm2.com/documentation-images.html), and [even inside tmux][iterm_g3898].
%package -n python3-imgcat
Summary: imgcat as Python API and CLI
Provides: python-imgcat
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-imgcat
[](https://pypi.python.org/pypi/imgcat)
[](https://travis-ci.org/wookayin/python-imgcat)
[](LICENSE)
The imgcat CLI, written in Python (and Python API, too).
It works with [iTerm2](https://www.iterm2.com/documentation-images.html), and [even inside tmux][iterm_g3898].
%package help
Summary: Development documents and examples for imgcat
Provides: python3-imgcat-doc
%description help
[](https://pypi.python.org/pypi/imgcat)
[](https://travis-ci.org/wookayin/python-imgcat)
[](LICENSE)
The imgcat CLI, written in Python (and Python API, too).
It works with [iTerm2](https://www.iterm2.com/documentation-images.html), and [even inside tmux][iterm_g3898].
%prep
%autosetup -n imgcat-0.5.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-imgcat -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.5.0-1
- Package Spec generated