%global _empty_manifest_terminate_build 0
Name: python-menu.py
Version: 0.3.14
Release: 1
Summary: A simple python package for in-terminal menu creation on Windows
License: MIT License
URL: https://github.com/readyyeti/menu.py
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c9/a2/112f19973789ee4e95b74312bb3712595d34199ea4a51961f0f974728bf7/menu.py-0.3.14.tar.gz
BuildArch: noarch
Requires: python3-keyboard
%description
# menu.py
[](https://pypi.org/project/menu.py/)
[](https://pypi.org/project/menu.py/)
[](https://pypi.org/project/menu.py/)
[](https://github.com/readyyeti/menu.py)
> ### created by: deadyeti
> - [Contact via e-mail](mailto:deadyeti@deadyeti.ca)
> - [Contact via discord](https://discordapp.com/users/323651600990339074)
>
> ### links
> - [view on github](https://www.github.com/readyyeti/menu.py)
> - [view on PyPI](https://pypi.org/project/menu.py/)
>
## Introduction ##
> ### ⚠️
>
> - **menu.py** is still in the early stages of development, it is not recommended that you download this package at this time.
> - **menu.py** only works on Windows.
>
**menu.py** is a lightweight and easy-to-use python package used to quickly and efficiently create in-terminal menus that work in both *Command Prompt* and *Windows PowerShell*. Using **menu.py**, a user can either create a selection menu, where one selects an option from a pre-determined list of options, ~~or a user-input menu, where users type their input.~~ (not yet implemented)
## Key Features ##
✔️ fast and efficient
✔️ supports the use of colors
✔️ variable refresh-rate
✔️ easy to use
✔️ actively supported
## Installation ##
To install this module using pip:
```
py -m pip install menu.py
```
I always try to keep the most up-to-date version on pypi, but in case you need to install the most up-to-date version from github:
```git
$ git clone https://github.com/readyyeti/menu.py
$ cd menu.py
$ py -m pip install -U
```
## Quick Example ##
```python
from menu import *
from time import sleep
example_menu = menu('app_or_file_name')
theme = 'blue'
def main_menu():
# setting up the page name and menu options
page_name = 'name_of_page'
text = [
'please choose from the following options:'
]
options = [
'option #1', # CASE 1
'option #2', # CASE 2
'_skip_', # # "_skip_", " " and "" can be used to create a blank line without messing up the selections
'exit' # CASE 3
]
# generate menu
selection = example_menu.generate(page_name, options, text, theme)
match selection:
case 1:
menuprint('you selected option 1'), sleep(2)
case 2:
menuprint('you selected option 2'), sleep(2)
case 3:
example_menu.terminate()
return exit()
return
while True:
main_menu()
```
For a more in-depth example, check out the [*example.py*](https://github.com/readyyeti/menu.py/blob/main/menu/example.py) file
%package -n python3-menu.py
Summary: A simple python package for in-terminal menu creation on Windows
Provides: python-menu.py
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-menu.py
# menu.py
[](https://pypi.org/project/menu.py/)
[](https://pypi.org/project/menu.py/)
[](https://pypi.org/project/menu.py/)
[](https://github.com/readyyeti/menu.py)
> ### created by: deadyeti
> - [Contact via e-mail](mailto:deadyeti@deadyeti.ca)
> - [Contact via discord](https://discordapp.com/users/323651600990339074)
>
> ### links
> - [view on github](https://www.github.com/readyyeti/menu.py)
> - [view on PyPI](https://pypi.org/project/menu.py/)
>
## Introduction ##
> ### ⚠️
>
> - **menu.py** is still in the early stages of development, it is not recommended that you download this package at this time.
> - **menu.py** only works on Windows.
>
**menu.py** is a lightweight and easy-to-use python package used to quickly and efficiently create in-terminal menus that work in both *Command Prompt* and *Windows PowerShell*. Using **menu.py**, a user can either create a selection menu, where one selects an option from a pre-determined list of options, ~~or a user-input menu, where users type their input.~~ (not yet implemented)
## Key Features ##
✔️ fast and efficient
✔️ supports the use of colors
✔️ variable refresh-rate
✔️ easy to use
✔️ actively supported
## Installation ##
To install this module using pip:
```
py -m pip install menu.py
```
I always try to keep the most up-to-date version on pypi, but in case you need to install the most up-to-date version from github:
```git
$ git clone https://github.com/readyyeti/menu.py
$ cd menu.py
$ py -m pip install -U
```
## Quick Example ##
```python
from menu import *
from time import sleep
example_menu = menu('app_or_file_name')
theme = 'blue'
def main_menu():
# setting up the page name and menu options
page_name = 'name_of_page'
text = [
'please choose from the following options:'
]
options = [
'option #1', # CASE 1
'option #2', # CASE 2
'_skip_', # # "_skip_", " " and "" can be used to create a blank line without messing up the selections
'exit' # CASE 3
]
# generate menu
selection = example_menu.generate(page_name, options, text, theme)
match selection:
case 1:
menuprint('you selected option 1'), sleep(2)
case 2:
menuprint('you selected option 2'), sleep(2)
case 3:
example_menu.terminate()
return exit()
return
while True:
main_menu()
```
For a more in-depth example, check out the [*example.py*](https://github.com/readyyeti/menu.py/blob/main/menu/example.py) file
%package help
Summary: Development documents and examples for menu.py
Provides: python3-menu.py-doc
%description help
# menu.py
[](https://pypi.org/project/menu.py/)
[](https://pypi.org/project/menu.py/)
[](https://pypi.org/project/menu.py/)
[](https://github.com/readyyeti/menu.py)
> ### created by: deadyeti
> - [Contact via e-mail](mailto:deadyeti@deadyeti.ca)
> - [Contact via discord](https://discordapp.com/users/323651600990339074)
>
> ### links
> - [view on github](https://www.github.com/readyyeti/menu.py)
> - [view on PyPI](https://pypi.org/project/menu.py/)
>
## Introduction ##
> ### ⚠️
>
> - **menu.py** is still in the early stages of development, it is not recommended that you download this package at this time.
> - **menu.py** only works on Windows.
>
**menu.py** is a lightweight and easy-to-use python package used to quickly and efficiently create in-terminal menus that work in both *Command Prompt* and *Windows PowerShell*. Using **menu.py**, a user can either create a selection menu, where one selects an option from a pre-determined list of options, ~~or a user-input menu, where users type their input.~~ (not yet implemented)
## Key Features ##
✔️ fast and efficient
✔️ supports the use of colors
✔️ variable refresh-rate
✔️ easy to use
✔️ actively supported
## Installation ##
To install this module using pip:
```
py -m pip install menu.py
```
I always try to keep the most up-to-date version on pypi, but in case you need to install the most up-to-date version from github:
```git
$ git clone https://github.com/readyyeti/menu.py
$ cd menu.py
$ py -m pip install -U
```
## Quick Example ##
```python
from menu import *
from time import sleep
example_menu = menu('app_or_file_name')
theme = 'blue'
def main_menu():
# setting up the page name and menu options
page_name = 'name_of_page'
text = [
'please choose from the following options:'
]
options = [
'option #1', # CASE 1
'option #2', # CASE 2
'_skip_', # # "_skip_", " " and "" can be used to create a blank line without messing up the selections
'exit' # CASE 3
]
# generate menu
selection = example_menu.generate(page_name, options, text, theme)
match selection:
case 1:
menuprint('you selected option 1'), sleep(2)
case 2:
menuprint('you selected option 2'), sleep(2)
case 3:
example_menu.terminate()
return exit()
return
while True:
main_menu()
```
For a more in-depth example, check out the [*example.py*](https://github.com/readyyeti/menu.py/blob/main/menu/example.py) file
%prep
%autosetup -n menu.py-0.3.14
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-menu.py -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 0.3.14-1
- Package Spec generated