%global _empty_manifest_terminate_build 0
Name: python-mu-editor
Version: 1.2.0
Release: 1
Summary: A simple Python editor for beginner programmers.
License: GPL3
URL: https://github.com/mu-editor/mu
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/1d/42/4291d0bbd575ed393d57a319e2a3d98439ac7ac289c69ea39ecb110585f2/mu-editor-1.2.0.tar.gz
BuildArch: noarch
Requires: python3-jupyter-client
Requires: python3-ipykernel
Requires: python3-ipython-genutils
Requires: python3-qtconsole
Requires: python3-adafruit-board-toolkit
Requires: python3-pyserial
Requires: python3-nudatus
Requires: python3-flake8
Requires: python3-click
Requires: python3-platformdirs
Requires: python3-semver
Requires: python3-virtualenv
Requires: python3-wheel
Requires: python3-requests
Requires: python3-PyQt5
Requires: python3-QScintilla
Requires: python3-PyQtChart
Requires: python3-black
Requires: python3-pywin32
Requires: python3-pytest-timeout
Requires: python3-twine
Requires: python3-pytest-cov
Requires: python3-scrapy
Requires: python3-pytest-faulthandler
Requires: python3-sphinx
Requires: python3-wheel
Requires: python3-coverage
Requires: python3-requests
Requires: python3-pytest
Requires: python3-pytest-random-order
Requires: python3-beautifulsoup4
Requires: python3-babel
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-pytest-random-order
Requires: python3-pytest-faulthandler
Requires: python3-pytest-timeout
Requires: python3-coverage
Requires: python3-sphinx
Requires: python3-wheel
Requires: python3-twine
Requires: python3-babel
Requires: python3-sphinx
Requires: python3-babel
Requires: python3-wheel
Requires: python3-twine
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-pytest-random-order
Requires: python3-pytest-faulthandler
Requires: python3-pytest-timeout
Requires: python3-coverage
Requires: python3-scrapy
Requires: python3-beautifulsoup4
Requires: python3-requests
%description
Mu is a simple code editor for beginner programmers based on extensive feedback
from teachers and learners. Having said that, Mu is for anyone who wants to use
a simple "no frills" editor.
Mu is a modal editor with modes for many different ways to use Python to create
cool and interesting things.
Mu is written in Python and works on Windows, macOS, Linux and Raspberry Pi.
The project's public facing website is
`https://codewith.mu/ `_. We celebrate the work done by
users of mu at `https://madewith.mu/ `_.
We have `extensive developer documentation `_
including a guide for
`setting up a development environment `_,
`contributor guidelines `_ and
`some suggested first steps `_.
We want our community to be a friendly place. Therefore, we expect contributors
and collaborators to follow our
`Code of Conduct `_.
%package -n python3-mu-editor
Summary: A simple Python editor for beginner programmers.
Provides: python-mu-editor
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-mu-editor
Mu is a simple code editor for beginner programmers based on extensive feedback
from teachers and learners. Having said that, Mu is for anyone who wants to use
a simple "no frills" editor.
Mu is a modal editor with modes for many different ways to use Python to create
cool and interesting things.
Mu is written in Python and works on Windows, macOS, Linux and Raspberry Pi.
The project's public facing website is
`https://codewith.mu/ `_. We celebrate the work done by
users of mu at `https://madewith.mu/ `_.
We have `extensive developer documentation `_
including a guide for
`setting up a development environment `_,
`contributor guidelines `_ and
`some suggested first steps `_.
We want our community to be a friendly place. Therefore, we expect contributors
and collaborators to follow our
`Code of Conduct `_.
%package help
Summary: Development documents and examples for mu-editor
Provides: python3-mu-editor-doc
%description help
Mu is a simple code editor for beginner programmers based on extensive feedback
from teachers and learners. Having said that, Mu is for anyone who wants to use
a simple "no frills" editor.
Mu is a modal editor with modes for many different ways to use Python to create
cool and interesting things.
Mu is written in Python and works on Windows, macOS, Linux and Raspberry Pi.
The project's public facing website is
`https://codewith.mu/ `_. We celebrate the work done by
users of mu at `https://madewith.mu/ `_.
We have `extensive developer documentation `_
including a guide for
`setting up a development environment `_,
`contributor guidelines `_ and
`some suggested first steps `_.
We want our community to be a friendly place. Therefore, we expect contributors
and collaborators to follow our
`Code of Conduct `_.
%prep
%autosetup -n mu-editor-1.2.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-mu-editor -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 1.2.0-1
- Package Spec generated