%global _empty_manifest_terminate_build 0
Name: python-mkdocs-exclude-search
Version: 0.6.5
Release: 1
Summary: A mkdocs plugin that lets you exclude selected files or sections from the search index.
License: MIT
URL: https://github.com/chrieke/mkdocs-exclude-search
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b3/aa/e5c69fa5161e5df38e6f5cfe779a7db350b8e7e5369ccf799dc7a4eb5253/mkdocs-exclude-search-0.6.5.tar.gz
BuildArch: noarch
Requires: python3-mkdocs
%description
# mkdocs-exclude-search
A mkdocs plugin that lets you exclude selected files or sections from the search index.
If you only need to exclude a few pages or sections, mkdocs-material now introduced
[built-in search exclusion](https://squidfunk.github.io/mkdocs-material/setup/setting-up-site-search/#search-exclusion)!
The **mkdocs-exclude-search** plugin
[complements](https://squidfunk.github.io/mkdocs-material/blog/2021/09/26/excluding-content-from-search/#whats-new)
this with more configuration options (wildcard exclusions, ignoring excluded subsections). It also provides
search-exclusion functionality to regular mkdocs users.
## Setup
Install the plugin using pip:
```bash
pip install mkdocs-exclude-search
```
**Activate the `search` and `exclude-search` plugins in `mkdocs.yml`**. `search` is required, otherwise
`exclude-search` has no effect!
```yaml
plugins:
- search
- exclude-search
```
More information about plugins in the [MkDocs documentation][mkdocs-plugins].
## Configuration
- List the markdown files to be excluded under `exclude` using the format `//filename.md` in the docs folder.
- Exclude specific heading subsections using the format `//filename.md#some-heading`. Chapter names are all lowercase, `-` as separator, no spaces.
- Exclude all markdown files within a directory (and its children) with `dirname/*`.
- Exclude all markdown files with a specific name within all subdirectories with `dirname/*/filename.md` or `/*/filename.md`.
- To still include a subsection of an excluded file, list the subsection heading under `ignore` using the format `//filename.md#some-heading`.
- To exclude all unreferenced files (markdown files not listed in mkdocs.yml nav section), use `exclude_unreferenced: true`. Default false.
```yaml
plugins:
- search
- exclude-search:
exclude:
- first.md
- dir/second.md
- third.md#some-heading
- dir2/*
- /*/fifth.md
ignore:
- dir/second.md#some-heading
exclude_unreferenced: true
```
```yaml
nav:
- Home: index.md
- First chapter: first.md
- Second chapter: dir/second.md
- Third chapter: third.md
- Fourth chapter: dir2/fourth.md
- Fifth chapter: subdir/fifth.md
```
This example would exclude:
- the first chapter.
- the second chapter (but still include its `some-heading` section).
- the `some-heading` section of the third chapter.
- all markdown files within `dir2` (and its children directories).
- all markdown files named `fifth.md` within all subdirectories.
- all unreferenced files
## See Also
More information about templates [here][mkdocs-template].
More information about blocks [here][mkdocs-block].
[mkdocs-plugins]: http://www.mkdocs.org/user-guide/plugins/
[mkdocs-template]: https://www.mkdocs.org/user-guide/custom-themes/#template-variables
[mkdocs-block]: https://www.mkdocs.org/user-guide/styling-your-docs/#overriding-template-blocks
%package -n python3-mkdocs-exclude-search
Summary: A mkdocs plugin that lets you exclude selected files or sections from the search index.
Provides: python-mkdocs-exclude-search
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-mkdocs-exclude-search
# mkdocs-exclude-search
A mkdocs plugin that lets you exclude selected files or sections from the search index.
If you only need to exclude a few pages or sections, mkdocs-material now introduced
[built-in search exclusion](https://squidfunk.github.io/mkdocs-material/setup/setting-up-site-search/#search-exclusion)!
The **mkdocs-exclude-search** plugin
[complements](https://squidfunk.github.io/mkdocs-material/blog/2021/09/26/excluding-content-from-search/#whats-new)
this with more configuration options (wildcard exclusions, ignoring excluded subsections). It also provides
search-exclusion functionality to regular mkdocs users.
## Setup
Install the plugin using pip:
```bash
pip install mkdocs-exclude-search
```
**Activate the `search` and `exclude-search` plugins in `mkdocs.yml`**. `search` is required, otherwise
`exclude-search` has no effect!
```yaml
plugins:
- search
- exclude-search
```
More information about plugins in the [MkDocs documentation][mkdocs-plugins].
## Configuration
- List the markdown files to be excluded under `exclude` using the format `//filename.md` in the docs folder.
- Exclude specific heading subsections using the format `//filename.md#some-heading`. Chapter names are all lowercase, `-` as separator, no spaces.
- Exclude all markdown files within a directory (and its children) with `dirname/*`.
- Exclude all markdown files with a specific name within all subdirectories with `dirname/*/filename.md` or `/*/filename.md`.
- To still include a subsection of an excluded file, list the subsection heading under `ignore` using the format `//filename.md#some-heading`.
- To exclude all unreferenced files (markdown files not listed in mkdocs.yml nav section), use `exclude_unreferenced: true`. Default false.
```yaml
plugins:
- search
- exclude-search:
exclude:
- first.md
- dir/second.md
- third.md#some-heading
- dir2/*
- /*/fifth.md
ignore:
- dir/second.md#some-heading
exclude_unreferenced: true
```
```yaml
nav:
- Home: index.md
- First chapter: first.md
- Second chapter: dir/second.md
- Third chapter: third.md
- Fourth chapter: dir2/fourth.md
- Fifth chapter: subdir/fifth.md
```
This example would exclude:
- the first chapter.
- the second chapter (but still include its `some-heading` section).
- the `some-heading` section of the third chapter.
- all markdown files within `dir2` (and its children directories).
- all markdown files named `fifth.md` within all subdirectories.
- all unreferenced files
## See Also
More information about templates [here][mkdocs-template].
More information about blocks [here][mkdocs-block].
[mkdocs-plugins]: http://www.mkdocs.org/user-guide/plugins/
[mkdocs-template]: https://www.mkdocs.org/user-guide/custom-themes/#template-variables
[mkdocs-block]: https://www.mkdocs.org/user-guide/styling-your-docs/#overriding-template-blocks
%package help
Summary: Development documents and examples for mkdocs-exclude-search
Provides: python3-mkdocs-exclude-search-doc
%description help
# mkdocs-exclude-search
A mkdocs plugin that lets you exclude selected files or sections from the search index.
If you only need to exclude a few pages or sections, mkdocs-material now introduced
[built-in search exclusion](https://squidfunk.github.io/mkdocs-material/setup/setting-up-site-search/#search-exclusion)!
The **mkdocs-exclude-search** plugin
[complements](https://squidfunk.github.io/mkdocs-material/blog/2021/09/26/excluding-content-from-search/#whats-new)
this with more configuration options (wildcard exclusions, ignoring excluded subsections). It also provides
search-exclusion functionality to regular mkdocs users.
## Setup
Install the plugin using pip:
```bash
pip install mkdocs-exclude-search
```
**Activate the `search` and `exclude-search` plugins in `mkdocs.yml`**. `search` is required, otherwise
`exclude-search` has no effect!
```yaml
plugins:
- search
- exclude-search
```
More information about plugins in the [MkDocs documentation][mkdocs-plugins].
## Configuration
- List the markdown files to be excluded under `exclude` using the format `//filename.md` in the docs folder.
- Exclude specific heading subsections using the format `//filename.md#some-heading`. Chapter names are all lowercase, `-` as separator, no spaces.
- Exclude all markdown files within a directory (and its children) with `dirname/*`.
- Exclude all markdown files with a specific name within all subdirectories with `dirname/*/filename.md` or `/*/filename.md`.
- To still include a subsection of an excluded file, list the subsection heading under `ignore` using the format `//filename.md#some-heading`.
- To exclude all unreferenced files (markdown files not listed in mkdocs.yml nav section), use `exclude_unreferenced: true`. Default false.
```yaml
plugins:
- search
- exclude-search:
exclude:
- first.md
- dir/second.md
- third.md#some-heading
- dir2/*
- /*/fifth.md
ignore:
- dir/second.md#some-heading
exclude_unreferenced: true
```
```yaml
nav:
- Home: index.md
- First chapter: first.md
- Second chapter: dir/second.md
- Third chapter: third.md
- Fourth chapter: dir2/fourth.md
- Fifth chapter: subdir/fifth.md
```
This example would exclude:
- the first chapter.
- the second chapter (but still include its `some-heading` section).
- the `some-heading` section of the third chapter.
- all markdown files within `dir2` (and its children directories).
- all markdown files named `fifth.md` within all subdirectories.
- all unreferenced files
## See Also
More information about templates [here][mkdocs-template].
More information about blocks [here][mkdocs-block].
[mkdocs-plugins]: http://www.mkdocs.org/user-guide/plugins/
[mkdocs-template]: https://www.mkdocs.org/user-guide/custom-themes/#template-variables
[mkdocs-block]: https://www.mkdocs.org/user-guide/styling-your-docs/#overriding-template-blocks
%prep
%autosetup -n mkdocs-exclude-search-0.6.5
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-mkdocs-exclude-search -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 0.6.5-1
- Package Spec generated