%global _empty_manifest_terminate_build 0
Name: python-igramscraper
Version: 0.3.5
Release: 1
Summary: scrapes medias, likes, followers, tags and all metadata
License: MIT
URL: https://github.com/realsirjoe/instagram-scraper
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/1c/ef/f86b3ed24902305a0b4d318ecc78b86c168fc4979814fd31ce8dfa6278cc/igramscraper-0.3.5.tar.gz
BuildArch: noarch
%description
# instagram_scraper
This is a minimalistic Instagram scraper written in Python.
It can fetch media, accounts, videos, comments etc.
`Comment` and `Like` actions are also supported.
It is not easy to get Applications approved for Instagram's API therefore I created this tool inspired by [instagram-php-scraper](https://github.com/postaddictme/instagram-php-scraper).
The goal of this project is to become as minimalistic as possible while still having all the needed functionality so that its easy to add code to it!
Any ⭐️ or contribution is appreciated if you like the project 🤘
## How to install
Simply run:
```
pip install igramscraper
```
or download the project via git clone and run the following:
```
pip install -r requirements.txt
```
## Usages
Some methods do require authentication:
```python
from igramscraper.instagram import Instagram
instagram = Instagram()
# authentication supported
instagram.with_credentials('username', 'password')
instagram.login()
#Getting an account by id
account = instagram.get_account_by_id(3)
# Available fields
print('Account info:')
print('Id: ', account.identifier)
print('Username: ', account.username)
print('Full name: ', account.full_name)
print('Biography: ', account.biography)
print('Profile pic url: ', account.get_profile_pic_url_hd())
print('External Url: ', account.external_url)
print('Number of published posts: ', account.media_count)
print('Number of followers: ', account.followed_by_count)
print('Number of follows: ', account.follows_count)
print('Is private: ', account.is_private)
print('Is verified: ', account.is_verified)
# or simply for printing use
print(account)
```
If you use authentication, the program will cache the user session by default so one doesn't need to create session every time.
If one want to disable the user session cache, assign `True` to Instagram.login() method
Two Factor Authentication is also supported through cli interface, simply use 'True' for second argument of login() function
Many of the methods do not require authentication
for more info browse through the examples folder
Using proxy for requests:
```python
from igramscraper.instagram import Instagram
proxies = {
'http': 'http://123.45.67.8:1087',
'https': 'http://123.45.67.8:1087',
}
instagram = Instagram()
instagram.set_proxies(proxies)
account = instagram.get_account('kevin')
print(account.identifier)
```
## Recommended Limits
If you make too many requests too fast you will get a 429 Error or something similar.
- It is recommended to make a short break between each request of 30s (+- random)
- In between all 10 requests a long break (300-600s)
If different proxies and accounts are used for all requests and the circle doesn't repeat too fast these limits don't apply ;)
Feel free to make your own tests and let us know of any limits you experienced
## More usages
See examples [here](https://github.com/SergioWagenleitner/instagram-scraper/tree/master/examples).
## How to contribute
Every contribution is welcome, check out our [TODOs](https://github.com/realsirjoe/instagram-scraper/blob/master/CONTRIBUTING.md)
and join our telegram group: https://t.me/joinchat/J86yTBAtZlEi-6T6LOxijw
## Other
instagram-php-scraper [here](https://github.com/postaddictme/instagram-php-scraper/)
%package -n python3-igramscraper
Summary: scrapes medias, likes, followers, tags and all metadata
Provides: python-igramscraper
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-igramscraper
# instagram_scraper
This is a minimalistic Instagram scraper written in Python.
It can fetch media, accounts, videos, comments etc.
`Comment` and `Like` actions are also supported.
It is not easy to get Applications approved for Instagram's API therefore I created this tool inspired by [instagram-php-scraper](https://github.com/postaddictme/instagram-php-scraper).
The goal of this project is to become as minimalistic as possible while still having all the needed functionality so that its easy to add code to it!
Any ⭐️ or contribution is appreciated if you like the project 🤘
## How to install
Simply run:
```
pip install igramscraper
```
or download the project via git clone and run the following:
```
pip install -r requirements.txt
```
## Usages
Some methods do require authentication:
```python
from igramscraper.instagram import Instagram
instagram = Instagram()
# authentication supported
instagram.with_credentials('username', 'password')
instagram.login()
#Getting an account by id
account = instagram.get_account_by_id(3)
# Available fields
print('Account info:')
print('Id: ', account.identifier)
print('Username: ', account.username)
print('Full name: ', account.full_name)
print('Biography: ', account.biography)
print('Profile pic url: ', account.get_profile_pic_url_hd())
print('External Url: ', account.external_url)
print('Number of published posts: ', account.media_count)
print('Number of followers: ', account.followed_by_count)
print('Number of follows: ', account.follows_count)
print('Is private: ', account.is_private)
print('Is verified: ', account.is_verified)
# or simply for printing use
print(account)
```
If you use authentication, the program will cache the user session by default so one doesn't need to create session every time.
If one want to disable the user session cache, assign `True` to Instagram.login() method
Two Factor Authentication is also supported through cli interface, simply use 'True' for second argument of login() function
Many of the methods do not require authentication
for more info browse through the examples folder
Using proxy for requests:
```python
from igramscraper.instagram import Instagram
proxies = {
'http': 'http://123.45.67.8:1087',
'https': 'http://123.45.67.8:1087',
}
instagram = Instagram()
instagram.set_proxies(proxies)
account = instagram.get_account('kevin')
print(account.identifier)
```
## Recommended Limits
If you make too many requests too fast you will get a 429 Error or something similar.
- It is recommended to make a short break between each request of 30s (+- random)
- In between all 10 requests a long break (300-600s)
If different proxies and accounts are used for all requests and the circle doesn't repeat too fast these limits don't apply ;)
Feel free to make your own tests and let us know of any limits you experienced
## More usages
See examples [here](https://github.com/SergioWagenleitner/instagram-scraper/tree/master/examples).
## How to contribute
Every contribution is welcome, check out our [TODOs](https://github.com/realsirjoe/instagram-scraper/blob/master/CONTRIBUTING.md)
and join our telegram group: https://t.me/joinchat/J86yTBAtZlEi-6T6LOxijw
## Other
instagram-php-scraper [here](https://github.com/postaddictme/instagram-php-scraper/)
%package help
Summary: Development documents and examples for igramscraper
Provides: python3-igramscraper-doc
%description help
# instagram_scraper
This is a minimalistic Instagram scraper written in Python.
It can fetch media, accounts, videos, comments etc.
`Comment` and `Like` actions are also supported.
It is not easy to get Applications approved for Instagram's API therefore I created this tool inspired by [instagram-php-scraper](https://github.com/postaddictme/instagram-php-scraper).
The goal of this project is to become as minimalistic as possible while still having all the needed functionality so that its easy to add code to it!
Any ⭐️ or contribution is appreciated if you like the project 🤘
## How to install
Simply run:
```
pip install igramscraper
```
or download the project via git clone and run the following:
```
pip install -r requirements.txt
```
## Usages
Some methods do require authentication:
```python
from igramscraper.instagram import Instagram
instagram = Instagram()
# authentication supported
instagram.with_credentials('username', 'password')
instagram.login()
#Getting an account by id
account = instagram.get_account_by_id(3)
# Available fields
print('Account info:')
print('Id: ', account.identifier)
print('Username: ', account.username)
print('Full name: ', account.full_name)
print('Biography: ', account.biography)
print('Profile pic url: ', account.get_profile_pic_url_hd())
print('External Url: ', account.external_url)
print('Number of published posts: ', account.media_count)
print('Number of followers: ', account.followed_by_count)
print('Number of follows: ', account.follows_count)
print('Is private: ', account.is_private)
print('Is verified: ', account.is_verified)
# or simply for printing use
print(account)
```
If you use authentication, the program will cache the user session by default so one doesn't need to create session every time.
If one want to disable the user session cache, assign `True` to Instagram.login() method
Two Factor Authentication is also supported through cli interface, simply use 'True' for second argument of login() function
Many of the methods do not require authentication
for more info browse through the examples folder
Using proxy for requests:
```python
from igramscraper.instagram import Instagram
proxies = {
'http': 'http://123.45.67.8:1087',
'https': 'http://123.45.67.8:1087',
}
instagram = Instagram()
instagram.set_proxies(proxies)
account = instagram.get_account('kevin')
print(account.identifier)
```
## Recommended Limits
If you make too many requests too fast you will get a 429 Error or something similar.
- It is recommended to make a short break between each request of 30s (+- random)
- In between all 10 requests a long break (300-600s)
If different proxies and accounts are used for all requests and the circle doesn't repeat too fast these limits don't apply ;)
Feel free to make your own tests and let us know of any limits you experienced
## More usages
See examples [here](https://github.com/SergioWagenleitner/instagram-scraper/tree/master/examples).
## How to contribute
Every contribution is welcome, check out our [TODOs](https://github.com/realsirjoe/instagram-scraper/blob/master/CONTRIBUTING.md)
and join our telegram group: https://t.me/joinchat/J86yTBAtZlEi-6T6LOxijw
## Other
instagram-php-scraper [here](https://github.com/postaddictme/instagram-php-scraper/)
%prep
%autosetup -n igramscraper-0.3.5
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-igramscraper -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 0.3.5-1
- Package Spec generated