%global _empty_manifest_terminate_build 0
Name: python-alice-onboarding
Version: 1.13.0
Release: 1
Summary: Alice Onboarding Python SDK
License: Alice Copyright
URL: https://github.com/alice-biometrics/onboarding-python
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b8/f8/a2f2a27d4983d70c0b32f7d5f9c9951cf648e7b14498d3af437d189f9d40/alice-onboarding-1.13.0.tar.gz
BuildArch: noarch
Requires: python3-pyjwt
Requires: python3-pydantic
Requires: python3-requests
Requires: python3-meiga
%description
# onboarding-python
[![version](https://img.shields.io/github/release/alice-biometrics/onboarding-python/all.svg)](https://github.com/alice-biometrics/onboarding-python/releases) [![doc](https://img.shields.io/badge/doc-onboarding-51CB56)](https://docs.alicebiometrics.com/onboarding/sections/server/server_side_sdks/python.html)
The aim of this Python package is to manage the authentication and backend operations against Alice Onboarding API.
If you want more information about how to integrate with Alice technology, please contact us at support@alicebiometrics.com.
## Requirements
Python 3.7+
## Installation :computer:
```console
pip install alice-onboarding
```
## Getting Started 📈
#### Config
Configure your credentials with *Config* class
```
from alice import Config
config = Config(api_key=given_valid_api_key)
```
#### Onboarding
To manage the operations with Alice Onboarding API, use *Onboarding* class.
This class deals with authentication automatically.
```console
export ONBOARDING_API_KEY=""
python examples/onboarding.py
```
see onboarding example [here](examples/onboarding.py)
## Authentication 🔐
To manage authorization and token creations, use *Auth* class.
Available tokens:
| Type Token | Info |
| ----------------------- |:-------------:|
| BACKEND_TOKEN | Used to secure global requests.|
| BACKEND_TOKEN_WITH_USER | Used to secure global requests include user_id information embedded |
| USER_TOKEN | Used to secure requests made by the users on their mobile devices or web clients.|
To create a BACKEND_TOKEN_WITH_USER and a USER_TOKEN you will need a valid user_id obtained from Alice Onboarding API.
```console
export ONBOARDING_API_KEY=""
python examples/auth.py
```
see auth example [here](examples/auth.py)
#### Sandbox (Only for early stages of integration)
To manage the operations with the Sandbox API, use *Sandbox* class.
```console
export ONBOARDING_SANDBOX_TOKEN=""
python examples/sandbox.py
```
see sandbox example [here](examples/sandbox.py)
## Advanced features 🎩
⚠️ These features could not be available by default. If you obtain a HTTP Error (405 method not allowed). Please, contact us to make them available for your credentials.
#### Certified Onboarding
If you need certify your user data, you can retrieve a certified Pdf Report with these feature.
```console
export ONBOARDING_API_KEY=""
python examples/onboarding_with_certificate.py
```
see certified onboarding usage [here](examples/onboarding_with_certificate.py)
#### User Screening
Alice Onboarding API bring us the opportunity of screening a user over different databases & lists (sanctions, PEP, etc)..
```console
export ONBOARDING_API_KEY=""
python examples/onboarding_with_screening.py
```
see screening onboarding usage [here](examples/onboarding_with_screening.py)
#### Webhooks
Configure your webhooks through the api with the `Webhooks` object.
```console
export ONBOARDING_API_KEY=""
python examples/onboarding_with_webhooks.py
```
see onboarding webhooks usage [here](examples/onboarding_with_webhooks.py)
Note: You can configure your webhooks using the Onboarding dashboard.
## Documentation 📄
For more information about Alice Onboarding: https://docs.alicebiometrics.com/onboarding/
## Contact 📬
support@alicebiometrics.com
%package -n python3-alice-onboarding
Summary: Alice Onboarding Python SDK
Provides: python-alice-onboarding
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-alice-onboarding
# onboarding-python
[![version](https://img.shields.io/github/release/alice-biometrics/onboarding-python/all.svg)](https://github.com/alice-biometrics/onboarding-python/releases) [![doc](https://img.shields.io/badge/doc-onboarding-51CB56)](https://docs.alicebiometrics.com/onboarding/sections/server/server_side_sdks/python.html)
The aim of this Python package is to manage the authentication and backend operations against Alice Onboarding API.
If you want more information about how to integrate with Alice technology, please contact us at support@alicebiometrics.com.
## Requirements
Python 3.7+
## Installation :computer:
```console
pip install alice-onboarding
```
## Getting Started 📈
#### Config
Configure your credentials with *Config* class
```
from alice import Config
config = Config(api_key=given_valid_api_key)
```
#### Onboarding
To manage the operations with Alice Onboarding API, use *Onboarding* class.
This class deals with authentication automatically.
```console
export ONBOARDING_API_KEY=""
python examples/onboarding.py
```
see onboarding example [here](examples/onboarding.py)
## Authentication 🔐
To manage authorization and token creations, use *Auth* class.
Available tokens:
| Type Token | Info |
| ----------------------- |:-------------:|
| BACKEND_TOKEN | Used to secure global requests.|
| BACKEND_TOKEN_WITH_USER | Used to secure global requests include user_id information embedded |
| USER_TOKEN | Used to secure requests made by the users on their mobile devices or web clients.|
To create a BACKEND_TOKEN_WITH_USER and a USER_TOKEN you will need a valid user_id obtained from Alice Onboarding API.
```console
export ONBOARDING_API_KEY=""
python examples/auth.py
```
see auth example [here](examples/auth.py)
#### Sandbox (Only for early stages of integration)
To manage the operations with the Sandbox API, use *Sandbox* class.
```console
export ONBOARDING_SANDBOX_TOKEN=""
python examples/sandbox.py
```
see sandbox example [here](examples/sandbox.py)
## Advanced features 🎩
⚠️ These features could not be available by default. If you obtain a HTTP Error (405 method not allowed). Please, contact us to make them available for your credentials.
#### Certified Onboarding
If you need certify your user data, you can retrieve a certified Pdf Report with these feature.
```console
export ONBOARDING_API_KEY=""
python examples/onboarding_with_certificate.py
```
see certified onboarding usage [here](examples/onboarding_with_certificate.py)
#### User Screening
Alice Onboarding API bring us the opportunity of screening a user over different databases & lists (sanctions, PEP, etc)..
```console
export ONBOARDING_API_KEY=""
python examples/onboarding_with_screening.py
```
see screening onboarding usage [here](examples/onboarding_with_screening.py)
#### Webhooks
Configure your webhooks through the api with the `Webhooks` object.
```console
export ONBOARDING_API_KEY=""
python examples/onboarding_with_webhooks.py
```
see onboarding webhooks usage [here](examples/onboarding_with_webhooks.py)
Note: You can configure your webhooks using the Onboarding dashboard.
## Documentation 📄
For more information about Alice Onboarding: https://docs.alicebiometrics.com/onboarding/
## Contact 📬
support@alicebiometrics.com
%package help
Summary: Development documents and examples for alice-onboarding
Provides: python3-alice-onboarding-doc
%description help
# onboarding-python
[![version](https://img.shields.io/github/release/alice-biometrics/onboarding-python/all.svg)](https://github.com/alice-biometrics/onboarding-python/releases) [![doc](https://img.shields.io/badge/doc-onboarding-51CB56)](https://docs.alicebiometrics.com/onboarding/sections/server/server_side_sdks/python.html)
The aim of this Python package is to manage the authentication and backend operations against Alice Onboarding API.
If you want more information about how to integrate with Alice technology, please contact us at support@alicebiometrics.com.
## Requirements
Python 3.7+
## Installation :computer:
```console
pip install alice-onboarding
```
## Getting Started 📈
#### Config
Configure your credentials with *Config* class
```
from alice import Config
config = Config(api_key=given_valid_api_key)
```
#### Onboarding
To manage the operations with Alice Onboarding API, use *Onboarding* class.
This class deals with authentication automatically.
```console
export ONBOARDING_API_KEY=""
python examples/onboarding.py
```
see onboarding example [here](examples/onboarding.py)
## Authentication 🔐
To manage authorization and token creations, use *Auth* class.
Available tokens:
| Type Token | Info |
| ----------------------- |:-------------:|
| BACKEND_TOKEN | Used to secure global requests.|
| BACKEND_TOKEN_WITH_USER | Used to secure global requests include user_id information embedded |
| USER_TOKEN | Used to secure requests made by the users on their mobile devices or web clients.|
To create a BACKEND_TOKEN_WITH_USER and a USER_TOKEN you will need a valid user_id obtained from Alice Onboarding API.
```console
export ONBOARDING_API_KEY=""
python examples/auth.py
```
see auth example [here](examples/auth.py)
#### Sandbox (Only for early stages of integration)
To manage the operations with the Sandbox API, use *Sandbox* class.
```console
export ONBOARDING_SANDBOX_TOKEN=""
python examples/sandbox.py
```
see sandbox example [here](examples/sandbox.py)
## Advanced features 🎩
⚠️ These features could not be available by default. If you obtain a HTTP Error (405 method not allowed). Please, contact us to make them available for your credentials.
#### Certified Onboarding
If you need certify your user data, you can retrieve a certified Pdf Report with these feature.
```console
export ONBOARDING_API_KEY=""
python examples/onboarding_with_certificate.py
```
see certified onboarding usage [here](examples/onboarding_with_certificate.py)
#### User Screening
Alice Onboarding API bring us the opportunity of screening a user over different databases & lists (sanctions, PEP, etc)..
```console
export ONBOARDING_API_KEY=""
python examples/onboarding_with_screening.py
```
see screening onboarding usage [here](examples/onboarding_with_screening.py)
#### Webhooks
Configure your webhooks through the api with the `Webhooks` object.
```console
export ONBOARDING_API_KEY=""
python examples/onboarding_with_webhooks.py
```
see onboarding webhooks usage [here](examples/onboarding_with_webhooks.py)
Note: You can configure your webhooks using the Onboarding dashboard.
## Documentation 📄
For more information about Alice Onboarding: https://docs.alicebiometrics.com/onboarding/
## Contact 📬
support@alicebiometrics.com
%prep
%autosetup -n alice-onboarding-1.13.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-alice-onboarding -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 1.13.0-1
- Package Spec generated