%global _empty_manifest_terminate_build 0
Name: python-protonvpn-cli
Version: 2.2.11
Release: 1
Summary: Linux command-line client for ProtonVPN
License: GPLv3
URL: https://github.com/protonvpn/linux-cli-community
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/7d/f7/55844a152a8a08ff6acb62e6eb38c5df29eb8843927d1bdda0b752acbdf4/protonvpn_cli-2.2.11.tar.gz
BuildArch: noarch
Requires: python3-distro
Requires: python3-docopt
Requires: python3-jinja2
Requires: python3-pythondialog
Requires: python3-requests
%description
ProtonVPN-CLI
A Linux CLI for ProtonVPN. Written in Python.
ProtonVPN-CLI is a full rewrite of the [bash protonvpn-cli](https://github.com/ProtonVPN/protonvpn-cli/blob/master/protonvpn-cli.sh) in Python, which adds more features and functionality with the purpose of improving readability, speed and reliability.
## Important information
The [official ProtonVPN Linux](https://protonvpn.com/blog/protonvpn-linux-app/) app is available for Debian 10, Ubuntu 20+, Mint 19+, MX Linux 19+, Fedora 31+ and Archlinux / Manjaro. Where possible, we recommend that you [upgrade to the official app](https://protonvpn.com/support/linux-vpn-setup/).
The community Linux client described below remains available for those who need it.
## Installation & Updating
For more detailed information on installing, updating and uninstalling, please view the extensive [usage guide](https://github.com/ProtonVPN/linux-cli-community/blob/master/USAGE.md#installation--updating).
### Installing from distribution repositories
For the following Linux distribution(s), install the official `protonvpn-cli` package:
#### Fedora
```sh
sudo dnf install -y protonvpn-cli
```
#### CentOS & RHEL
`protonvpn-cli` is available for CentOS/RHEL 7.x and 8.x via the [EPEL repositories](https://fedoraproject.org/wiki/EPEL).
**For CentOS/RHEL 7.x**:
```sh
sudo yum install https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
sudo yum install protonvpn-cli
```
**For CentOS/RHEL 8.x**:
```sh
sudo dnf install https://dl.fedoraproject.org/pub/epel/epel-release-latest-8.noarch.rpm
sudo dnf install -y protonvpn-cli
```
### Installing from PyPI
#### Installing Dependencies
**Dependencies:**
- openvpn
- dialog (optional, needed for interactive selection)
- pip for python3 (pip3)
- python3.5+
- setuptools for python3 (python3-setuptools)
Depending on your distribution, run the appropriate following command to install the necessary dependencies
| **Distro** | **Command** |
|:----------------------------------------|:------------------------------------------------ |
|Fedora/CentOS/RHEL | `sudo dnf install -y openvpn dialog python3-pip python3-setuptools`|
|Ubuntu/Linux Mint/Debian and derivatives | `sudo apt install -y openvpn dialog python3-pip python3-setuptools`|
|OpenSUSE/SLES | `sudo zypper in -y openvpn dialog python3-pip python3-setuptools` |
|Arch Linux/Manjaro | `sudo pacman -S openvpn dialog python-pip python-setuptools` |
#### Installing ProtonVPN-CLI
Installation happens via Python's package manager PIP.
*Note: Make sure to run pip with sudo, so it installs globally and recognizes the command with sudo*
`sudo pip3 install protonvpn-cli`
#### Updating ProtonVPN-CLI
`sudo pip3 install protonvpn-cli --upgrade`
### Manual Installation from source
*Disclaimer: If you are unsure about what you're doing, please follow the [normal installation guide](https://github.com/ProtonVPN/linux-cli-community/blob/master/USAGE.md#installation--updating).*
It is recommended to do the manual installation in a virtual environment. Especially if it serves the purpose of developing.
1. Clone this repository
`git clone https://github.com/ProtonVPN/linux-cli-community`
2. Step into the directory
`cd linux-cli`
3. Install
`pip3 install -e .`
For updating, you just need to pull the latest version of the repository with git.
### How to use
#### For more detailed information, see the extensive [usage guide](https://github.com/ProtonVPN/linux-cli-community/blob/master/USAGE.md).
| **Command** | **Description** |
|:----------------------------------|:------------------------------------------------------|
|`protonvpn init` | Initialize ProtonVPN profile. |
|`protonvpn connect, c` | Select a ProtonVPN server and connect to it. |
|`protonvpn c [servername]` | Connect to a specified server. |
|`protonvpn c -r` | Connect to a random server. |
|`protonvpn c -f` | Connect to the fastest server. |
|`protonvpn c --p2p` | Connect to the fastest P2P server. |
|`protonvpn c --cc [countrycode]` | Connect to the fastest server in a specified country. |
|`protonvpn c --sc` | Connect to the fastest Secure Core server. |
|`protonvpn reconnect, r` | Reconnect or connect to the last server used. |
|`protonvpn disconnect, d` | Disconnect the current session. |
|`protonvpn status, s` | Print connection status. |
|`protonvpn configure` | Change CLI configuration. |
|`protonvpn refresh` | Refresh OpenVPN configuration and server data. |
|`protonvpn examples` | Print example commands. |
|`protonvpn --version` | Display version. |
|`protonvpn --help` | Show help message. |
All connect options can be used with the `-p` flag to explicitly specify which transmission protocol is used for that connection (either `udp` or `tcp`).
## Contributing
If you want to contribute to this project, please read the [contribution guide](https://github.com/ProtonVPN/linux-cli-community/blob/master/CONTRIBUTING.md).
%package -n python3-protonvpn-cli
Summary: Linux command-line client for ProtonVPN
Provides: python-protonvpn-cli
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-protonvpn-cli
ProtonVPN-CLI
A Linux CLI for ProtonVPN. Written in Python.
ProtonVPN-CLI is a full rewrite of the [bash protonvpn-cli](https://github.com/ProtonVPN/protonvpn-cli/blob/master/protonvpn-cli.sh) in Python, which adds more features and functionality with the purpose of improving readability, speed and reliability.
## Important information
The [official ProtonVPN Linux](https://protonvpn.com/blog/protonvpn-linux-app/) app is available for Debian 10, Ubuntu 20+, Mint 19+, MX Linux 19+, Fedora 31+ and Archlinux / Manjaro. Where possible, we recommend that you [upgrade to the official app](https://protonvpn.com/support/linux-vpn-setup/).
The community Linux client described below remains available for those who need it.
## Installation & Updating
For more detailed information on installing, updating and uninstalling, please view the extensive [usage guide](https://github.com/ProtonVPN/linux-cli-community/blob/master/USAGE.md#installation--updating).
### Installing from distribution repositories
For the following Linux distribution(s), install the official `protonvpn-cli` package:
#### Fedora
```sh
sudo dnf install -y protonvpn-cli
```
#### CentOS & RHEL
`protonvpn-cli` is available for CentOS/RHEL 7.x and 8.x via the [EPEL repositories](https://fedoraproject.org/wiki/EPEL).
**For CentOS/RHEL 7.x**:
```sh
sudo yum install https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
sudo yum install protonvpn-cli
```
**For CentOS/RHEL 8.x**:
```sh
sudo dnf install https://dl.fedoraproject.org/pub/epel/epel-release-latest-8.noarch.rpm
sudo dnf install -y protonvpn-cli
```
### Installing from PyPI
#### Installing Dependencies
**Dependencies:**
- openvpn
- dialog (optional, needed for interactive selection)
- pip for python3 (pip3)
- python3.5+
- setuptools for python3 (python3-setuptools)
Depending on your distribution, run the appropriate following command to install the necessary dependencies
| **Distro** | **Command** |
|:----------------------------------------|:------------------------------------------------ |
|Fedora/CentOS/RHEL | `sudo dnf install -y openvpn dialog python3-pip python3-setuptools`|
|Ubuntu/Linux Mint/Debian and derivatives | `sudo apt install -y openvpn dialog python3-pip python3-setuptools`|
|OpenSUSE/SLES | `sudo zypper in -y openvpn dialog python3-pip python3-setuptools` |
|Arch Linux/Manjaro | `sudo pacman -S openvpn dialog python-pip python-setuptools` |
#### Installing ProtonVPN-CLI
Installation happens via Python's package manager PIP.
*Note: Make sure to run pip with sudo, so it installs globally and recognizes the command with sudo*
`sudo pip3 install protonvpn-cli`
#### Updating ProtonVPN-CLI
`sudo pip3 install protonvpn-cli --upgrade`
### Manual Installation from source
*Disclaimer: If you are unsure about what you're doing, please follow the [normal installation guide](https://github.com/ProtonVPN/linux-cli-community/blob/master/USAGE.md#installation--updating).*
It is recommended to do the manual installation in a virtual environment. Especially if it serves the purpose of developing.
1. Clone this repository
`git clone https://github.com/ProtonVPN/linux-cli-community`
2. Step into the directory
`cd linux-cli`
3. Install
`pip3 install -e .`
For updating, you just need to pull the latest version of the repository with git.
### How to use
#### For more detailed information, see the extensive [usage guide](https://github.com/ProtonVPN/linux-cli-community/blob/master/USAGE.md).
| **Command** | **Description** |
|:----------------------------------|:------------------------------------------------------|
|`protonvpn init` | Initialize ProtonVPN profile. |
|`protonvpn connect, c` | Select a ProtonVPN server and connect to it. |
|`protonvpn c [servername]` | Connect to a specified server. |
|`protonvpn c -r` | Connect to a random server. |
|`protonvpn c -f` | Connect to the fastest server. |
|`protonvpn c --p2p` | Connect to the fastest P2P server. |
|`protonvpn c --cc [countrycode]` | Connect to the fastest server in a specified country. |
|`protonvpn c --sc` | Connect to the fastest Secure Core server. |
|`protonvpn reconnect, r` | Reconnect or connect to the last server used. |
|`protonvpn disconnect, d` | Disconnect the current session. |
|`protonvpn status, s` | Print connection status. |
|`protonvpn configure` | Change CLI configuration. |
|`protonvpn refresh` | Refresh OpenVPN configuration and server data. |
|`protonvpn examples` | Print example commands. |
|`protonvpn --version` | Display version. |
|`protonvpn --help` | Show help message. |
All connect options can be used with the `-p` flag to explicitly specify which transmission protocol is used for that connection (either `udp` or `tcp`).
## Contributing
If you want to contribute to this project, please read the [contribution guide](https://github.com/ProtonVPN/linux-cli-community/blob/master/CONTRIBUTING.md).
%package help
Summary: Development documents and examples for protonvpn-cli
Provides: python3-protonvpn-cli-doc
%description help
ProtonVPN-CLI
A Linux CLI for ProtonVPN. Written in Python.
ProtonVPN-CLI is a full rewrite of the [bash protonvpn-cli](https://github.com/ProtonVPN/protonvpn-cli/blob/master/protonvpn-cli.sh) in Python, which adds more features and functionality with the purpose of improving readability, speed and reliability.
## Important information
The [official ProtonVPN Linux](https://protonvpn.com/blog/protonvpn-linux-app/) app is available for Debian 10, Ubuntu 20+, Mint 19+, MX Linux 19+, Fedora 31+ and Archlinux / Manjaro. Where possible, we recommend that you [upgrade to the official app](https://protonvpn.com/support/linux-vpn-setup/).
The community Linux client described below remains available for those who need it.
## Installation & Updating
For more detailed information on installing, updating and uninstalling, please view the extensive [usage guide](https://github.com/ProtonVPN/linux-cli-community/blob/master/USAGE.md#installation--updating).
### Installing from distribution repositories
For the following Linux distribution(s), install the official `protonvpn-cli` package:
#### Fedora
```sh
sudo dnf install -y protonvpn-cli
```
#### CentOS & RHEL
`protonvpn-cli` is available for CentOS/RHEL 7.x and 8.x via the [EPEL repositories](https://fedoraproject.org/wiki/EPEL).
**For CentOS/RHEL 7.x**:
```sh
sudo yum install https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
sudo yum install protonvpn-cli
```
**For CentOS/RHEL 8.x**:
```sh
sudo dnf install https://dl.fedoraproject.org/pub/epel/epel-release-latest-8.noarch.rpm
sudo dnf install -y protonvpn-cli
```
### Installing from PyPI
#### Installing Dependencies
**Dependencies:**
- openvpn
- dialog (optional, needed for interactive selection)
- pip for python3 (pip3)
- python3.5+
- setuptools for python3 (python3-setuptools)
Depending on your distribution, run the appropriate following command to install the necessary dependencies
| **Distro** | **Command** |
|:----------------------------------------|:------------------------------------------------ |
|Fedora/CentOS/RHEL | `sudo dnf install -y openvpn dialog python3-pip python3-setuptools`|
|Ubuntu/Linux Mint/Debian and derivatives | `sudo apt install -y openvpn dialog python3-pip python3-setuptools`|
|OpenSUSE/SLES | `sudo zypper in -y openvpn dialog python3-pip python3-setuptools` |
|Arch Linux/Manjaro | `sudo pacman -S openvpn dialog python-pip python-setuptools` |
#### Installing ProtonVPN-CLI
Installation happens via Python's package manager PIP.
*Note: Make sure to run pip with sudo, so it installs globally and recognizes the command with sudo*
`sudo pip3 install protonvpn-cli`
#### Updating ProtonVPN-CLI
`sudo pip3 install protonvpn-cli --upgrade`
### Manual Installation from source
*Disclaimer: If you are unsure about what you're doing, please follow the [normal installation guide](https://github.com/ProtonVPN/linux-cli-community/blob/master/USAGE.md#installation--updating).*
It is recommended to do the manual installation in a virtual environment. Especially if it serves the purpose of developing.
1. Clone this repository
`git clone https://github.com/ProtonVPN/linux-cli-community`
2. Step into the directory
`cd linux-cli`
3. Install
`pip3 install -e .`
For updating, you just need to pull the latest version of the repository with git.
### How to use
#### For more detailed information, see the extensive [usage guide](https://github.com/ProtonVPN/linux-cli-community/blob/master/USAGE.md).
| **Command** | **Description** |
|:----------------------------------|:------------------------------------------------------|
|`protonvpn init` | Initialize ProtonVPN profile. |
|`protonvpn connect, c` | Select a ProtonVPN server and connect to it. |
|`protonvpn c [servername]` | Connect to a specified server. |
|`protonvpn c -r` | Connect to a random server. |
|`protonvpn c -f` | Connect to the fastest server. |
|`protonvpn c --p2p` | Connect to the fastest P2P server. |
|`protonvpn c --cc [countrycode]` | Connect to the fastest server in a specified country. |
|`protonvpn c --sc` | Connect to the fastest Secure Core server. |
|`protonvpn reconnect, r` | Reconnect or connect to the last server used. |
|`protonvpn disconnect, d` | Disconnect the current session. |
|`protonvpn status, s` | Print connection status. |
|`protonvpn configure` | Change CLI configuration. |
|`protonvpn refresh` | Refresh OpenVPN configuration and server data. |
|`protonvpn examples` | Print example commands. |
|`protonvpn --version` | Display version. |
|`protonvpn --help` | Show help message. |
All connect options can be used with the `-p` flag to explicitly specify which transmission protocol is used for that connection (either `udp` or `tcp`).
## Contributing
If you want to contribute to this project, please read the [contribution guide](https://github.com/ProtonVPN/linux-cli-community/blob/master/CONTRIBUTING.md).
%prep
%autosetup -n protonvpn-cli-2.2.11
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-protonvpn-cli -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 2.2.11-1
- Package Spec generated